Advertisement:

Author Topic: Bad Behavior for SMF mod  (Read 280634 times)

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #960 on: June 30, 2017, 02:24:39 PM »
Do you have anything in the Whitelist settings of the mod?
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline BillLeeDee

  • Semi-Newbie
  • *
  • Posts: 91
Re: Bad Behavior for SMF mod
« Reply #961 on: July 01, 2017, 06:58:35 AM »
Do you have anything in the Whitelist settings of the mod?

There are a couple of dozen IP addresses and one user agent listed

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #962 on: July 02, 2017, 08:13:47 AM »
I suspect you have a extra blank in the User Agent field.  You most likely hit a carriage return after entering the value.  Please remove the carriage return.

Some of that image looks like a SQL Injection attack.  I suggest you install CrawlProtect.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline BillLeeDee

  • Semi-Newbie
  • *
  • Posts: 91
Re: Bad Behavior for SMF mod
« Reply #963 on: July 02, 2017, 10:41:13 AM »
@butchs: I checked the user agent I had slugged in and there wasn't any return character afterwards. Since it was only one I simply removed it.

Thanks for the recommendation of CrawlProtect as I wasn't aware of it. I had written a multitude of traps into my htaccess file but this looks like it might be a better solution. Thanks.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #964 on: August 18, 2017, 02:59:33 PM »
Helps are back in first post.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline siavoshkc

  • Semi-Newbie
  • *
  • Posts: 45
  • Gender: Male
Installing Bad Behavior for SMF mod on v2.0.14
« Reply #965 on: September 21, 2017, 10:27:38 AM »
How can I install this mod on my v2.0.14? I can't find it in the list shown by my forum. Do I have to use manual method?

By the way is this the right place to ask this question?
Persian Translator

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #966 on: September 24, 2017, 07:48:28 AM »
The mod should install with v2.0.14.  Not sure why you cannot see it.  Only install with the manual method if you have a custom theme.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #967 on: December 31, 2017, 09:34:40 PM »
This mod has been updated to the latest version of Bad Behavior, added Italian and bug fixes.  BB Changes:
  • A spurious PHP notice was removed. Fixes issue 121.
  • The current use of cookies to screen requests is being deprecated. Any cookies will be removed from users’ browsers, if they exist. Fixes issue 131.
  • A new IP address range is in use by the Bing search engine; this range has been added to Bad Behavior.

See the first post for more info...
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline doughboy99

  • Semi-Newbie
  • *
  • Posts: 98
Re: Bad Behavior for SMF mod
« Reply #968 on: January 04, 2018, 06:55:17 AM »
Hello

When i install this version I get a plus symbol at the top of every page in the forum. Bad behaviour doesn't run on the site although I can acces the setup pages. Reverting to an earlier version works  correctly.
Any ideas what might be causing this.

Thanks

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #969 on: January 04, 2018, 08:04:11 AM »
There is nothing wrong.  That is a Project Honeypot Google Safe Spam trap.  Check out the link in the "RANDOM CHARACTERS ABOVE FORUM HEADER" FAQ in the first post of this thread.

Setting up a spam trap helps contribute to project honey pot and keeps your site safe.  Attached are some I caught.
« Last Edit: January 04, 2018, 08:21:24 AM by butchs »
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,361
    • Arantor on GitHub
Re: Bad Behavior for SMF mod
« Reply #970 on: January 04, 2018, 08:22:07 AM »
You caught a lot of CloudFlare IPs in that list, interesting.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,718
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Bad Behavior for SMF mod
« Reply #971 on: January 04, 2018, 08:35:58 AM »
They have to click on the link to get on the list.  I use CloudFlare but years ago I noticed that some people use it to spam and some try to bypass CF.   I have not seen much of the latter in years after they revamped their system.
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,361
    • Arantor on GitHub
Re: Bad Behavior for SMF mod
« Reply #972 on: January 04, 2018, 08:44:06 AM »
I was more noticing that the 172.68.7 range is owned by CloudFlare in Thailand for example, wasn't sure if this was skewing your findings or not.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline BillLeeDee

  • Semi-Newbie
  • *
  • Posts: 91
Re: Bad Behavior for SMF mod
« Reply #973 on: January 12, 2018, 08:29:13 PM »
I took a quick skim of the thread and might have missed it so please forgive me if this was already asked. Can the update be installed without removing the older version or do you need to remove the old version before installing the latest version?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,262
  • Gender: Male
    • Kindred-999 on GitHub
Re: Bad Behavior for SMF mod
« Reply #974 on: January 12, 2018, 10:35:42 PM »
As with almost every mod ...  uninstall the old version first. ;)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline BillLeeDee

  • Semi-Newbie
  • *
  • Posts: 91
Re: Bad Behavior for SMF mod
« Reply #975 on: January 13, 2018, 04:00:53 PM »
That's what I thought but wanted to be certain. Thanks.

Offline BillLeeDee

  • Semi-Newbie
  • *
  • Posts: 91
Re: Bad Behavior for SMF mod
« Reply #976 on: January 16, 2018, 06:01:38 PM »
Has anyone noticed an text oddity with the 1.5.20 version. I uninstalled the older 1.5.19 version and installed the new version and noticed various portions of my site had the text size increase from what is normally. After installing it showed up as "upgrade" install instead of uninstall, so I had to restore the SMF directory from my backup.

I don't know if it has anything to do with the other assorted mods installed in the forum so when I get some spare time to take the forums offline I plan on another clean install with the Bad Behavior mod being the first one to be installed.

Offline djkimmel

  • Semi-Newbie
  • *
  • Posts: 64
    • GreatLakesBass.com
Re: Bad Behavior for SMF mod
« Reply #977 on: January 17, 2018, 10:19:32 PM »
I had the same thing happen on several of my forums - the font size increased and messed up some of my layouts - primarily those with portals. I started thinking it might be a change in portal css but one of the forums the only change I made at the time was upgrading to Bad Behavior 1.5.20 and the fonts look supersized! I haven't had time yet to track down what it causing this.

Offline djkimmel

  • Semi-Newbie
  • *
  • Posts: 64
    • GreatLakesBass.com
Re: Bad Behavior for SMF mod
« Reply #978 on: January 18, 2018, 12:26:50 AM »
Okay, I found the problem with mod Bad Behavior version 1.5.20 modified 12/31/2017. In the mod file /Sources/bad-behavior/BadBehavior-SMF.php that is called for all Bad Behavior actions, there is an errant carriage return and '+' sign at the very end of that file.

Delete the carriage return and plus sign so the file ends properly with '?>' and my fonts are no longer magnified.

Offline djkimmel

  • Semi-Newbie
  • *
  • Posts: 64
    • GreatLakesBass.com
Re: Bad Behavior for SMF mod
« Reply #979 on: January 18, 2018, 12:42:14 AM »
Actually, looking at the 12/31/2017 modified date mod install package I do not see the '+' sign at the end? Only a line feed which should be removed anyway as I've always been told PHP doesn't like a blank line after the closing '?>' code. I didn't modify the install package but every install I did of Bad Behavior 1.5.20 has the carriage return and a plus sign at the end. However it is happening that is the problem with magnified fonts for my installs. Removing everything after the closing '?>' puts my fonts back to normal.