Advertisement:

Author Topic: Yabb 2.5AE to SMF Error...  (Read 23128 times)

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Yabb 2.5AE to SMF Error...
« on: October 10, 2011, 11:21:59 PM »
Hi all,

I am new here (first post).  I am wanting to move a couple of forums from Yabb 2.4 & 2.5AE to SMF and found an older converter.  I read up on it and also downloaded the additional file.  I also saw that some others (on this forum) have had success in converting 2.5AE to SMF.  When I ran the converter, this is the error I got:

Converting...
Successful.
Converting membergroups... Successful.
Converting members... Unsuccessful!
This query:
SELECT ID_GROUP, groupName
FROM `corners0_smf168`.smf_membergroups
WHERE ID_GROUP != 3;
Caused the error:
Unknown column 'groupName' in 'field list'

I am not proficient with code so I don't know what this means.  I understand that it found a column it didn't like in the field list, but apart from that, I don't know what to do with the information it is telling me nor do I know how to proceed in correcting it.  Any pointers or help in any way would be greatly appreciated. 

j razz

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #1 on: October 10, 2011, 11:49:47 PM »
I've found a membersgroups.pl in my yabb directory- I assume this is the same thing as membersgroups.txt (perhaps it converts it to .txt or just changes the file extension)?  When I open the file in notepad I cannot find groupName when doing a search in the file.  Maybe I'm on the wrong file but I couldn't find a membersgroups.txt.

j razz

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #2 on: October 11, 2011, 12:06:50 AM »
I also found this in the error log:

[10-Oct-2011 21:15:45] PHP Warning:  file(/home/corners0/public_html/cgi-bin/forum/Variables/membergroups.txt) [<a href='function.file'>function.file</a>]: failed to open stream: No such file or directory in /home/corners0/public_html/smf/yabb22_to_smf.php on line 150
[10-Oct-2011 21:15:45] PHP Warning:  Invalid argument supplied for foreach() in /home/corners0/public_html/smf/yabb22_to_smf.php on line 151

That led me to look in the Variables folder and as the error states, there is no such file there.  I am going to make a dummy file and call it by that name to see if it is actually needed or just fussing that the file is not there.

I'll report back.

j razz

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #3 on: October 11, 2011, 12:15:35 AM »
I tried a blank file as well as taking the file that ended in .pl, changing the extension and uploading it to the Variables directory.  Still no luck.

I am at a loss.  If anyone can help shed some light on this, it would be greatly appreciated.  Currently I am unable to log into my SMF forum (which is blank and not being used) because I told the converter to wipe out existing members... however, since SMF was installed via cpanel I believe I can just reinstall it without issue if need be.  Ideally though, I would like to import my members and log in using my login information from Yabb.

Thanks again for any help anyone can provide on this.

j razz

Offline Tonyvic

  • Jr. Member
  • **
  • Posts: 133
  • Gender: Male
Re: Yabb 2.5AE to SMF Error...
« Reply #4 on: October 11, 2011, 05:05:22 AM »
Are you using the route that IamTheBoy used?
Quote
YaBB 2.5AE > yabb 2.4-smf1 tool > smf1.1.4 > smf2 > fix boards and perms > smf2.0.1

I followed that & it worked reasonably well, it was only the attachments that caused a major headache. I removed that folder & converted again, it worked fine but I had to manually upload the attachments into posts in SMF 2.01.

I'm afraid I'm not good with code/errors, so can't help with yours.

Tony

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #5 on: October 11, 2011, 09:16:40 AM »
I didn't try that way.  I read the thread (I also read another one a little below that one where another guy said he converted from 2.5 and all seemed to go well) that detailed how he went about converting and I even looked into it.  However, I don't know how to revert my forum to 2.4.  If you have some instructions on that, I would greatly appreciate any help you can offer....

Or, if there is a way for me to correct the error I am getting above without having to jump through the hoops laid out by Iamtheboy, that would be even better!

j razz

Offline Tonyvic

  • Jr. Member
  • **
  • Posts: 133
  • Gender: Male
Re: Yabb 2.5AE to SMF Error...
« Reply #6 on: October 12, 2011, 06:40:46 AM »
I am new to SMF, PHP & MySQL, so I'm sorry but I can't help with errors.
I suggest you check on the http://www.yabbforum.com/community/ YaBB Community Forum regarding downgrading to 2.4.

Good luck! :)

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #7 on: October 13, 2011, 11:58:28 AM »
For anyone following this thread- here is the response I got on Yabb's forum:


LOL - I'm with you, I liked 2.4 just fine (I have 3 of them) 

Downgrades, upgrades whatever right place to ask -  (MOST downgrades will not work period)

BUT - AFAIK - the data files are identical between 2.4 and 2.5AE

SO the answer would be to backup/download your data FIRST!

Install YABB 2.4 clean

Make sure it works 1st.

Upload/restore your data files ONLY.

Treat it just like a 'Server Move'.

http://www.yabbforum.com/codex/YaBB.pl?board=moveyabb

Good Luck

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: Yabb 2.5AE to SMF Error...
« Reply #8 on: October 13, 2011, 03:32:35 PM »
No need to downgrade to 2.4, as YaBB 2.5 and 2.4 are pretty much the same.

With you YaBB 2.5AE:
Put in Maintenence Mode
Run all the maintenence functions from Admin Panel
Use the YaBB 2.4 to SMF1.1.14 scripts
Once migrated to SMF1.1.14, upgrade this to SMF2.0
Fix you boards and permissions (these will be screwed up badly), and any membergroup errors
Upgrade to SMF2.0.1


I migrated my 1.1m post, 100,000 thread, 11,000 member YaBB 2.5AE to SMF2.0.1 this way.

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #9 on: October 14, 2011, 09:17:11 AM »
Thanks for the reply.  I will look for the SMF script and run the maintenances on the YABB board as you stated and see where it gets me.  Thanks for the tip!

j razz

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #10 on: October 15, 2011, 01:15:36 PM »
It got me a working forum!  Thanks for the tip and  help.  Attachments all showed up fine.  The only issue I have seen thus far is that my user rights (custom groups) were no longer present and my boards were jumbled up as well as custom profile fields are missing.  I have so far fixed all of these issues except the custom fields and am looking at a few other tweaks. 

If I had information on my forum such as spouse name, children names, birth dates, etc. is there a mod that you would recommend so I can add these fields back?  In YABB I could just add custom fields directly in the template- unfortunately I don't know how to do this here.

j razz

Offline j.razz1

  • Semi-Newbie
  • *
  • Posts: 73
Re: Yabb 2.5AE to SMF Error...
« Reply #11 on: October 15, 2011, 03:23:46 PM »
I found (under admin- server settings) the ability to add profile fields.  I found a mod before I found that and it wasn't suited to work with 2.0.1.  Glad you guys incorporated that!

j razz

Offline IamTheBoy

  • Semi-Newbie
  • *
  • Posts: 74
    • Omega Owners Forum
Re: Yabb 2.5AE to SMF Error...
« Reply #12 on: October 16, 2011, 03:32:03 PM »
Indeed, SMF has custom fields built in :)

Glad you've managed to sort it