• Welcome to Simple Machines Community Forum. Please login or sign up.

database error. Posts on threads not opening

Started by br360, September 30, 2012, 05:43:49 PM

Previous topic - Next topic

br360

September 30, 2012, 05:43:49 PM Last Edit: October 02, 2012, 11:58:41 PM by Bradley206
This is the error I am getting.

Table 'adu1214404230574.smf_sp_articles' doesn't exist
File: /home/content/65/9384965/html/Sources/Display.php
Line: 383




The forum is working, but whenever someone opens up a topic, that is the error. How in the world do I fix this?

JBlaze

Looks like you have some leftover code from SimplePortal in your Display.php file.

You might want to go over the installation instructions for SimplePortal to find out what code was added and what you need to remove.
Jason Clemons
Former Team Member 2009 - 2012

br360

I looked, and I can't find anything. Honestly, everytime I try to do something with the code, I make it worse. I need to get this worked out, and am willing to pay for support to get this working, and have members be able to open posts again.

Shambles

Looks like db_prefix is being corrupted to include a prefix of "adu1214404230574.", making it "adu1214404230574.smf_sp_articles" when used in the FROM clause.

I think Jason's nailed it - you need to look long and hard (again) at your Display.php file

br360

Yeah, looking long and hard is what I did. Fixed the issue, and it only took me about 7 hours. ;)

Thanks for leading me in the right direction.

br360

Ok so here's an update, as it appears things aren't all fixed. The errors from the earlier post happened when I did a restore of my files through my ftp manager on my host website. The thing is that I can restore up to 30 days, and for some reason, I decided to roll back to September 1st. Anyway, fixed the error above, but then when I went into my packages, I had a couple I tried to un-install, but kept getting "test failed" in every single file.

Well being all proud of myself for being able to fix my problem earlier, I decided to try to un-install a mod by parse. Everything was working fine, until I uninstalled what I thought was exactly correct. When I was done, I was suddenly unable to get into the feature and options when I went into my admin panel. I was getting a fatal error: parse error.

Anyway, I decided to restore again, but obviously can't go back further than September 2nd now. ( I did restore to September 5th, just in case) I do the restore, but now I have numerous un-install fails when trying to un-install a mod. The weird thing is, that when I go to the mod parse to get the code to un-install,  none of the code for that mod is anywhere in my files.

How am I getting fail tests when the code of those packages no longer exists? Can I go through with the uninstall, even though it says test failed?

Sorry for the novel, but I am completely stumped.

Bigguy

If you have checked the files for for modification code and it is not there then that is why you get test failed when trying to uninstall. The mod is looking for code from the mod that is not there. If you are sure the code is out of all of the files you should be able to delete that one and re-upload the mod in question and try to re-install.

br360

That's good to know, thanks.

Now sorry for the stupid question, but I'm really trying not to screw up any further:

Double checking my source code, I noticed that my boardindex.php is a script that since the backup, does not have any of the mod code in it. However, my boardindex.php~ shows it's a file that has been edited on 10/02/12, and it DOES still have the mod code in it.  Now since the ~ script is the backup, should I worry about the code still being in that file before I un-install?

Here is an image-


Bigguy


Advertisement: