Advertisement:

Author Topic: Similar Topics  (Read 72796 times)

Offline Realinfo

  • Full Member
  • ***
  • Posts: 627
    • Real Info
Re: Similar Topics
« Reply #160 on: November 24, 2013, 04:07:13 AM »
any way to have similar topic by Simple Portal Block like SSI method?

Offline phantomm

  • Sophist Member
  • *****
  • Posts: 1,064
  • Gender: Male
    • pages/smfpl/171860759503032 on Facebook
    • Polish ElkArte community
Re: Similar Topics
« Reply #161 on: November 28, 2013, 01:13:33 PM »
From some time in logs I have this errors:
Code: [Select]
http://**.info/forum/simtopics.php
Wrong value type sent to the database. Integer expected. (current_board)
File: simtopics.php
Line: 70

but on line 70 I see only this:
Code: [Select]
);SMF 2.0.6
Similar Topics 0.6
how to fix this?
Polskie wsparcie SMF na simplemachines.org

My mods

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,123
    • StoryBB/StoryBB on GitHub
Re: Similar Topics
« Reply #162 on: November 28, 2013, 01:14:33 PM »
What's on lines 60-70?

(The error is flagged up as the last line of a query.)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

Nothing turns to hate so bitter as what once was love.

Offline phantomm

  • Sophist Member
  • *****
  • Posts: 1,064
  • Gender: Male
    • pages/smfpl/171860759503032 on Facebook
    • Polish ElkArte community
Re: Similar Topics
« Reply #163 on: November 28, 2013, 01:17:43 PM »
there's this database query before it:
Code: [Select]
$result = $smcFunc['db_query']('', "
SELECT DISTINCT t.id_topic, t.id_board, t.is_sticky, t.locked, t.id_member_started as id_author, t.num_replies, t.num_views, b.name as bname,
mf.icon, mf.poster_name as author, mf.subject
FROM {db_prefix}messages AS m
LEFT JOIN {db_prefix}topics AS t ON t.id_topic = m.id_topic
LEFT JOIN {db_prefix}boards AS b ON b.id_board = t.id_board
LEFT JOIN {db_prefix}messages AS mf ON mf.id_msg = t.id_first_msg
WHERE m.approved = {int:is_active}" . (!empty($modSettings['simtopics_only_cur_board']) ? '
AND t.id_board = {int:current_board}' : '') . (!empty($ignore_boards) ? '
AND b.id_board NOT IN ({array_int:ignore_boards})' : '') . "
AND {query_wanna_see_board}
AND {query_see_board}
AND (" . $where . ")
LIMIT {int:limit}",
array(
'is_active' => 1,
'current_board' => $board,
'ignore_boards' => !empty($ignore_boards) ? $ignore_boards : null,
'limit' => !empty($modSettings['simtopics_num_topics']) ? $modSettings['simtopics_num_topics'] : 5
)
);

$topics = array();
while ($topic = $smcFunc['db_fetch_assoc']($result))
$topics[$topic['id_topic']] = $topic;

$smcFunc['db_free_result']($result);

$output['topics'] = count($topics) == 0 ? false : $topics;
}

echo json_encode($output);

?>
Polskie wsparcie SMF na simplemachines.org

My mods

Offline Yoss

  • Semi-Newbie
  • *
  • Posts: 14
Re: Similar Topics
« Reply #164 on: January 24, 2014, 12:16:44 PM »
1) My forum language is spanish, so we use áéíóú etc, in topic display there is no problem, but when I start a new topic I get "null" on those topics using special chars.

Attached you can find an image.
[/quote]

i love this mod but i have same problem here  :'( Can we expect for a new release soon?

Thank you Bugo!

Offline Kimmie

  • SMF Hero
  • ******
  • Posts: 1,590
Re: Similar Topics
« Reply #165 on: June 15, 2014, 07:42:35 PM »
Will this be updated for 2.07?

Offline Sh@mbles

  • SMF Hero
  • ******
  • Posts: 4,894
  • Gender: Male
    • i30 Owners Club
Re: Similar Topics
« Reply #166 on: June 16, 2014, 05:01:47 AM »
Quote
Will this be updated for 2.07?

Works fine on that version.

Offline Kimmie

  • SMF Hero
  • ******
  • Posts: 1,590
Re: Similar Topics
« Reply #167 on: August 20, 2014, 02:13:06 PM »
I am seeing a problem. it isn't looking though the thread titles correctly. Example:

2 threads with similar titles = the 1st two words of the title are the same but the rest is different. I go into one of those threads, but it doesn't show the other one under similar topics.

It appears to be looking for the words in a random order and only looking for individual words. Having it look from left to right would be the solution. It would also be helpfu if it looks for the entire title first - possibly.


Another issue I found: When creating a new thread, I tried a word that was the first word in several topics and it didn't show any of those. It shows 5 that are unrelated.

What do I need to do to fix this? Thanks.

Offline Bob Perry of Web Presence Consulting

  • Sr. Member
  • ****
  • Posts: 967
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Re: Similar Topics
« Reply #168 on: January 18, 2015, 01:54:54 AM »
I want to use this for 2.1... and as an encouraging side note to the author, I'm guessing that it's only going to take just minor tweaking to be 100% with 2.1, just attempted to install on 2.1 production site and the pre-test had 0 errors! Unusual for this point in the transition process... Watching the logs for a minute reveals only one error thus far, though it is a show stopper should be easy to fix...

error= "The callable simtopics_actions could not be called."  I get this on another module too and I'll track down the author on that too later... heads up man you could be ahead of the competition a bit by fixing this asap

[edit]
Duh, just looked again, the reason there's no errors is that there is very little editing happening... open mouth insert foot yet again... never the less, only one minor little glitch is still VERY cool
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

Offline Portugal

  • Jr. Member
  • **
  • Posts: 192
Re: Similar Topics
« Reply #169 on: March 17, 2016, 03:02:04 PM »
That MOD works on 2.0.11?? Its reliable and dont use lots of resources of database (if dont slow down my forum)??

Thanks in advance

Offline MULITRI

  • Semi-Newbie
  • *
  • Posts: 74
Re: Similar Topics
« Reply #170 on: March 01, 2017, 01:23:54 PM »
I have the same problem as ScrumpyJack, it doesn't load in my themed forum, with v2.0.13 version and Anecdota Theme.

I neither can find that line of code, and after clear the cache and follow all Bugo's instructions, still doesn't appears the Similar Topics block anywhere, so after reading others with the same problem and no solution, i'm guessing is realted with the Theme we're using.

I've had the same load problem with a similar Mod, so it can assure me the issue is related with our Theme, and as i can't change theme after the long modding work unfortunately i will have to dessist to use this feature. It's a big shame because Bugo's Mod is awesome, and install perfectly, so maybe in based default themes.

Thanks anyway for your work with this great feature Bugo... Regards

Offline Replikacep

  • Jr. Member
  • **
  • Posts: 271
  • Gender: Male
    • Orjinal Cin Kore Telefon lari Rom ve Destek
Re: Similar Topics
« Reply #171 on: October 29, 2017, 02:53:57 PM »
The used table type doesn't support FULLTEXT indexes
Dosya: /home/retr/public_html/Packages/temp/install.php
Satır: 20

table  species   MyISAM  supports

table  species  InnoDB   does not support

smf_messages  does not support   
smf 2.1 beta 3 

beta 3 table type  InnoDB  mod is actually incompatible   mod must be updated

Code: [Select]
if ($smcFunc['db_num_rows']($request) == 0)
$smcFunc['db_query']('', '
ALTER TABLE {db_prefix}messages
ADD FULLTEXT st_idx_subject (subject)',
array()
);
« Last Edit: October 29, 2017, 03:24:09 PM by Replikacep »

Offline jack208

  • Semi-Newbie
  • *
  • Posts: 42
Re: Similar Topics
« Reply #172 on: July 01, 2018, 05:44:30 AM »
Just installed this mod on my ver 2.0.15 board, and it works fine as intended. I can see the list of similar topics under the message page. However some strange issues for Bugo's attention. The mod is actually working ok in my board; just need to workaround the issues below.

1) The permission settings within the Mod's Configure Page (ie under Admin > Configuration > Similar Topics) do not work. I can change the settings to "Allow", save the changes.. and the mod is still not switched on for the membergroup.

When I go into the Membergroup's Permission page, under the section "Similar Topics", I noticed both permission items are still set to "Disallow". If I now make the changes - in Membergroup Permission - for these two items to "Allow", ah.. the mod is now switched on for this membergroup and I can see the list of similar topics underneath the message.

so this seems to indicate updating permissions from the Mod Config Page is not working on my board. The workaround is to use the Membergroup Permission page itself to do this.

2) Now a strange issue. After making the changes via Membergroup Permission page (above) and getting the mod to work, if I look at the Mod Config Page, the permissions for the updated membergroups are strangely changed to "Disallow" (X). But the mod is working (ie showing the list of similar topics) for these membergroups. It's just the page showing "X" instead of "A".

See attached file - Config Page Perm
- I've just updated both Similar Topics permission items for these two group (Regular Members, BGC Members) via Membergroup Permission to "Allow", save the changes and in the Mod Config Page, they are marked as "X". The mod is working for these two membergroups so that tells me the permission settings are correct but somehow not displaying correctly in the Mod Config Page?
- note Guests is left as default "X"; didn't make any change to this membergroup since installing this mod

3) The last issue is regarding the list of two new permission items under Membergroup Permission page
- see attached screenshot "MemberGroup Perm"
- you can see under the section "Similar Topics", there are two permission line items but with empty description? I presume they are "Permission to view" and "Access to list on new post" but somehow my board lost the description
- they still work.. I can set them to Allow (or Disallow) and the mod works accordingly

If Bugo is still active here and wants to look closer at the issues, I can arrange test acct and access etc.

Offline Bugo

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,479
  • Gender: Male
    • dragomano on GitHub
    • @dragomano on Twitter
    • Russian translations for SMF mods
Re: Similar Topics
« Reply #173 on: July 01, 2018, 12:52:03 PM »
It's a very good bug, thank you :)
I have updated the mod.

Offline jack208

  • Semi-Newbie
  • *
  • Posts: 42
Re: Similar Topics
« Reply #174 on: July 01, 2018, 05:59:28 PM »
Thanks Bugo. Ver 0.8.1 have fixed all the issues I mentioned above.

 8)

Offline mattizzy

  • Semi-Newbie
  • *
  • Posts: 73
  • Gender: Male
    • mattizzy.okeke on Facebook
    • @mattizzyo on Twitter
    • Xtremeloaded
Re: Similar Topics
« Reply #175 on: August 28, 2018, 01:11:02 AM »
Please What determines the similar topics position. I want to change the position to after the first message

Offline EthanR

  • Semi-Newbie
  • *
  • Posts: 25
Re: Similar Topics
« Reply #176 on: September 04, 2018, 09:24:23 PM »
Working nicely thanks  :) Is there any use in options for tweaking the matching options? For example match 1, 2 or more words in the topic?
« Last Edit: September 04, 2018, 09:46:14 PM by EthanR »

Offline mattizzy

  • Semi-Newbie
  • *
  • Posts: 73
  • Gender: Male
    • mattizzy.okeke on Facebook
    • @mattizzyo on Twitter
    • Xtremeloaded
Re: Similar Topics
« Reply #177 on: September 05, 2018, 07:41:33 PM »
Nice Mod Bro, Please how can I manually change the similar topics position. I don't like where it appears both top and button. I prefer it appears after the first post.