• Welcome to Simple Machines Community Forum. Please login or sign up.
January 19, 2022, 11:20:34 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Visualizzare ad inizio post una allegato

Started by pierpis, February 27, 2013, 11:36:30 AM

Previous topic - Next topic

pierpis

Ciao a tutti, come in oggetto cerco mod per poter visualizzare un allegato al post in anteprima al post stesso.
Grazie

emanuele

Non ho capito...
Cioè vuoi che gli allegati vengano caricati mentre si fa la preview?


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Tento di spiegarlo, allora, se nel mio topic metto un allegato, vorrei che si vedesse l'anteprima a lato del titolo, tutto qui.

emanuele

Okay, ora si capisce un po' meglio.
Ancora una domanda però: quale titolo?
Qui?
http://www.simplemachines.org/community/index.php?board=15.0
o qui?
http://www.simplemachines.org/community/index.php?topic=498588.msg3498701#msg3498701

In entrambi i casi, la cosa non è immediata ed ha varie ramificazioni:
1) l'allegato è solo nel primo messaggio o anche in altri?
2) se c'è più di un allegato?
3) se l'allegato non c'è? (la domanda può sembrare ovvia, ma meglio non fare supposizioni, ho imparato che portano sempre alla conclusione sbagliata)

Potrebbero essere necessarie altre domande a seconda delle risposte alle domande sopra.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Direi da visualizzare nel titolo del primo link che hai postato, quindi solo in quello originale e non nelle risposte, da far vedere il primo degli allegati.....in caso fossero in due. E se l'allegato non c'e'.....non credo che appaia qualcos'altro, al massimo potrebbe apparire l'icona del fermacarte

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

E' quella che cercavo, però non ha possibilità di regolazione della grandezza delle immagini, cioè non riduce, riporta tale e quale l'allegato interno.  :(

emanuele

echo '<a href="', $topic['first_post']['href'], '"><img src="', $image['url'], '" width="', $image['width'], '" height="', $image['height'], '" alt="" /></a>';
e metti:
echo '<a href="', $topic['first_post']['href'], '"><img src="', $image['url'], '" width="100px" height="100px" alt="" /></a>';
ad esempio.


Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

OK ci provo, in quale cartella trovo la stringa?  e con la seconda che mi hai postato, vado in sostituzione della prima?

emanuele



Take a peek at what I'm doing! ;D




Hai bisogno di supporto in Italiano?

Aiutateci ad aiutarvi: spiegate bene il vostro problema: no, "non funziona" non è una spiegazione!!
1) Cosa fai,
2) cosa ti aspetti,
3) cosa ottieni.

pierpis

Grazie Emanuele ho risolto il mio problema (che poi problema non è) ho cambiato la stringa in themes>MessageIndex.template.php ma ho solo impostato le altezze, per avere un risultato in proporzione delle immagini, non ho messo misure alle larghezze.
Ti ringrazio ancora

Advertisement: