• Welcome to Simple Machines Community Forum. Please login or sign up.

Thank-o-matic mod

Started by [yub] Lazo, August 26, 2013, 03:30:00 PM

Previous topic - Next topic

[yub] Lazo

August 26, 2013, 03:30:00 PM Last Edit: August 26, 2013, 03:41:30 PM by [yub] Lazo
Dakle, koristim dobro poznati thank-o-matic mod(http://custom.simplemachines.org/mods/index.php?mod=710), instaliram ga na localhost bez problema, ni jedna greška u default temi, a ni za ovu koju ja koristim. Ali, nakon instalacije kada treba da redirect-a u podešavanja za tu modifikaciju, prebaci me u administracioni centar, u kategoriji konfiguracije nema linka za podešavanja za ovu modifikaciju(kao na slici: http://custom.simplemachines.org/mods/index.php?action=download;mod=710;id=186422;image). Probao sam i da prebacim na default temu(iako to ne pravi razliku jer taj template uopšte nemam u svojoj temi) ali isto naravno. Da li neko ima pretpostavku do čega bi moglo biti? Hvala unaprijed :).

Dynamic forum signatures v1.2

Branko.

Taj mod je radio ADK Tim i nešto su zeznuli s admin panelom dok se sve ostalo u dozvolama i na forumu vidi ( već prijavljeno u support temi). I sam sam se uvjerio u to. Mod je rađen na osnovu prethodne verzije i ima puno izmjena tako da se mora pažljivo pogledati gdje je propust. Ako ti nije žurba ja već radim na tome.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

[yub] Lazo

Naravno da nije žurba. Nadam se da ćeš nas obavijestiti kada uspiješ to riještiti, jer sam ja već tri puta razbio glavu tražeći, bio sam skoro pred ručnim instaliranjem iako nije bilo greške u instalaciji.

Hvala još jednom.  :)

Dynamic forum signatures v1.2

Branko.

Gledao sam i upoređivao, toliko su ga zapetljali da se više isplati sačekati odgovor u support temi nego trošiti vrijeme i rješavati ono što im je obaveza. Nije mi jasno kako je mod prošao provjeru.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

Venera

Ja krostim staru verziju. Više mi se sviđa od nove jer je polje koje pokazuje koliko je i od koga posto dobio zahvalnica u okviru postojećeg posta, a ne ispod kao poseban blok. Davno sam primetila jedan bag zbog kojeg pri pregledu datih zahvalnica na profilu na prvoj strani vidimo date, a već na drugoj i ostalima primljene. Obratila sam im se, sve lepo objasnila, ali sve nešto kao da nisu ukaprali o čemu se radi. Pre toga ih je i Skipper pitao isto, nikad nije dobio odgovor. Tako da se ja ne bih naročito pouzdala u njihovo rešenje, uz svo poštovanje.  :)

Branko.

Dokaz više da su ga sklepali na brzinu. Što se tiče podrške vjerovatno bi reagovali da im se ponudi novac. Uglavnom svi takvi timovi su na SMF-u najviše zbog reklame. I na njihovom sajtu nije bolja situacija. Takođe ne daju rješenje za ovaj problem.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

[yub] Lazo

Ne razumijem kako neko može biti tako neodgovoran. I da im se ponudi novac, vjerovatno bi opet nešto "zbrljali". Ali ipak, modifikacija mi je ipak dosta privlačna i baš ovakva kakva jest potrebna. Gledao sam i neke slične ali nažalost ni jedna ne radi ono šta mi treba, i kako treba. Ako imate neki prijedlog šta dalje, javite, jer ja ne znam šta dalje. :-X

Dynamic forum signatures v1.2

Branko.

Starija (prethodna) verzija radi to isto i što je najvažnije nema ovakvih grešaka
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

comtrade

Nov sam na forumu kao sto se vidi :D
I da ne bih otvarao novu temu,jer ova slicna mom problemu nije resena,postavicu pitanje ovde :)

Dakle,instalirao sam ovaj mod i posto mi nije radio kako treba,tacnije nije nikako radio od pocetka,deinstalirao sam ga...
Problem je nastao kad sam hteo da udjem na bilo ciji profil,cak i svoj.Izbaci mi belu stranicu sa ovom porukom

Fatal error: Cannot redeclare template_profile_thank_you_post_modify() (previously declared in /home/vol2_1/phpnet.us/pn_12385356/htdocs/forum/Sources/Load.php(2197) : eval()'d code:3029) in /home/vol2_1/phpnet.us/pn_12385356/htdocs/forum/Sources/Load.php(2197) : eval()'d code on line 3066

Zna li neko u cemu je problem?
Ja vec 10 dana pretrazujem forume i glava me vec boli


Branko.

Dobrodošao na SMF!
1. Koja smf verzija i koju verziju mod-a si instalirao?
2. Je li automatska instalacija i deinstalacija prošla bez greške?
3. Zipuj i stavi ovdje kao prilog taj Load.php

Problem je što ti je nakon deinstalacije ostalo nešto od mod-a u Load.php datoteci.

@[yub] Lazo, da nisi bio sad online ne bih se sjetio obećanja. Imaš moje rješenje u mod support temi.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

[yub] Lazo

Moj prijedlog pošto u tvom postu ne vidim indicije na to šta je tačno ostalo pa da brka je da pogledaš parser za ovaj mod i ideš redom niz promjene koje se vrše u load.php fajlu te gledaš šta je kako ne treba da bude. Ukoliko ne mogneš sam riješiti slobodno se javi na PP/PM ako treba preko teamviewer-a ćemo riješiti. Znam da sam i ja im'o taj problem te da je nešto u fajlu ostalo od tog moda samo ne znam tačno šta.  :)


Edit: ne viđoh uopšte tvoj post Branko, izvinajvam se ali možda mu pomogne. :)

Dynamic forum signatures v1.2

Venera

Pre instaliranja bilo koje modifikacije, a posebno bilo kog moda koji je radio ADK  tim treba napraviti backup. ADK ima primamljive modifikacije (kao što je upravo T-O-M), ali treba imati u vidu da svoje modove uklapaju da se slažu sa njihovim: Adk portalom, ADK galerijom, ADK blogom i ostalim njihovim modovima, ali često prave problem ako imamo drugi portal ili neke modove drugih autora, tako da se može desiti da pola toga ne radi recimo na Simple portalu, da se "sudara" sa nekim modom, a gotovo uvek pri deinstalaciji ostaju repovi po fajlovima. Posle deinstalacije njihovih modova najbolje je vratiti backup (fajlova koji trpe promenu, a ko ne zna-ceo backup), čak i ako se odmah ne javi/uoči neki problem. Desi se da je ostalo nešto što u startu ne pravi problem, ali već pri instalaciji sledećeg moda može izazvati problem, a onda je situacija malo složenija.

Instalacija T-O-M moda na čistoj default temi ima bagova na staroj verziji moda, a ozbiljnijih grešaka na novoj, kao što smo svi konstatovali, ne bi smelo,ali prolazi kontrolu. Podrška im je loša, pa ne uzalud čekati njihovu pomoć kad imamo problem...  :)

Nemam ništa protiv ADK-tima, koristim staru verziju T-O-M, isprobala gomilu njihovih modova, a i skinova (takođe sa greškama). Govorim iz svog i skustva, a samo želim da skrenem pažnju kolegama da budu oprezni kako bi sebi skratili muke.

Pozdrav svima  :)




[yub] Lazo

Evo Branko upravo sam probao ovaj tvoj ispravak za mod i radi savršeno.

Znači rešenje problema je ovaj post.

Hvala još jednom! :)

Dynamic forum signatures v1.2

comtrade

Hvala i bolje vas nasao :)

Uff probacu da odgovorim na sve postove tj pitanja,ako nesto izostavim,nemojte zameriti :)
@branko

1.smf verzija 2.04 a mod je 2.0
2. bicu iskren :) nije prosla bez greske instalacija moda tj javio mi je da neki fajlovi tacnije jedan nije prosao test sto sam ja ignorisao :(
Deinstalacija je prosla ok...
Nisam jos rekao u prvom postu...Kad sam uradio deinstalaciju,uopste nije bilo moguce pristupiti forumu,isto je izbacivao neku gresku vezanu za pomenuti mod...tacnije video se board ali klik na bilo koji forum vodio je do bele stranice sa slicnom greskom.
Pristupio sam admin panelu i instalirao mod opet :D
Sad je sve po starom,tacnije moze da se pristupi forumimam,forum normalno funkcionise ali profili su onemoguceni (sto je bio problem i pre deinstalacije)
...nadam se da nisam zapetljao iovako konfuznu situaciju i izvinjavam se na opsirnosti

3.ubacio sam load.php


@[yub] Lazo
Hvala na svemu,precesljacu taj load veceras korak po korak (ako branko ne nadje do tad problem) :)

@Venera
Od sad cu se ipak kloniti tog tima :D


Venera

Quote from: comtrade on September 13, 2013, 08:05:39 AM

@Venera
Od sad cu se ipak kloniti tog tima :D

Ne moraš, (mada znam kako ti je, prošla sam tu priču), samo prvo uradi backup - uvek!  ;)

Srećno!  :)

comtrade

Ja sam probao da editujem load.php al bezuspesno jer posle bilo kakvog edit-a ne moze forum da otvori i svaki pokusaj edit-a se zavrsavao restore-om starog load fajla..
Gresim li u editu negde,koji vi php editor koristite?

pozdrav :)

Venera

Notped ++ je odličan.  :)

Sačuvaj taj load.php fajl, deinstaliraj mod, pa zameni load php starim iz backupa-pre instalacije ovog moda, pa vidi šta će da se desi. Lako ćeš vratiti.  ;)

comtrade

Hvala :)

Nemam backup pre instalacije tog moda,u tome je problem....

Branko.

Nije riječ o bekapu baze, već forumskih datoteka koje se čuvaju kao arhive u /Packages/backups direktorijumu a automatski se formiraju nakon svake instalacije modova... osim ako ih nisi namjerno pobrisao.
Strong people don't put others down, they lift them up.
A clever person solves a problem. A wise person avoids it.

Advertisement: