News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Problem with avatars and attachments in IE after installing 2.0.6

Started by WimB, October 27, 2013, 03:25:04 PM

Previous topic - Next topic

WimB

This morning we installed patch 2.0.6 to our forum (update from 2.0.5). Our members which are using IE can no longer see some of the avatars and attachments. They work perfectly in Firefox, Safari,....

Anyone any idea what the cause might be? (something with the programming which IE doesn't digest very well it would seem ;))

Arantor

Well... the 2.0.6 patch did not change how avatars and attachments are served. It *did* change how avatars get *saved* but that only kicks in when someone actually updates their avatar.

What else changed for your users?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

WimB

The only thing we changed was update the patch and change the time from summertime to wintertime.

For the rest no changes were made and I've heard no other complaints, when the IE users renew their avatar, it is visible again in IE, but that's not possible for the attachments.

Arantor

I don't know what to tell you.

Here's what I know, for certain (mostly because I'm the one who wrote the patch)...

1) The patch did not touch Display.php, which is where action=dlattach is located (and action=dlattach is what serves avatars and attachments)

2) The only change that does come up in index.php?action=dlattach is the change to index.php where extra headers were added. If the headers were damaging the process, it would break new uploads too.

As a test, though, you could try commenting out this line from index.php:
header('X-Content-Type-Options: nosniff');

But as I understand it, both Facebook and Twitter use this and they haven't had any problems.

Is it all IE users on your site? Is it all files or just some of them?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

WimB

Quote from: Arantor on October 27, 2013, 03:50:57 PM
I don't know what to tell you.

Here's what I know, for certain (mostly because I'm the one who wrote the patch)...

1) The patch did not touch Display.php, which is where action=dlattach is located (and action=dlattach is what serves avatars and attachments)

2) The only change that does come up in index.php?action=dlattach is the change to index.php where extra headers were added. If the headers were damaging the process, it would break new uploads too.

As a test, though, you could try commenting out this line from index.php:
header('X-Content-Type-Options: nosniff');

But as I understand it, both Facebook and Twitter use this and they haven't had any problems.

Is it all IE users on your site? Is it all files or just some of them?

Thanks Arantor, will try the commenting out.

All IE users have the problem (all versions of IE) and it's just some of the files, but it's not related to the format, they are all jpg but the pics that are still visible are jpg too.

WimB

commenting that out didn't change anything either....Thank you very much for helping Arantor!

Arantor

Is there anything the files have in common?

Do they have funny characters in the names (when they don't work properly)?
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

WimB

Quote from: Arantor on October 27, 2013, 04:05:24 PM
Is there anything the files have in common?

Do they have funny characters in the names (when they don't work properly)?

Nothing in common....no funny characters in the names.
Just noticed that when I rightclick on the black x where the attachment should be and select "open link in a new tab", it shows the attachment correctly.

Arantor

Ah, so thumbnail generation failed. But my changes didn't touch Subs-Graphics where that occurs.
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

WimB

So, something we changed must have affected Subs-Graphics in a way that only IE responds badly to it.....

Arantor

No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

WimB


mashby

Some avatars and attachments? Mind providing a link to where an avatar isn't displaying properly in IE? And one with attachments, too?
Always be a little kinder than necessary.
- James M. Barrie

WimB

Quote from: monster mashby on October 27, 2013, 04:28:08 PM
Some avatars and attachments? Mind providing a link to where an avatar isn't displaying properly in IE? And one with attachments, too?

Here you go monster M: http : //www.vrvforum.be/forum/index.php?topic=1209.0 [nofollow]

lurkalot

Quote from: Arantor on October 27, 2013, 04:24:23 PM
Well, it wasn't 2.0.6...

Arantor.  Well I'm glad I read this thread.  As you know I uploaded a fresh set of files to my site and now I'm missing some of my users avatars too. they also show in Firefox and Chrome, but not in IE10 as they did before the upgrade.  ???

Arantor

OK, so let's try something really crazy.

Comment out this line from index.php.
header('X-XSS-Protection: 1; mode=block');
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

lurkalot

Quote from: Arantor on October 27, 2013, 06:00:26 PM
OK, so let's try something really crazy.

Comment out this line from index.php.
header('X-XSS-Protection: 1; mode=block');

Tried it, but unfortunately it made no difference.  :(

Arantor

I didn't really expect it to, but it was one option that might have done; IE is a bit crazy when it comes to those headers (even though it was IE that introduced them originally!)
No good deed goes unpunished / All helpful urges should be circumvented

I have something to say: it's better to burn out than to fade away. There can be only one.

lurkalot

Strange how its just blocking some and not all off the uploaded avatars.  If I go to Admin > Forum > Attachments and avatars > Browse files > Avatars, the missing ones are there, and I can view them.

Some Of my members have since uploaded them again (including me).

WimB

Really strange.... nothing seems to have changed in Subs-Graphics either  :o

Advertisement: