• Welcome to Simple Machines Community Forum. Please login or sign up.

Problème de compatibilité PHP 5.5

Started by 0Connors, July 22, 2014, 03:43:50 PM

Previous topic - Next topic

0Connors

Bonjour à tous,

Finalement le problème ce répète sur mon site avec les navigateurs IE et firefox ou les fonts spécifiques ne sont pas téléchargé. Je n'avais pas vu car je n'utilise pas ces navigateurs. Ce qui est curieux c'est que le problème ne ce produise pas sous Chrome.

Avez-vous une idée d'où peu venir le problème ?

En vous remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

J'ai IE 11.0.10 et je ne vois rien de particulier sur ton site. Peut-être les anciens navigateurs mais là les utilisateurs doivent les mettre à jour :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut Maximus,

Pour être plus clair, j'ai fait des captures d'écrans pour que tu note bien la différence de l'étrange phénomène. De plus j'ai noté que sur Firefox je n'arrive pas à me connecter au forum, est-ce lié ou est-ce un problème différent ? Je ne sais pas mais en tous les cas certains des utilisateurs viennent de me le rapporter. Du coup j'ai vérifié mes déclarations de font etc... Et je t'avoue ne pas bien comprendre pourquoi ça fonctionne bien sur Chrome mais pas sur IE ni Firefox.

En te remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

Salut,

Je relance un peu le sujet des-fois que quelqu'un aurait un semblant de solution.

A+
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Moi je ne vois vraiment pas de différence quand je me connecte sur ton site actuellement. De plus je me connecte très bien avec FF. Tu es déjà en php 5.5+ ?

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

J'y suis bien... C'est étrange pourquoi ça me le fait à moi et certains de mes membres...  ???
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

J'y pense juste à tu bien vidé ton cache ??  ???

En te remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonsoir,

Moi j'ai essayé du boulot (tout les caches sont vidés dès la fermeture) et de chez moi même chose en ce qui me concerne rien d'anormal.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

C'est étrange pourquoi ça fait uniquement avec certains utilisateurs et certains de mes navigateurs... ??? Là je n'y comprends plus grand chose... Surtout que c'est pas logique seul les polices ont l'air d'être touché le reste du CSS est intacte.

Bref, je essayé de continuer à trouver une logique.
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

0Connors

Bonjour,

Le phénomène est étrange, j'ai demandé 20 membres de faire le test sur les 20, 12 m'ont effectivement rapporté le problème.

J'ai trouvé un truc étrange avec deux forme de déclarations de mes fichiers ".css" :

1
<link rel="stylesheet" type="text/css" href="../css/style_declaration.css" />
<link rel="stylesheet" type="text/css" href="../css/style_entete.css" />
<link rel="stylesheet" type="text/css" href="../css/style_slide.css" />
<link rel="stylesheet" type="text/css" href="../css/style_news.css" />


2
<link rel="stylesheet" type="text/css" href="http://www.pafteam.com/css/style_declaration.css" />
<link rel="stylesheet" type="text/css" href="http://www.pafteam.com/css/style_entete.css" />
<link rel="stylesheet" type="text/css" href="http://www.pafteam.com/css/style_slide.css" />
<link rel="stylesheet" type="text/css" href="http://www.pafteam.com/css/style_news.css" />


Lorsque que je suis en version PHP 5.2 le forum réagis normalement, mais lorsque je suis en version 5.5 le CSS du forum réagis différemment, en fonction de la manière de le déclarer.

De plus j'ai noté qu'en 5.5 l'adresse des pages du forum sont sous cette forme : http://pafteam.com/forum/index.php?board=1.0.html au lieu de http://pafteam.com/forum/index.php?board=1.0 en 5.2.

Du coup je pense qu'il y a un vrai problème avec la version PHP. Je précise au cas où que les déclarations du CSS sont faites dans le fichier "index.template.php".

Voilà je sais pas si ça te donne une idée ?

En te remerciant,

PS : Sous Firefox j'ai toujours un problème je n'arrive pas à me connecter au forum, l'erreur transmise à chaque fois est :
QuoteUne erreur s'est produite !
Désolé, nombre de tentatives de connexion dépassé. Patientez 30 secondes et réessayez.

Pourtant je n'ai aucun souci sur IE et Chrome.
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

maximus23

Bonjour,

Pour que tes urls soient identiques en php5.5+ et php5.5- tu dois mettre dans Admin -> Fonctionnalités et Options -> Réglages -> URLs plus compréhensibles pour les moteurs de recherche -> Cocher :)

Pour ta déclaration des paths indiques les chemins complets pour une compatibilité aussi.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

0Connors

Salut,

Merci effectivement ça à l'air de mieux fonctionner, je vous tiendrais au courant si il y a un souci !

En vous remerciant,
Site : www.pafteam.com

Projet : www.pafteam.com/beta-test/maj-site/

Version SMF : 2.0.9

Advertisement: