Advertisement:

Author Topic: "The message body was left empty" error  (Read 5081 times)

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
"The message body was left empty" error
« on: July 19, 2016, 08:31:23 AM »
Hello, I have encountered a rather upsetting bug. Whenever I try to post a message that's more than 20000 characters, an error appear with the message "The message body was left empty", and I cant post at all. Even when I raised the maximum number of character per post, the error persisted. I dont have that many mods installed (Mostly subaccounts and Image Floating Left and Right BBCode) I have browsed through the forum and saw that many other people had the same bug and couldnt find a clear fix. But from times to times, users reported that it was probably because of the image. My post did contain a floating picture that I removed and I had no problem posting.

Even though it's a huge problem for me. I'm using my message board to post articles and I desperately need the floating image fonction. Is there any way to fix this ? Any prior version of SMF where I might not encounter the bug ? Any mod that does the same thing ? I'm willing to completely uninstall and reinstall everything if I have to

For testing purposes, here is the link to my forum and a test account

http://asobu-asso.org/forum [nofollow]

Login : testaccount
Password : chocolate

Offline Grammy

  • Full Member
  • ***
  • Posts: 428
  • Gender: Female
  • Tire Kicker
Re: "The message body was left empty" error
« Reply #1 on: July 19, 2016, 08:45:32 AM »

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #2 on: July 19, 2016, 09:02:12 AM »
Since OP problem wasnt solved in the end I'd say no ?

-I'm not pasting from a word processor but from a webpage.
-The text is 20422 characters long right above the default maximum
-Where can I check if the body column in the messages table is MEDIUMTEXT ?
-I have tried to change the maximum amount of characters per post many times but unfortunately, be it 200000 30000 or 50000 it doesnt change a thing.

I do believe the problem comes from floating images since I have tried to post without the [imgleft][/imgleft] code andit worked just fine

Offline Grammy

  • Full Member
  • ***
  • Posts: 428
  • Gender: Female
  • Tire Kicker
Re: "The message body was left empty" error
« Reply #3 on: July 19, 2016, 09:06:41 AM »
Since OP problem wasnt solved in the end I'd say no ?

-I'm not pasting from a word processor but from a webpage.
-The text is 20422 characters long right above the default maximum
-Where can I check if the body column in the messages table is MEDIUMTEXT ?
-I have tried to change the maximum amount of characters per post many times but unfortunately, be it 200000 30000 or 50000 it doesnt change a thing.

I do believe the problem comes from floating images since I have tried to post without the [imgleft][/imgleft] code andit worked just fine


I'd start with pasting everything into a plain text editor, instead of from another website straight into the current site.  Then copying and pasting from that text editor.  If that didn't sort it, I'd try uninstalling that mod and clearing my cache, then, just to see if it's the issue.

You'd have to go into your database to check the structure of that table to see about MEDIUMTEXT.

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #4 on: July 19, 2016, 09:48:05 AM »
My biggest question would be -- *WHY* do you need to make a post that large?
That seems more like text for a static page than for a post.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #5 on: July 19, 2016, 09:56:48 AM »
I've copied my text into notepad to no avail. I have uninstalled the mod, cleared my cache, and reinstalled it, to no avail as well.

As for the database, do you mean mySQL ?Where exactly should I be looking?

Kindred=>I am hosting a roleplaying community and database, posts containing a lot of lore will be common place once the forum will open. Most of our users are content providers and cant handle themselves with Wikias or static pages but are used to handle forum. 20000 character is not a large post by my standard, hence why I'm worried that this problem is going to be a real pain.

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #6 on: July 19, 2016, 12:40:12 PM »
basically, you are using a forum for something it is not intended to be used as...   I would suggest posting things like "lore" in a knowledgebase or articles system instead of using forum posts.

Also, however, please make sure that your forum is UTF-8, if you are going to be pasting stuff from programs like Word, etc.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #7 on: July 19, 2016, 01:57:13 PM »
I doublechecked and my forum is indeed using UTF-8, thank you or your advice.

Could my bug be solved by editing the mod ? Or is it something relevant to this version ?

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #8 on: July 19, 2016, 03:32:54 PM »
how are you posting the image?   as an IMG BBC tag?

If you are having issues with a specific mod, then you would really need to ask for assistance fomr the mod author in the thread dedicated to supporting that specific mod.

That being said -- I really suggest that you look at the knowledgebase or articles mods instead of trying to shoehorn a poor solution into the forum
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Steve

  • Freak
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,501
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: "The message body was left empty" error
« Reply #9 on: July 20, 2016, 08:22:59 AM »
If you are having issues with a specific mod, then you would really need to ask for assistance fomr the mod author in the thread dedicated to supporting that specific mod.

That being said -- I really suggest that you look at the knowledgebase or articles mods instead of trying to shoehorn a poor solution into the forum

Even so ... knowing Dougie, I'm sure he'd like to be made aware of this issue.
Online Manual

Please do not PM me for support.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #10 on: July 20, 2016, 11:02:58 AM »
how are you posting the image?   as an IMG BBC tag?

If you are having issues with a specific mod, then you would really need to ask for assistance fomr the mod author in the thread dedicated to supporting that specific mod.

That being said -- I really suggest that you look at the knowledgebase or articles mods instead of trying to shoehorn a poor solution into the forum

Indeed, I'm using the mod specific [imgleft][/imgleft]for a picture floating left and [imgright][/imgright] for a picture floating right.

I have looked through the knowledgebase and article mods today and it doesnt solve my problem. The article mods dont come with a fonction allowing me to make pictures float left or right and rely on my mod to do so. So whenever I try to post something the error is still here.

I will try ask for assistance on the mod specific thread. Thank for your assistance.

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #11 on: July 20, 2016, 11:38:18 AM »
hmmm... something just occurred to me...    is the BBC img code the first thing in your post?

If so, I think that might be the issue
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #12 on: July 23, 2016, 07:52:17 AM »
The BBC img code is indeed the first thing in my post. What is the issue then ?

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #13 on: July 23, 2016, 09:06:06 AM »
ah ha...    put something else before it.
it is not a problem with the mod...   it's a known limitation.  BBC can not be the first (or only) think in a post.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #14 on: July 23, 2016, 10:43:15 AM »
I just tried it out, it's still not working, no matter where I put it in the post. As soon as I use the bbcode of the image floating mod the post become completely empty

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,939
Re: "The message body was left empty" error
« Reply #15 on: July 23, 2016, 10:58:36 AM »
so if you leave out that bbc it works fine? then it is an issue with that mod, you would need to post in that mods support topic. the author did not define the bbc in a way that makes it stop triggering that error.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #16 on: July 23, 2016, 11:29:20 AM »
I did as you can see here : http://www.simplemachines.org/community/index.php?topic=530744.msg3883765#msg3883765

Though the author of the mod doesnt seem to believe his mod is the issue.

Offline Védé

  • Semi-Newbie
  • *
  • Posts: 17
Re: "The message body was left empty" error
« Reply #17 on: July 31, 2016, 06:22:47 PM »
I'm upping this thread since I still have no clue how to fix the bug.

Offline FireDitto

  • Full Member
  • ***
  • Posts: 617
  • Gender: Female
  • Shadow In The Flame
    • @SPWeyr on Twitter
    • Second Pass Weyr RPG
Re: "The message body was left empty" error
« Reply #18 on: December 15, 2016, 09:47:12 PM »
The bug vanishes if you revert back to 2.0.11, so it's definitely a .12 issue

Unfortunately I am unable to revert to .11 on one of my forums so I'm really frustrated :/ I have no idea where to look to figure out what is causing the issue.
Second Pass Weyr
An AU Pernse RPG

SMF 2.0.6 with SP 2.3.5

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,741
  • Gender: Male
    • Kindred-999 on GitHub
Re: "The message body was left empty" error
« Reply #19 on: December 15, 2016, 10:01:04 PM »
As we have stated several times, we KNOW that it is an issue with 2.0.12... and we know the issue and it is getting fixed in 2.0.13

The issue has to do with starting a message with a whole bunch of BBC before any actual content
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.