Advertisement:

Author Topic: Can 2.1 emulate 2.0  (Read 2436 times)

Offline skb

  • Jr. Member
  • **
  • Posts: 360
    • Metabolically Challenged
Can 2.1 emulate 2.0
« on: October 05, 2016, 05:42:45 AM »
Just a theoretical question. Not installing 2.1 till it is ready.
But if a mod was required to be installed in 2.1, could it be emulated to work as 2.0 for a short time ?
Learning, every day.
Forum - The Diabetic Pub
Because every diabetic needs help
SMF 2.1 RC2 (default theme) / TP 1.6.2

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Can 2.1 emulate 2.0
« Reply #1 on: October 05, 2016, 05:47:06 AM »
SMF 2.1 has a smart emulate function that does include SMF 2.0. that does not guarantee that the mods will work as expected though.

Offline skb

  • Jr. Member
  • **
  • Posts: 360
    • Metabolically Challenged
Re: Can 2.1 emulate 2.0
« Reply #2 on: October 05, 2016, 05:51:40 AM »
Thanks Illori. Marking as Solved
Learning, every day.
Forum - The Diabetic Pub
Because every diabetic needs help
SMF 2.1 RC2 (default theme) / TP 1.6.2

Offline BYUFanatic

  • Jr. Member
  • **
  • Posts: 130
  • Gender: Male
Re: Can 2.1 emulate 2.0
« Reply #3 on: November 25, 2016, 01:14:32 AM »
SMF 2.1 has a smart emulate function that does include SMF 2.0. that does not guarantee that the mods will work as expected though.

This feature does not appear to work. I've tried installing mods and themes after "applying" the version emulation but no luck. It doesn't appear to emulate previous versions. Nor does it give me a choice for which version to emulate.

Offline Suki

  • Kaizoku Jotei
  • Developer
  • SMF Super Hero
  • *
  • Posts: 15,551
  • Oh, wouldn't it be great if I *was* crazy?
    • MissAllSunday on GitHub
    • SMF mods
Re: Can 2.1 emulate 2.0
« Reply #4 on: November 25, 2016, 09:46:20 AM »
Emulation in 2.1 is still present and works the same as the one in 2.0. This page is still relevant for using emulation on a 2.1 installation: http://wiki.simplemachines.org/smf/How_can_I_install_a_mod_that_doesn%27t_work_in_my_SMF_version

Now, emulation does not mean mods and themes will flawlessly work on a 2.1 installation. Emulation does help you to be able to install a mod designed for another version but it does not guarantee it will work.A mod been compatible solely relies on what that particular mod does and how it performs its operations.

Themes designed for 2.0 aren't compatible with 2.1.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Look at them. They're just asking for it. Maybe the human race deserves to be wiped out.

Offline BYUFanatic

  • Jr. Member
  • **
  • Posts: 130
  • Gender: Male
Re: Can 2.1 emulate 2.0
« Reply #5 on: November 25, 2016, 07:48:57 PM »
Sorry, but I cannot even install the mod. I get the following error:

"The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

This mod worked seamlessly on 2.0.x with no problem, so I know it's not corrupt. Therefore the "emulate" feature is apparently not working correctly or I'm somehow missing something in trying to use the emulator.

When I go to the administration panel and pull up emulation support, the drop-down list does not specify a particular version, instead, all of them are shown as one single comma-delimited list in just one drop-down. A bug perhaps?

Screenshot attached.

Oh, and thank you for that link. I had read it earlier. Which makes me believe it's a bug because it does not show a drop down LIST of versions, but rather just one long string of comma-delimited versions.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Can 2.1 emulate 2.0
« Reply #6 on: November 25, 2016, 08:01:00 PM »
seems https://github.com/SimpleMachines/SMF2.1/issues/2899 has returned, since that feature pulls from a file on sm.org and it has not been updated this is happening. once that file is updated the issue should go away.

Offline BYUFanatic

  • Jr. Member
  • **
  • Posts: 130
  • Gender: Male
Re: Can 2.1 emulate 2.0
« Reply #7 on: November 25, 2016, 10:00:52 PM »
Ah. Thanks for pointing that out. Looks like this bug has been around for a while. I'm surprised it hasn't been fixed by now. That conversation was from a year ago... is there still a valid "work around" to make it work?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,502
  • Gender: Male
    • Kindred-999 on GitHub
Re: Can 2.1 emulate 2.0
« Reply #8 on: November 25, 2016, 10:06:42 PM »
The issue is not in the code...  it's a problem, with a file on this site
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline BYUFanatic

  • Jr. Member
  • **
  • Posts: 130
  • Gender: Male
Re: Can 2.1 emulate 2.0
« Reply #9 on: November 25, 2016, 10:12:01 PM »
Which file? And can I edit that file to work? Thanks!

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,502
  • Gender: Male
    • Kindred-999 on GitHub
Re: Can 2.1 emulate 2.0
« Reply #10 on: November 25, 2016, 10:34:34 PM »
No. it is a file here on this site that thebwystems pull to get a list of valid versions.   

However, its not considered a major issue to update quickly since we're more concerned about the actual forum base installation and not the mods which will probably have to change anyway after beta is done
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline BYUFanatic

  • Jr. Member
  • **
  • Posts: 130
  • Gender: Male
Re: Can 2.1 emulate 2.0
« Reply #11 on: November 25, 2016, 10:39:12 PM »
Ok. Thanks. :) Is there someone I can sweet-talk to fix it? It is apparently something that can be done in just a minute or two. If not, I'll ust wait until beta is done. How's it progressing?