Advertisement:

Author Topic: Captcha not found (sometimes)  (Read 1091 times)

Offline meheh123

  • Newbie
  • *
  • Posts: 4
Captcha not found (sometimes)
« on: November 04, 2016, 05:37:35 AM »
Hey,

On the forum I am managing captcha seems to disappear sometimes. However there is link to an image, but it's only 1 pixel...

Console on the image page says:

Quote
Pastebin info 1
(check P.S.)

But in fact I have disable uBlock at that forum (attachment 1).

You can find the problem at this link:
Quote
Pastebin info 2
if you succesfully access the captcha F5 (refresh) won't screw it up. Need to move again to the page (I suggest incognito mode).

In the past when Captcha wasn't appearing there was an error in the console related to "Access-Control-Allow-Origin" and the Cross-Origin Resource Sharing (CORS), but I couldn't find any satisfying sollution with this knowledge.

This is the polish forum, so in case I attach a screenshot where is the verification (attachment 2).

Thanks in advance for spending your time to help or direct me.

P.S. I didn't know I cannot post links so the infos are in the pastebin.com/SPZqK63g


Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,167
  • Gender: Male
    • i30 Owners Club
Re: Captcha not found (sometimes)
« Reply #1 on: November 04, 2016, 05:54:27 AM »
What's your SMF version and is it at this address?

http://forum.suwalki.info

Only asking as it's hard to tell what you're running, seeing as there's no SMF Copyright info in there...

Offline meheh123

  • Newbie
  • *
  • Posts: 4
Re: Captcha not found (sometimes)
« Reply #2 on: November 04, 2016, 06:00:33 AM »
It is running  SMF 2.1 Beta 2.

Yeah, link is correct. I couldn't add that in my post as editor prevent me.

Quote
Only asking as it's hard to tell what you're running, seeing as there's no SMF Copyright info in there...

Sorry to hear that, I will note that to the administrator so he will add that immediately.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Captcha not found (sometimes)
« Reply #3 on: November 04, 2016, 06:29:13 AM »
since you dont have a copyright displayed, we can deny you support. also you should not be running a beta in production, there are bugs and no guarantee that you will be able to upgrade to the next release without running into issues.

Offline meheh123

  • Newbie
  • *
  • Posts: 4
Re: Captcha not found (sometimes)
« Reply #4 on: November 04, 2016, 06:33:43 AM »
Copyrights were already added at the footer.

I'm not so sure that this is Beta version fault as I couldn't find any refference over the web, I mean that probably no one had same problem as we do.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Captcha not found (sometimes)
« Reply #5 on: November 04, 2016, 07:10:46 AM »
that is not the correct copyright. all rights reserved has never been part of the copyright. the copyright year is also incorrect, beta 1 was released in 2014 not 2013. also beta 2 has been released since the version you all seem to be using, so you should upgrade to that or even try to the beta 3 on github. but as i said before there is no guarantee that the upgrade process will work or work at all.

Offline meheh123

  • Newbie
  • *
  • Posts: 4
Re: Captcha not found (sometimes)
« Reply #6 on: November 04, 2016, 07:23:42 AM »
Hope the Copyrights are in the proper form now.

I will try upgrading forum to the beta 3 as you suggested. ( hxxp:github.com/SimpleMachines/SMF2.1 [nonactive] that is correct source, right?) and let you know.

Thank you.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Captcha not found (sometimes)
« Reply #7 on: November 04, 2016, 07:33:49 AM »
yes that is the correct location. you should also use the default theme and see if that resolves the issue as it could be related to the custom theme that is in use.