• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 02:42:33 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Anchor tag - it doesn't work anymore

Started by Raffaele1977, December 01, 2016, 03:07:56 AM

Previous topic - Next topic

Raffaele1977

I have a long post that I divided in 30 sections.
For every section I use a

[iurl=#par1]Title[/iurl]

and I put this at the beginning of the section i want to link to

[a n c h o r =par1][/anchor]
I wrote with spaces inside the word anchor, otherwise it was deleted! :(



Now the editor delete all the anchor tags I inserted.
If I put them again, when iI save the post, they are deleted each time.

Do you know the reason?
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

Illori

is this the only word that is effected? sounds like in someway your host may have mod_security enabled and it is causing you headaches.

Raffaele1977

The same happens in this forum...

What should I do?
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

Illori

what if you put a word in between the anchor tags? this could be part of some of the bbc issues that has been facing SMF 2.0.12 and will be fixed in SMF 2.0.13 when it gets released.

Raffaele1977

Yes, perfect.
That is the bug.

If i put a character or a (shift+alt+space, that is a special space) it works :D




I suggest to anyone who has this bug to insert the special space (shift+alt+space)
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

nend

Link to...




[iurl=#par1]Link to...[/iurl]




[anchor=par1]...Here[/anchor]








...Here

Illori

Quote from: nend on December 05, 2016, 11:59:54 PM
Link to...




[iurl=#par1]Link to...[/iurl]




[anchor=par1]...Here[/anchor]








...Here

right but if the anchor is empty it does not work. if you fill it in then you are not duplicating the issue.

Raffaele1977

Quote from: Raffaele1977 on December 01, 2016, 11:14:41 AM
I suggest to anyone who has this bug to insert the special space (shift+alt+space)

This is the trick to have it working without inserting any visible character :)
MacOsX - 11.6
SMF 2.0.15
Safari (last) or Chrome (last)

Advertisement: