Advertisement:

Author Topic: [2.0.14] PHP7.0 and search with custom index error  (Read 6775 times)

Offline digger

  • Sr. Member
  • ****
  • Posts: 733
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
[2.0.14] PHP7.0 and search with custom index error
« on: October 07, 2017, 02:42:13 PM »
Code: [Select]
Fatal error: 'continue' not in the 'loop' or 'switch' context in /.../Sources/SearchAPI-Custom.php on line 112

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,135
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild

Offline digger

  • Sr. Member
  • ****
  • Posts: 733
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: [2.0.14] PHP7.0 and search with custom index error
« Reply #2 on: October 08, 2017, 02:45:05 PM »
In case you missed it. https://www.simplemachines.org/community/index.php?topic=553979.0
It's a SMF bug and there is no comnents that it will be fixed in 2.0.15.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,313
    • StoryBB/StoryBB on GitHub
Re: [2.0.14] PHP7.0 and search with custom index error
« Reply #3 on: October 08, 2017, 03:03:23 PM »
I've specifically re-referred it back to the people working on 2.0.15.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.