Advertisement:

Author Topic: Error after updating to the latest version  (Read 752 times)

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Error after updating to the latest version
« on: December 02, 2017, 10:11:44 AM »
After I upgrated forum to the latest version I am getting this error message: Fatal error: Function name must be a string in /home/bharatco/public_html/enforum_prod/Sources/Load.php on line 133

What can be the reason?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,384
    • StoryBB/StoryBB on GitHub
Re: Error after updating to the latest version
« Reply #1 on: December 02, 2017, 10:13:01 AM »
You need to have PHP 5.4 or higher on the server.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #2 on: December 02, 2017, 10:20:55 AM »
I recently updated my Russian forum, everything is working fine and now did the same for English part.

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #3 on: December 02, 2017, 11:18:01 AM »
Can someone help me, I can't even access the site anymore.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,384
    • StoryBB/StoryBB on GitHub
Re: Error after updating to the latest version
« Reply #4 on: December 02, 2017, 11:47:24 AM »
Ask your host to upgrade PHP...
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #5 on: December 02, 2017, 11:54:06 AM »
I have 2 forums on the same platform, how come I can access one and not the other one?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,128
Re: Error after updating to the latest version
« Reply #6 on: December 02, 2017, 12:31:20 PM »
are they on the same hosting plan? are they on the same server?

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #7 on: December 02, 2017, 12:48:47 PM »
Yes, they are, that's why I am really surprised.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,384
    • StoryBB/StoryBB on GitHub
Re: Error after updating to the latest version
« Reply #8 on: December 02, 2017, 01:28:07 PM »
You can have multiple versions of PHP on the same hosting plan. Ask your host.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #9 on: December 02, 2017, 02:22:25 PM »
Ok, I will check with them, thanks for the suggestion.

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,424
  • Gender: Male
    • Kindred-999 on GitHub
Re: Error after updating to the latest version
« Reply #10 on: December 02, 2017, 08:04:40 PM »
Also, please stop demanding help with a bump only an hour after you post.

This is not a “real time” support site.
You should wait AT LEAST 24 hours before you bump a post.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #11 on: December 03, 2017, 04:06:03 AM »
Ok, sorry about that.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,539
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Error after updating to the latest version
« Reply #12 on: December 21, 2017, 06:19:38 AM »
Hi, have you been able to figure this one out? :)
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline bharat

  • Full Member
  • ***
  • Posts: 417
Re: Error after updating to the latest version
« Reply #13 on: January 17, 2018, 03:47:03 AM »
Yes, I could fix it, thanks for your help!