Advertisement:

Author Topic: PM autopopulate issues and more...  (Read 256 times)

Offline Torngate

  • Semi-Newbie
  • *
  • Posts: 30
  • Gender: Male
    • Torngate on GitHub
    • Shadow Fleet
PM autopopulate issues and more...
« on: December 11, 2017, 09:44:59 PM »
Hey,

So a few members of my forum have names as display names, or usernames, or both, with Apostrophes in them. This means that when I try and send them PM's, I Get an error saying that their username or "to-" recipient could not be found.

This used to not be a problem as when i started to type any part of their name past like two letters, it would autopopulate and register. However, recently this has stopped working for no apparent reason.

From my running things, there are a few other symptoms and I have one possible culprit.

Other Symptoms:

On the Admin page (?action=admin;area=index), in the "Live from Simple Machines". I always do not have the news, instead, a "You are Unable to connect to simplemachines.org's latest news file, and the "current SMF version" appears as two question marks.

Under "More Detailed", no results show up. All files are ?? under "Current Versions"


The only possible culprit I can think of is our cloudflare service.

Unless there's something else I'm missing?

Stats:
Browsers impacted: All Desktop browsers, most mobile ones
Occasionally Android chrome will not have issues.

Server:
SMF 2.0.15
PHP 5.6
Apache-based
Ambassador By Crip theme

Any and all help would be appreciated.

EDIT:

Why I think Cloudflare: I run a 2.1 development testbed on the same machine and service. Same issues with PM's present themselves, and occasionally with the other issues listed.

Edit 2:

I think it's totally possible these are unrelated issues, but I have no way to show. No errors show up in my logs.
Site Administrator- Shadow Fleet Star Trek RPG

Online Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,393
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: PM autopopulate issues and more...
« Reply #1 on: December 21, 2017, 11:52:06 AM »
Hi, this is a hard one really - I just tested this on 2.0.15 and it worked flawlessly for me through the suggestion list of names.
I have no Cloudflare to test out, but can't really think of a reason right now why that would interfere either.

Is this still an issue? Have you had any further luck tracking down the cause?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Torngate

  • Semi-Newbie
  • *
  • Posts: 30
  • Gender: Male
    • Torngate on GitHub
    • Shadow Fleet
Re: PM autopopulate issues and more...
« Reply #2 on: December 22, 2017, 05:29:35 PM »
Hey,

I don't know why but as of about two days ago the issue dropped off. I have no idea why but it has. The only change was our host moving what IP we were using.

Thanks for checking in anyways. I'm still at a loss of what caused it but it's working.
Site Administrator- Shadow Fleet Star Trek RPG

Online Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,393
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: PM autopopulate issues and more...
« Reply #3 on: December 22, 2017, 05:49:03 PM »
I'm still at a loss of what caused it but it's working.
Well, while the cause would be nice to know for possible future issues of similar nature, that sounds good none the less :)
Thanks for letting us know.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas