Advertisement:

Author Topic: Problems after move to new cloud based server  (Read 847 times)

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Problems after move to new cloud based server
« on: January 09, 2018, 01:32:50 AM »
Latest SMF 2.1.15 and simple portal 2.3.7
After move to new server there seem to be a language problem.
åäö in Swedish works fine i the topics and messages, but in admin it seems to be something not working, i can for exempal not name the forum to "Värmepumpsforum" (leaves a blank form efter saving.
Need to put in "Varmepumpsforum" for the name to stick.

Same issues when trying to change source code through admin panel, if i have åäö in some image title or alt tag the admin will save the changes with very corrupt code, taking away lots of code, and ADDING code never been there before.
The host tells me all settings in the server äre OK, but what can it be that makes this problems?

I also updated "Like Mod" in one of my forums (www.poolforum.se) and after upgrade i have duplicate lika mods showing in the forum...
Any ideas?
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline drewactual

  • Full Member
  • ***
  • Posts: 563
    • College Football Fan Site CFB51
Re: Problems after move to new cloud based server
« Reply #1 on: January 09, 2018, 01:54:05 AM »
did you migrate or did your server folks?

go into a directory on both locations... see if the compression or copy only went one or two sub directories deep... this was my problem when i did same thing... simple fix... port the copies file by file to new server until they match in content and structure...

trying to do it the easy way is sometimes the hard way with these things... make sure every copy of every file carried over.. obviously, if this is your issue, check the language directories first.

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #2 on: January 09, 2018, 02:00:14 AM »
It was my server folks that did the migration.
I will point him to this topic.
Can you give an example of a language file that could be missmatched after the move?
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,137
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Problems after move to new cloud based server
« Reply #3 on: January 09, 2018, 02:13:33 AM »
Sounds ike the database colliation type is wrong should probably utf8 and the file you exported from the old server should be in that format as well.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #4 on: January 09, 2018, 02:19:10 AM »
Forum is ISO-8859-1
Portal is windows-1252
Database is latin1_swedish_ci

As far as i know this has been the same before and after the mowe, I think there might be a problem with this, my server folks dont.
I dont know enough to stand my ground.

I know i should convert to UTF-8, but i tried 10 years ago and it was a total failure, i am nervous about trying again.
And, converting now when it doesnt work NOW, what would that mean?
I cant go back to an old backup, have been runnign the forums för weeks on the new server, going back to old backup would make me loose A LOT of messages and topics.
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline drewactual

  • Full Member
  • ***
  • Posts: 563
    • College Football Fan Site CFB51
Re: Problems after move to new cloud based server
« Reply #5 on: January 09, 2018, 08:59:47 AM »
my suggestion better explained is:

when the 'network managers' manage a move, they 'usually' just 'click-and-compress' a directory/folder, and then copy it over and unpack it.  this is fine, so long as they actually retrieved all the directories and files.  often times, compressors only go so deep into a directory/folder, and ignore the rest.  My personal experience is that image folders, language folders, and script folders, usually at the bottom of directories, have missing contents after a compression-and-move.

example...

on the 'old' server where everything functioned as expected (including languages) there may be a structure like:

parent directory>
     child directory + files>
             grandchild directory> more directories + files
             <same as above>
             <same as above>
             <same as above>
             <same as above>             
     child directory + files>
             grandchild directory> more directories + files
             <same as above>
             <same as above>
             <same as above>
             <same as above>
    etc....

and then on the 'new' (your cloud) server:

parent directory>
     child directory + files>
             grandchild directory> more directories + files missing
             <same as above>
             <same as above>
             <same as above>
             <same as above>             
     child directory + files>
             grandchild directory> more directories + files files missing
             <same as above>
             <same as above>
             <same as above>
             <same as above>
    etc....


to see if this is the case go to your OLD server and look at a directory- choose, for instance, Themes>default>languages and see if the contents of that folder match the contents of the folder on the NEW server file for file... go all the way to the bottom of a directory and make sure the files match on both servers.

I wager the move didn't include files in the deepest directories- which is common when people who don't have stake in a website start compressing and then using copy/paste without investigating if ALL the files are present. 

you can also simply check the weight of directories uncompressed... they should match precisely (byte size)

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,144
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Problems after move to new cloud based server
« Reply #6 on: January 10, 2018, 05:12:55 AM »
Forum is ISO-8859-1
Portal is windows-1252
Database is latin1_swedish_ci
Latin1 character sets are MySQL defaults - If you have access to PhpMyAdmin or similar, could you check what the tables in that database actually use?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #7 on: January 10, 2018, 10:22:16 AM »
I anly have access to the new server now, and all i can see in the tables is latin1 (or blank)
Checked the table xxx_messages for example.
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,144
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Problems after move to new cloud based server
« Reply #8 on: January 17, 2018, 12:35:14 AM »
Just a shot in the dark, but I'm guessing there is some sort of conflict between the current DB setup and Language files, compared to the one you had before. When you were migrated, did you get a backup of the DB for yourself?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #9 on: January 17, 2018, 01:04:12 AM »
No i did not take a backup myself, but the host tells me they have made all the right things when woving the files.

As i understand converting to UTF8 will be mandatory for the next version of SMF, maybe it would be wise to do this now, that should get rid of the problems i have?
But, this change seems to be quite difficult, a lot of people doiing this are looking for support after the convertion...
What are your thoughts about this?
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,144
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Problems after move to new cloud based server
« Reply #10 on: January 17, 2018, 01:05:46 AM »
That makes things a bit tricky. At least, before testing any major changes anywhere - backup now.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #11 on: January 17, 2018, 01:07:12 AM »
Updated the question above.
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,144
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Problems after move to new cloud based server
« Reply #12 on: January 17, 2018, 01:28:14 AM »
First, make a backup. Then, perhaps install an UTF8 language pack and try if it makes a difference. Don't do any changes to the database at this point.
There have been oddities like this with some autoinstallers in the past.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #13 on: January 17, 2018, 01:39:46 AM »
Regarding the mowe of files and database the host tells me this:
Quote
All files were transferred, we ran using the rsync tool and it moves all files that have not been changed to the new server (ie, it does not write over files that are changed at the destination). There was no manual transfer of files that they seem to suggest on the forum without a command that was executed as specific at first run:
rsync -avzhe ssh / home / dxxxxxx / root@xxxxxxxxxx: / home / olddata /

This goes through each directory automatically under / home / dxxxxx on the old server and transfers the files via ssh to the server at xxxxxxxxxxx (the new server) to / home / olddata. Then on the new server, I only moved or copied entire directories, never individual files, so that's not the fault they describe.

I have also entered and compared the catalogs to the all levels without finding something missing on new ones. The new one actually has more files than the old one, this in form of images in Csmanul_20 / images, there are 64 more pictures than on the old server. Throughout that, there is nothing on the old server that is not on new ones, but there are things on new ones that are not old, which probably came in the upgrade.
(Google translated)
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Offline drewactual

  • Full Member
  • ***
  • Posts: 563
    • College Football Fan Site CFB51
Re: Problems after move to new cloud based server
« Reply #14 on: January 17, 2018, 08:23:09 AM »
Rickard, i too migrated to a new server stack back in August.  i used the same method your host did- and the process left grandchildren and great grandchildren files stranded.. most notably stranded, were lower (as in the lowest level) files in directories such as js, css, and language... the directories were there but the files were not- at least not all of the files.  i didn't even notice at first- it wasn't until i was deep into the forum that broken style manifest itself and struck me curious...

do you use chrome? (i just tried to go to your page to look for myself, but it timed out)

if you do use chrome, use the developer tools to find broken links.  it won't show you broken language links, but it will show you broken js and css links.  if this is the case, simply go to your plugin/mods, write their names down, and seek out the mod again... DON'T install it... instead, open it up and copy the missing files, and plant them in the proper place.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,144
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Problems after move to new cloud based server
« Reply #15 on: January 17, 2018, 01:58:54 PM »
Regarding the mowe of files and database the host tells me this:
I wouldn't concentrate on the files too much, they aren't the key ( apart from language files affecting certain things ) - The database is what I'd be looking at.

If I were you, I would back up everything - and try to diagnose this situation slowly and carefully, one thing at a time.
And I would start off by seeing if switching to an UTF8 language pack makes a difference, and if it does - then what kind of difference.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #16 on: January 18, 2018, 02:44:47 AM »
We are preparing to convert one of my forums (not mentioned in my signature) www.diskussionsforum.se without the portal.
If this works, we will go ahead with one of the more important forums, with the portal.

My host tells me it probably has to do with Simple Machines configuration and PHP not being compatible with Swedish language.

Server info:

Hosting Packages: default
Server Name: xxxxx
cPanel version: 68.0 (build 26)
Apache version: 4.2.29
PHP version: 5.6.33
MySQL version: 5.6.38
Architecture: x86_64
operating Systems: linux
Shared IP Address xxxxxxxxxxxxxx
Path to Sendmail / usr / sbin / sendmail
Path to Perl / usr / bin / perl
Perl version: 5.16.3
Kernel Version: 3.10.0-514.21.1.el7.x86_64

Does this tell you something?

One thing happens yesterday when i was uploading the UTF-8 languagepack, SMF admin tells me "packages" was uploaded but ni files where uploaded, possible due to folders Packages and Temp not writable.
Both folders are writable...
This problem occured earlier on poolforum also, i dont know what solved that problem, if the host did something or not.
Waiting for his reply right now.
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,974
  • Gender: Male
    • Kindred-999 on GitHub
Re: Problems after move to new cloud based server
« Reply #17 on: January 18, 2018, 11:05:50 AM »
problems with packages being marked as applied but no changes being made are invariably due to host configuration issues.
Specifically, in these cases, php is usually being run as "nobody" which means that chmod 755/644 won't work...  775/664 may not even work... and many hosts won't allow 777/666

you have to chown the files/directories to be owned by the php user... or correctly set php to be run as the (hosting) logged in user account
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Rickard

  • Jr. Member
  • **
  • Posts: 233
  • Gender: Male
    • Värmepumpsforum
Re: Problems after move to new cloud based server
« Reply #18 on: January 18, 2018, 11:10:56 AM »
Stupid me tried to use the package manager för the language pack.
I have succesfully uploaded the package through the language tool.
Sorry for this missunderstanding.
Admin for 3 forums:
www.varmepumpsforum.com
www.poolforum.se
www.atvforum.se
SMF 2.0.15
Default Theme: CS Manual by crip
Simple Portal 2.3.7
Got my own hosted and managed server on www.space2u.com