Advertisement:

Author Topic: Forum doesn't load through www. and no SSL  (Read 384 times)

Offline Obsydian

  • Semi-Newbie
  • *
  • Posts: 20
Forum doesn't load through www. and no SSL
« on: February 05, 2018, 10:21:29 AM »
For some reason, my forum has been loading through http://thetarotforum.com/index.php [nofollow] (Not even SSL, which it should have!)
However, if you change it to http://www.thetarotforum.com/ [nofollow], you get a white page without the theme.

Is this related to the theme folders?  And how can I get SSL back up and running?

Offline drewactual

  • Sr. Member
  • ****
  • Posts: 834
    • College Football Fan Site CFB51
Re: Forum doesn't load through www. and no SSL
« Reply #1 on: February 05, 2018, 10:25:18 AM »
check the 'step by step conversion to ssl' in the server section for guidance and making sure you've done it right...

for your issue above, i wager your pointing everywhere.... search for and download repair_settings.php for your version of SMF, install and run it, then delete it... make sure ALL the paths match (https://www as opposed to http:// or http://www, ect)...

edited to add: here is the link to repair_settings.php, and instructions: https://wiki.simplemachines.org/smf/Repair_settings.php

Offline aegersz

  • SMF Hero
  • ******
  • Posts: 1,631
  • Gender: Male
  • the "mods and tweaks" junkie
    • aegersz on GitHub
    • dopetalk (drugs and users)
Re: Forum doesn't load through www. and no SSL
« Reply #2 on: February 05, 2018, 10:46:08 AM »
your site loads the same for me, with or without https or www

you are almost there so if you are running Linux then you need forcefully redirect all non-SSL (http/port 80) data to SSL (https/port 443) via .htaccess something like the following:

Code: [Select]
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://thetarotforum.com/$1 [R=301,L]
The configuration of my Linux VPS (SMF 2.0 with 150 mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,818
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Forum doesn't load through www. and no SSL
« Reply #3 on: February 07, 2018, 01:36:33 AM »
The links in the OP seem to be working perfectly fine and redirecting to https, so I'm gonna assume this is solved. :)
If however I am wrong, and there are further questions regarding this, feel free to mark this not solved again and post back to let us know.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas