Advertisement:

Author Topic: Błędy po instalacji certyfikatu SSL  (Read 632 times)

Offline siCk_BoY_

  • Semi-Newbie
  • *
  • Posts: 24
Błędy po instalacji certyfikatu SSL
« on: March 08, 2018, 05:05:08 AM »
Witam,
Moja wersja forum to 2.0.15.
Właśnie zaimplementowałem certyfikat SSL dla mojego forum.
Do zmiany URLi z http na https użyłem repair_settings.php. W Panelu Administracyjnym w lokalizacji Konfiguracja > Ustawienia serwera > Ciasteczka i Sesje zaznaczyłem "Wymuś ciasteczka w celu bezpieczeństwa".
W lokalizacji Konfiguracja > Ustawienia serwera > Główne zaznaczyłem "Włącz proxy obrazków".
Używam motywu BlueBird.
Kiedy nie jestem zalogowany na stronie to informacja o https, w pasku adresu przeglądarki, wyświetla się poprawnie zielona kłódka. Natomiast po zalogowaniu pojawia się wykrzyknik na szarej kłódce z informacją, że niektóre elementy tej strony nie były przesłane w sposób bezpieczny.

Co może być przyczyną i jak można rozwiązać ten problem?
Podejrzewam, że mogą to być jakieś skrypty z odwołaniami do http.

Ktoś miał podobne problemy i je rozwiązał?

Link do strony to podkarpackie.it [nofollow]

Offline siCk_BoY_

  • Semi-Newbie
  • *
  • Posts: 24
Re: Błędy po instalacji certyfikatu SSL
« Reply #1 on: March 08, 2018, 05:23:17 AM »
Problem został rozwiązany.
Okazało się, że w jednym artykule z modułu SimplePortal użyta została ikona, która miała odwołanie do zewnętrznego serwera z protokołem http://. Plik ikony zapisałem bezpośrednio na swoim serwerze, wskazałem ścieżkę do niego i problem zniknął.

Offline Nolt

  • Local Moderator
  • Full Member
  • *
  • Posts: 488
  • Gender: Male
  • /dev/null
    • smfpolska on Facebook
    • Wizzi
Re: Błędy po instalacji certyfikatu SSL
« Reply #2 on: March 09, 2018, 02:55:33 PM »
Świetnie, że udało Ci się rozwiązać problem oraz dać wskazówkę innym jeżeli napotkają na podobny przypadek.

Offline bod22

  • Newbie
  • *
  • Posts: 7
Re: Błędy po instalacji certyfikatu SSL
« Reply #3 on: June 01, 2018, 02:31:22 PM »
Mam podobny problem, dzisiaj zainstalowałem certyfikat i cały czas mam przekreśloną kłódkę. Póki co zrobiłem wszystko co kolega w pierwszym poście. Ktoś pomoże ogarnąć resztę?

Adres forum: strefapsx.pl/forum/index.php

Powinienem coś dodawać jeszcze w htaccess?

Używam motywu Reseller i pretty urls jakby to miało znaczenie.
« Last Edit: June 01, 2018, 03:27:35 PM by bod22 »

Offline bod22

  • Newbie
  • *
  • Posts: 7
Re: Błędy po instalacji certyfikatu SSL
« Reply #4 on: June 02, 2018, 05:28:32 AM »
Temat ogarnięty. Można scalić posty.