• Welcome to Simple Machines Community Forum. Please login or sign up.

Läuft die SMF-Version 2.0.15 mit PHP 7.2.1 ?

Started by Tina11, April 16, 2018, 02:37:00 PM

Previous topic - Next topic

Tina11

Hallo,

ich möchte in den nächsten Tagen von PHP 5.5.38 auf eine 7er-Version wechseln.
Mein Hoster bietet diese an:

PHP 7.0.25
PHP 7.1.11
PHP 7.2.1

Ist es okay, wenn ich da die 7.2.1 nehme? Läuft die SMF-Version 2.0.15 damit problemlos?

albertlast


AmaSha

Hallo.

Sorry, dass ich dieses Thema hier noch mal hervorkrame, aber ich muss bei meinem Forum auch noch etwas rumdoktorn...

Mal abgesehen davon, dass ich noch auf 2.0.15 updaten muss, aber ist es sicher (soweit man sicher sein kann), dass SMF 2.0.15 unter PHP 7.0 / 7.1 lauffähig ist? Worauf muss ich bei einem Server-Upgrade achten?

Danke im Voraus für die Antworten.
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

Tina11

Ich kann da leider nicht mehr weiterhelfen. Ich bin mit meinem Forum vor etwa zwei Monaten zu ElkArte konvertiert, einer Fork des SMF.
Dort läuft es jetzt jedenfalls problemlos mit PHP 7.2.1.  In der Software von beiden Forensysteme gibt es mittlerweile aber einige, zum Teil größere, Unterschiede.

AmaSha

Oh, schade...

Nun ja, ich würde gerne weiter mit SMF arbeiten, darum meine Frage. Aber vielleicht kann ja noch jemand anderes was dazu schreiben, bitte.
;)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

albertlast


AmaSha

Hm,

das ist nun nicht die Antwort, die ich erhofft hatte, denn ich weiß nicht, auf welche meiner Fragen Du dich beziehst:

Quote from: AmaSha on July 17, 2018, 05:36:31 AM
...
Mal abgesehen davon, dass ich noch auf 2.0.15 updaten muss, aber ist es sicher (soweit man sicher sein kann), dass SMF 2.0.15 unter PHP 7.0 / 7.1 lauffähig ist?
...

Ich gehe mal davon aus, dass Du mit Deinem JA lediglich diese Frage beantwortet hast.

Nun gut. Gibt es sonst irgendwelche Tipps, Kniffs, Hintbits die man beachten sollte, wenn man seinen Server auf PHP7 upgradet?

Klar, alles sichern, das ist logisch, aber muss ich unter SMF noch etwas im Vorfeld erledigen, damit die Portierung auf die PHP7-Umgebung reibungslos funktioniert?

Bin für jeden Hinweis dankbar. Danke im Voraus! :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

rho_simafo

Ich hab das Forum 2.0.15 zweimal installiert: die öffentlich zugängliche unter PHP 7.1 und eine Testversion zum Ausprobieren von Mods und Einstellungen  unter PHP 7.2.
Beide laufen bisher tadellos.

AmaSha

Guten Morgen.

Vielen Dank für die Info, das klingt schon vertrauenserweckend. Aber durch Deine Antwort bin ich überzeugt, dass ich auch eine Testumgebung einrichten sollte, muss ich mal einen meiner alten PCs auf Ubuntu "umrüsten"...

Vielen Dank nochmals.
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

Louis

Offiziell gibt es wohl noch Dinge im Code von 2.0.15, die nicht 7.2-kompatibel sind (ich sage nur: create_function()).
Die Version läuft unter 7.2, allerdings füllt sie dir auch dein Fehlerprotokoll sehr schnell - dafür gibt es aber ein Mod, mit dem genau diese Stellen umgebaut werden:
SMF 2.0.X - PHP 7.2+ Compatibility

Solange du nicht noch ein anderes Mod mit veraltetem Code im Einsatz hast, sollte das reichen....

It is your mind that creates this world (Buddha)

Nightwish76

Quote from: Louis on September 17, 2018, 08:17:45 AM
Offiziell gibt es wohl noch Dinge im Code von 2.0.15, die nicht 7.2-kompatibel sind (ich sage nur: create_function()).
Die Version läuft unter 7.2, allerdings füllt sie dir auch dein Fehlerprotokoll sehr schnell - dafür gibt es aber ein Mod, mit dem genau diese Stellen umgebaut werden:
SMF 2.0.X - PHP 7.2+ Compatibility

Solange du nicht noch ein anderes Mod mit veraltetem Code im Einsatz hast, sollte das reichen....

--> Wie "installiert" man das nach dem Download und dem entpacken ?

Windtänzerin

February 04, 2019, 04:25:43 AM #11 Last Edit: February 04, 2019, 04:42:00 AM by Windtänzerin
Hallo zusammen,

vermutlich habe ich das gleiche Problem nach Serverumzug. Kann mir vielleicht jemand bei einer Fehlermeldung helfen, die ich nicht verstehe?

Liebe Grüße
Windtänzerin
SMF 2.0.15
FF 65.0

Windtänzerin

Hallo Louis,

Quote from: Louis on September 17, 2018, 08:17:45 AM
Offiziell gibt es wohl noch Dinge im Code von 2.0.15, die nicht 7.2-kompatibel sind (ich sage nur: create_function()).
Die Version läuft unter 7.2, allerdings füllt sie dir auch dein Fehlerprotokoll sehr schnell - dafür gibt es aber ein Mod, mit dem genau diese Stellen umgebaut werden:
SMF 2.0.X - PHP 7.2+ Compatibility

Solange du nicht noch ein anderes Mod mit veraltetem Code im Einsatz hast, sollte das reichen....

Leider funktionierte das auch mit dem Mod nicht.
Was kann das denn dann noch sein?

Warning: require_once(/webspace/12/58763/xxx.de/forum/Sources/QueryString.php): failed to open stream: No such file or directory in /homepages/40/d4294976647/htdocs/xxx.de/forum/index.php on line 51

Fatal error: require_once(): Failed opening required '/webspace/12/58763xxx.de/forum/Sources/QueryString.php' (include_path='.:/usr/lib/php7.1') in /homepages/40/d4294976647/htdocs/xxx.de/forum/index.php on line 51

Liebe Grüße
Windtänzerin

wintstar

Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Nightwish76

Quote from: wintstar on February 11, 2019, 03:44:38 PM
Es gibt eine Mod, da läuft 2.0.15 auch unter 7.3.1. Ohne Mods gestest.

https://web-develop.ca/index.php?action=downloads;area=stable_smf_modifications;file=48

OK...nach dem Download sieht das so aus wie im Anhang. Wie installiert man das dann ?

wintstar

Geht ganz einfach  :)

Administrator-Center » Paket Manager » Pakete herunterladen

Zip Archiv damit hochladen und den Anweisungen folgen. Sollten Mods installiert sein, kann es vorkommen das dass System bestimmte stellen im Code nicht finden kann. Diese Stellen sind dann rot markiert. Drauf klicken öffnet sich ein Popup. Dann muss man mit einem geeigneten Editor diese Code Einfügungen manuell vornehmen.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Louis

It is your mind that creates this world (Buddha)

Louis

Quote from: Windtänzerin on February 04, 2019, 05:27:05 AM
Was kann das denn dann noch sein?

Warning: require_once(/webspace/12/58763/xxx.de/forum/Sources/QueryString.php): failed to open stream: No such file or directory in /homepages/40/d4294976647/htdocs/xxx.de/forum/index.php on line 51
Fatal error: require_once(): Failed opening required '/webspace/12/58763xxx.de/forum/Sources/QueryString.php' (include_path='.:/usr/lib/php7.1') in /homepages/40/d4294976647/htdocs/xxx.de/forum/index.php on line 51
Da antworte ich mal in deinem anderen Thread zum Thema: https://www.simplemachines.org/community/index.php?topic=564809.0
It is your mind that creates this world (Buddha)

Nightwish76

Damit die angezeigten Fehler auf meiner Forum Startseite weg gingen, hab ich SMF 2.0.17 runter geladen und entpackt.
(Ich hatte SMF 2.0.16 online)
Danach mit FTP die entpackten Dateien hoch geladen und alles alte einfach überschrieben (mir war nicht ganz wohl dabei :-) )
Danach die upgrade.php aufgerufen (www.meinforum.de/forum/upgrade.php).
Die Schritte ausgeführt...danach war die Fehlermeldung bzw. diese komischen Zeilen auf der Startseite des Forums weg.
Zur Sicherheit sollte man über FTP alle Ordner einfach lokal downloaden vorher und die Datenbank sichern.

Advertisement: