• Welcome to Simple Machines Community Forum. Please login or sign up.
October 15, 2021, 11:34:58 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


重新扛起SMF事业,发布简体语言包

Started by fmben, November 09, 2005, 03:58:24 PM

Previous topic - Next topic

fmben

November 09, 2005, 03:58:24 PM Last Edit: November 13, 2005, 12:52:26 PM by fmben
应 SMF 英文官方的邀请,我将在以后的发布文件中加入 UTF-8 版本,同时提供四个版本的文件,请各位看准自己需要的版本后再下载,不建议原来使用 Ansi 的朋友转换为 UTF-8,除非你经过充分的测试和备份好数据,至于新安装的朋友,请根据自己的实际情况选择。

语言包版本:SMF 1.1 RC1
发布时间:2005年11月14日


简体中文语言包已经提供了,文件也发给了smf英文官方,相信很快能在官方找到。

地址:http://www.smf.cn/bbs/index.php/topic,15.0.html

希望大家满意,如果发现什么翻译不正确的欢迎指出。

yesman123

thanks, the problem with beta3 is that upgrading to smf 1.1 rc1 fails (complaining old files).

fmben

Can you show us your site? I am not sure what you mean , you mean upgrading from 1.05 -> 1.1 rc1 or upgrading from 1.05 -> 1.1 b3 or 1.1 b3 -> 1.1rc1?

Because I am using 1.1 rc1 forum program and using 1.1 b3 skin, there are no problems.

CapriSkye

just change the lines in every language files to 1.1 RC1.....

yesman123

first, where is 1.1 b3? i could not find it...
how do you upgrade from 1.0.5 to 1.1 rc1? i am currently running 1.0.5 (with simplified chinese)...do you need to put 1.1 b3 in 1.1 rc1 and do the upgrade?
change which lines to 1.1 rc1?

CapriSkye

beta3 is not available for download anymore.
just download 1.1 rc1 upgrade package, then run upgrade.php

on top of language files, you'll see a line that tells which file it is, and its version.
just change 1.1 Beta3 to 1.1 RC1 for the time being.


yesman123

thanks. where to download 1.1 rc1 upgrade? you mean the english version?

CapriSkye

yes, isn't that what you mean? upgrading your forums?
language files don't need to upgrade, all you do is replace them with new versions.

yesman123

thanks. but is there something called chinese 1.1 b3?

yesman123

i was wondering why i need to change 1.1 b3 to 1.1 rc1 for each file? the  line is commented out already.

yesman123

this time, i did replace beta 3 by RC1 on all the language files (also and removed the tranditional), but still the problem persists.

CapriSkye

they're commented out, but smf still reads them.
what is the exact error you're getting? if you go into admin and do a version check, it tells you which file is outdated.
or you can always get the traditional chinese, i don't think you would have trouble reading it.

yesman123

it complained about the old and outdated files...i prefer simplified chinese, it is easier to type...

CapriSkye

we're not going anywhere with this....
which file does it complain about? then change the file version, this works with source files also.
just change the version to 1.1 RC1.
for example in /Sources/Admin.php you'll find this line
* Software Version:           SMF 1.1 Beta3
change that to
* Software Version:           SMF 1.1 RC1

of course you shouldn't be doing this with source files, language files are what you need to change.   

yesman123

it did not say which file or files are outdated...i did replace beta 3 with rc1 in all the language files. i will double check to see if i have missed anything...
thanks...

CapriSkye

do you know you can do a version check in admin? there's a link on the very first page when you login to admin section.

Sheepy

If the forum is complaining about version problems visibily, instead of in log, chances are it's not about language files.  Changes version of files in root folder and if problem presists, source and template folder.  A good text editor helps a lot.  I think there's a topic in some other board about it, about what smf checks.

fmben

You can download smf1.1 rc1 Chinese simplified now, I have provided it easy today, thanks. A little change in the translation, please redownload it. thanks.

http://www.smf.cn/bbs/index.php/topic,15.0.html

yesman123

thank all. i just downloaded this new chinese version and the upgrade was successful...

Leaf

谢谢fmben!小小建议:

Quote from: fmben on November 13, 2005, 12:15:21 PM
Ansi 简体中文语言包(297.11KB)
http://www.smf.cn/downloads/smf_1-1-rc1_chinese_simplified.zip

Ansi 整合简体中文安装文件(1.60MB)
http://www.smf.cn/downloads/smf_1-1-rc1_chinese_simplified_all.zip
ANSI对国外人来讲含义不大清楚,建议更名为:

GB2312 简体中文语言包(297.11KB)
http://www.smf.cn/downloads/smf_1-1-rc1_chinese_simplified.zip

GB2312 整合简体中文安装文件(1.60MB)
http://www.smf.cn/downloads/smf_1-1-rc1_chinese_simplified_all.zip

同时, 为方便MOD制作和测试, 可不可以仿照繁体中文那样, 允许同时安装GB2312和UTF-8两个语言包?
UTF-8语言包文件可以象繁体中文那样加UTF-8以示区别。
目前Sheepy的精华区MOD不支持GB2312, 就是因为简体中文的两个语言包不能并存, 来回折腾太费事。

fmben

恩,好,我重新弄一个下后发布。

bbsplay.net

Quote from: fmben on November 09, 2005, 03:58:24 PM
应 SMF 英文官方的邀请,我将在以后的发布文件中加入 UTF-8 版本,同时提供四个版本的文件,请各位看准自己需要的版本后再下载,不建议原来使用 Ansi 的朋友转换为 UTF-8,除非你经过充分的测试和备份好数据,至于新安装的朋友,请根据自己的实际情况选择。

语言包版本:SMF 1.1 RC1
发布时间:2005年11月14日


简体中文语言包已经提供了,文件也发给了smf英文官方,相信很快能在官方找到。

地址:hxxp:www.smf.cn/bbs/index.php/topic,15.0.html [nonactive]

希望大家满意,如果发现什么翻译不正确的欢迎指出。
老大,您的网站打不开呀...
我来自http://www.bbsplay.net

fmben

昨天转服务器了。现在可以了的。

Advertisement: