Advertisement:

Author Topic: 1.1.23 to 2.0.15 Upgrade Issue - Part II  (Read 2366 times)

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
1.1.23 to 2.0.15 Upgrade Issue - Part II
« on: August 02, 2018, 06:17:04 PM »
Now am getting this during upgrade
see attachment

"You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' width = 800, height = 559 WHERE ID_ATTACH = 318 LIMIT' at line 3"

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,243
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #1 on: August 02, 2018, 06:18:59 PM »
Downgrade php to 5.4, run upgrade, then bump it back to 5.6.

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #2 on: August 02, 2018, 10:43:45 PM »
Thank you. I changed php to 5.4
Went back to upgrade.php from browser but now am getting "HTTP 500 Internal Server Error"
I tried IE and Chrome just to try.

Switched back to 5.6 and now the upgrade page appears. This is what it shows [see attachment]

Quote
"username" has been running the upgrade script for the last 4 hours - and was last active 4 hours ago.

You can choose to either run the upgrade again from the beginning - or alternatively continue from the last step reached during the last upgrade.

I looked at the db scripts that are part of the upgrade package. There is a section "--- Updating thumbnails..." in the upgrade_1-1.sql file.
at the end it has:



Code: [Select]
UPDATE {$db_prefix}attachments
SET
width = $width,
height = $height
WHERE ID_ATTACH = $row[ID_ATTACH]



So ran this query on the smf.attachments table
Code: [Select]
SELECT * FROM `smf_attachments` WHERE ID_attach like '%318%'
I see the file in question. The file_hash column is blank for that one image. [see attachment]
Could I just delete this row? sure whatever image it is will not work, but maybe it's just one file/line in the db that has issue?

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #3 on: August 02, 2018, 11:06:39 PM »
Looking through the db update section for attachments table and it seems like it queries the actual files in attachments directory and populates the table with some info. And the file_hash column is blank on a lot of images, so maybe those are not encrypted.
I thought maybe I could delete the SUC50074.jpg from the attachment directory, then run script again, but that actual file name is not there.
I do see one named "_SUC50074_JPG_thumbbd830e6f92c6....." and it is 0 bytes.  There are 17 files in attachments folder that are 0 bytes.

Not sure what to do. Thanks for any suggestions or input.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,433
  • Gender: Male
    • Kindred-999 on GitHub
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #4 on: August 02, 2018, 11:17:32 PM »
Are you actually using version 1.1.23?   The official versions were stopped at 1.1.21

Also. I believe that others have had success upgrading to 2.0.13 first and then bumping to 2.0,15
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #5 on: August 03, 2018, 08:45:42 AM »
SMF 1.1.22 and 23 were from smfhacks.

If I were to try  2.0.13 then go to  2.0.15, would I first need to restore all files and databases from the backups I made, correct?

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #6 on: August 03, 2018, 10:55:35 AM »
Decided to try and delete that one image and then continue the upgrade. It got passed that part of the upgrade and now has error on this part:

Quote
Executing upgrade script 2 of 2.
Executing: "Adding permission profiles for boards." (16 of 42 - of this script)

Error!
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE id_board IN (7,9,1,13,12,4,8,10,11)' at line 3

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,433
  • Gender: Male
    • Kindred-999 on GitHub
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #7 on: August 03, 2018, 11:26:53 AM »
OK. We've encountered a difficulty here.

1.1.22 and 1.1.23 were not official SMF releases. Tehcnically, we have no idea what was done in them and we don't support them...

So, quite honestly, I have no true idea if the issues that you are encountering are due to the unofficial patches or due to something in the core, supported product.

Our upgraders are designed to work with the official releases -- so from 1.1.21 to 2.0.x -- and there is a very good chance that the issues you are encountering are due to some changes that vbgamer made in the unofficial (and untested) patches




Are you using a MariaDB or actual mySQL?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue - Part II
« Reply #8 on: August 03, 2018, 11:28:59 AM »
Thank you for the reply.
With the last error, I again returned back to the main forum/upgrade.php to continue the upgrade. it completed. I do not know if there are any issues yet, but so far testing is going well.

If there are issues that can't be fixed then will look at doing full restore of files/dbs and see if I can remove those last two 'unofficial' patches, then try again.