Advertisement:

Author Topic: Need to convert 1.x databases  (Read 1792 times)

Offline redheadturkey

  • Newbie
  • *
  • Posts: 2
Need to convert 1.x databases
« on: November 12, 2018, 01:06:01 PM »
I need a way to convert old 1.x databases to 2.x, but my hosting won't let me install a 1.x board because the php version is above what it needs to be to install it. Is there a way to convert them without installing a board? I'm going a little nuts trying to make these work.

Offline vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,505
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Need to convert 1.x databases
« Reply #1 on: November 12, 2018, 01:12:44 PM »
Yes you could. what I suggest install SMF 2.0.13
Replace the database with your old database.

Then run the upgrade package for 2.0.13
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,243
Re: Need to convert 1.x databases
« Reply #2 on: November 12, 2018, 09:38:47 PM »
Depends how early a 1.1 version was running.  May be necessary to first upgrade to 1.1.21, then 2.0.15.  You might also have difficulty running the upgrade if php version is too high, upgrader is fussy about that.

Offline Looking

  • SMF Hero
  • ******
  • Posts: 2,370
  • SMF Customization
    • jeanborde on Facebook
    • SMF Custom Themes & Custom Coding
Re: Need to convert 1.x databases
« Reply #3 on: November 14, 2018, 06:15:55 AM »
Another option: being on a host with multilevel PHP so you can switch between PHP versions.