Advertisement:

Author Topic: photos not seen by all members  (Read 575 times)

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
photos not seen by all members
« on: December 11, 2018, 09:46:31 AM »
Hello

We are running 2.0.7.   Some users are not able to see photos when using in img button.     We are also using Taptatalk but not every member has it installed and usually post threads in forum with ease in the past.  Running in to issues, some can see them and some cannot.   

Sample photo, wondering if it can be seen here.   


Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,265
Re: photos not seen by all members
« Reply #1 on: December 11, 2018, 09:52:39 AM »
upgrade to 2.0.15 and try again.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #2 on: December 11, 2018, 10:14:30 AM »
upgrade to 2.0.15 and try again.

Thanks

Kind of what I was thinking anyone was going to say but we have a lot of mods installed...simple portal, SMF Gallery Pro etc..

I am the admin and owner for the site but not too techie so jumping all the way to toe 2.0.15 makes me very nervous.   

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #3 on: December 11, 2018, 10:59:11 AM »
so, use the PATCHES instead of a full upgrade.

https://wiki.simplemachines.org/smf/Patching
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #4 on: December 11, 2018, 11:33:39 AM »
so, use the PATCHES instead of a full upgrade.

https://wiki.simplemachines.org/smf/Patching

UGH, as expected, I got all the way to 2.0.14 and my forum is down now, any ideas? 

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #5 on: December 11, 2018, 11:46:48 AM »
please describe "down"?

Also, hopefully you took a backup before you started patching?


What version of php are you running?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #6 on: December 11, 2018, 11:57:03 AM »
please describe "down"?

Also, hopefully you took a backup before you started patching?


What version of php are you running?

no i didn't take a back up.   The patching was working so smoothly until .14 now, it is down.  I cannot get repair_settings to work either

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #7 on: December 11, 2018, 11:59:17 AM »
ok... 

first, once again, please describe what "down" means?
What is your forum URL?

second, what version of php is your server running?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #8 on: December 11, 2018, 12:02:34 PM »
ok... 

first, once again, please describe what "down" means?
What is your forum URL?

second, what version of php is your server running?

Error, I get is this page isn't working .  URL . is http://www.thedetailerscafe.com/smf/index.php?action=forum

Not sure what version my php is,    does this make sense . Version information: 4.8.3

Or

cpsrvd 11.76.0.12
Database client version: libmysql - 5.1.73
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 7.2.7


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #9 on: December 11, 2018, 12:12:56 PM »
ok...

So...   it's a white screen. That indicates a server side error.

This should generate a log.
Usually, a file called error.log, errorlog. or something similar.

no, 4.8.3 does not make sense.. but neither does 7.2.7

SMF 2.0.14/15 requires 5.4 to 7.1 -- I recommend 5.6 for now and possibly 7.0 or 7.1 once everything stabilizes.




on a slightly related note..  ALWAYS take a backup before each and every mod or patch.
If all else fails, you might be able to ask your host to restore last night's backup (assuming the host does nightly backups)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #10 on: December 11, 2018, 12:14:57 PM »
ok...

So...   it's a white screen. That indicates a server side error.

This should generate a log.
Usually, a file called error.log, errorlog. or something similar.

no, 4.8.3 does not make sense.. but neither does 7.2.7

SMF 2.0.14/15 requires 5.4 to 7.1 -- I recommend 5.6 for now and possibly 7.0 or 7.1 once everything stabilizes.




on a slightly related note..  ALWAYS take a backup before each and every mod or patch.
If all else fails, you might be able to ask your host to restore last night's backup (assuming the host does nightly backups)


Where do i look for the error log to speak of?  In the php? 

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #11 on: December 11, 2018, 12:22:07 PM »
I have about 1K of this error

[11-Dec-2018 10:32:07 America/Chicago] PHP Fatal error:  Function name must be a string in /home/thedetai/public_html/smf/Sources/Load.php on line 142
and a hand full of this error

[11-Dec-2018 10:51:37 America/Chicago] PHP Fatal error:  Function name must be a string in /home/thedetai/public_html/smf/repair_settings.php on line 368

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #12 on: December 11, 2018, 12:29:00 PM »
BTW, looks like my PHP is version    5.6.23

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #13 on: December 11, 2018, 01:06:47 PM »
ok...

So...   it's a white screen. That indicates a server side error.

This should generate a log.
Usually, a file called error.log, errorlog. or something similar.

no, 4.8.3 does not make sense.. but neither does 7.2.7

SMF 2.0.14/15 requires 5.4 to 7.1 -- I recommend 5.6 for now and possibly 7.0 or 7.1 once everything stabilizes.




on a slightly related note..  ALWAYS take a backup before each and every mod or patch.
If all else fails, you might be able to ask your host to restore last night's backup (assuming the host does nightly backups)


My host upgraded our PHP to 5.6 .     SMF version 2.0.14 is now back and operational but I have goofy emjoi's all over the place.   Anyway to fix that?

site is here .  http://www.thedetailerscafe.com/smf/index.php


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #14 on: December 11, 2018, 01:10:58 PM »
looks like you have some sort of badly written replacement script...

either you picked a common thing like <space><space> or something along those lines for the wavey smiley, or you have something else doing replacements
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline rollingrock

  • Jr. Member
  • **
  • Posts: 164
Re: photos not seen by all members
« Reply #15 on: December 11, 2018, 01:25:31 PM »
looks like you have some sort of badly written replacement script...

either you picked a common thing like <space><space> or something along those lines for the wavey smiley, or you have something else doing replacements

Yeah it was a rogue one with no command line so I changed that and upgraded to 2.0.15....all good and thanks for your help today. 


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,499
  • Gender: Male
    • Kindred-999 on GitHub
Re: photos not seen by all members
« Reply #16 on: December 11, 2018, 01:27:54 PM »
glad to help. :)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.