Advertisement:

Author Topic: Many errors per second in Sub.php  (Read 367 times)

Offline Tazzo

  • Newbie
  • *
  • Posts: 3
Many errors per second in Sub.php
« on: December 13, 2018, 12:40:51 PM »
Hello All,

Please excuse me if my question is a silly one and I'm overlooking something obvious. I'm new to setting up message boards and such things.

I've set up a SMF board (2.0.15) using the core theme.

The error log fills rapidly. Apparently this is in the Sub.php file and seems to be on multiple lines, different each time.

I have 7.0 php

Best wishes, Tom

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,412
Re: Many errors per second in Sub.php
« Reply #1 on: December 13, 2018, 12:46:51 PM »
you are on php 7.2 not php 7.0. you need to downgrade to php 7.1 or lower.

Offline Tazzo

  • Newbie
  • *
  • Posts: 3
Re: Many errors per second in Sub.php
« Reply #2 on: December 13, 2018, 01:10:23 PM »
Hi There,

Thank you for your response.

I have it set on 7.0 PHP in my host settings but I only did that a couple of hours ago. Perhaps it takes time to take effect?

Many thanks, Tom

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,412
Re: Many errors per second in Sub.php
« Reply #3 on: December 13, 2018, 01:11:58 PM »
ask your host.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,621
Re: Many errors per second in Sub.php
« Reply #4 on: December 13, 2018, 04:14:30 PM »
Shouldn't take couple of hours.  On some hosts cpanel will display incorrect php version.  If forum is running, look in Admin -> Support and Cedits, if not run phpinfo.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,867
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • SMFH
Re: Many errors per second in Sub.php
« Reply #5 on: December 13, 2018, 10:38:24 PM »
If you have to run php info this may help.

What is a phpinfo() file?

Offline Tazzo

  • Newbie
  • *
  • Posts: 3
Re: Many errors per second in Sub.php
« Reply #6 on: December 14, 2018, 02:00:58 AM »
Hi Guys,

I emailed the tech peeps and they set the PHP version to 7.1 for me and the errors have stopped.
I'm grateful for your advice.

Best wishes,
Tom