Advertisement:
GCWebhosting

Author Topic: Problème d'affichage suite à réinstallation.  (Read 973 times)

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Problème d'affichage suite à réinstallation.
« on: May 05, 2019, 01:07:33 PM »
Bonjour,

Suite à des soucis de base de données je tente une réinstallation de mon forum SMF en repartant de zéro, tout ce passe bien jusqu'à la fin; l'installateur me dit que tout est Ok et en cliquant sur le lien vers le forum j'ai le message suivant:

Unable to load Themes/default/index.template.php!

Quelqu'un saurait il comment corriger ce problème ?

Par avance merci.

Bonne soirée.
PFJ

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #1 on: May 05, 2019, 05:05:51 PM »
Bonjour,

Commence par faire un repair_settings et coche Template par défaut de Smf.

Si ok et encore le même problème alors il faut revérifier touts les fichiers et remettre le pack large upgrade au complet.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline ironside.legende

  • Semi-Newbie
  • *
  • Posts: 36
Re: Problème d'affichage suite à réinstallation.
« Reply #2 on: May 06, 2019, 02:07:03 AM »
Tu fait une installation à blanc , dans un autre répertoire , tu récupère ce fameux "Themes/default/index.template.php" , et tu l'envois en remplacement sur ton répertoire désiré.
SMF: 2.0.15
SimplePortal:2.3.6

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Re: Problème d'affichage suite à réinstallation.
« Reply #3 on: May 06, 2019, 06:03:47 AM »
Merci à vous deux pour votre aide précieuse.

En réinstallant le forum en version anglaise je n'ai pas eu ce soucis, en mettant le patch langue française je n'avais plus le fichier "Themes/default/index.template.php".

A peine le temps d'aller dans le menu pour configurer les inscriptions qu'un russe venait déjà polluer...


J'aurai une autre question, je ne sais pas si je dois créer ou pas un nouveau fil, j'ai des sauvegardes de mon forum avant le crash. Peut-on les restaurer sachant que le nom de la base de données à changé et que le mode de passe également ?

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #4 on: May 06, 2019, 10:26:01 AM »
Bonjour,

Oui tu peux récupérer la base de données sans problèmes si elle est compatible avec ta version de Smf.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Re: Problème d'affichage suite à réinstallation.
« Reply #5 on: May 06, 2019, 01:46:15 PM »
Merci pour votre aide.  8)

Il s'agit de sauvegardes non compressées faites à partir du forum smf en version 2.0.15.

J'ai tenté de restaurer une sauvegarde via l'onglet base de données de mon hébergeur ( OVH ), il y a une possibilité d'importer une base de données sql. L'import semble bien se passer mais en relançant le site il y a un message d'erreur portant sur une table qui semble inexistante. Je pense que c'est lié au changement de nom de la base de données.

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #6 on: May 06, 2019, 04:31:46 PM »
Bonjour,

Quel est le nom de la table manquante ?

Avec quoi ce backup a t-il été fait ?

Le changement de nom de la Bdd ne compte en rien pour un backup.

Il faut faire un repair_settings juste après la mise en place du backup c'est tout.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Re: Problème d'affichage suite à réinstallation.
« Reply #7 on: May 07, 2019, 07:20:49 AM »
Bonjour,

Un message du "genre":
Table 'smf.smf_settings' doesn't exist

La table manquante est celle qui correspond au nom de ma base de données ( je ne sais pas si je peux la mettre en clair ) qui correspond il me semble à smf et smf_ lors de l'installation dans l'étape 2.

Le backup a été fait via le forum smf, dans la section base de données.

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #8 on: May 07, 2019, 05:14:47 PM »
Bonsoir,

C'est la table de configuration principale de Smf.

Il ne manque que celle là ou le backup est carrément incomplet ?

Si il ne manque que cette table c'est pas grave on installe une nouvelle version 2.0.15 et on remet le backup en gardant simplement la table settings de smf puis on procède comme tout upgrade.

Il faudra réinstaller tout les modules car là on repart comme si on avait une nouvelle version de Smf mais avec les tables messages etc correspondantes.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Re: Problème d'affichage suite à réinstallation.
« Reply #9 on: May 08, 2019, 08:59:32 AM »
Bonjour,

Je ne sais pas si la sauvegarde est ou non complète.

Je vais sans doute dire de grosses âneries , mais tout cela aurait été plus simple si OVH n'avait pas changer la façon dont on crée le nom de sa base de données. A l'époque j'avais utilisé le mode de création en 1 clic, mode qui n'existe plus aujourd'hui avec smf.
A l'époque les noms de base étaient du type 123456-9, maintenant il y a obligatoirement le nom du forum plus quelques caractères à ajouter.
Je pense que l'essentiel du problème vient de là.


Je ne sais pas si avec repair_settings on peut remettre un nom de type 123456-9 et 123456-9_ à la place du nom actuel de base de données. Il faudra que je tente la chose.

Mais tout ça me parait bien compliqué et je crains que mon seuil de compétences soit largement dépassé. Et dieu sait que mon seuil est bas...  ;D

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #10 on: May 08, 2019, 10:12:49 AM »
Bonjour,

Le nom de ta base n'a aucune importance.

Que son nom soit trucmachin ou 45654354 cela ne change absolument rien là concernant étant donné que tu reportes le nom de ta base créée dans le settings.php de Smf.

Par contre il te manque des tables et là c'est un autre problème.

Maintenant si tu veux tu peux me mettre un lien MP vers un backup de ta base que je puisse le récupérer pour moi voir ce qui se passe en local là c'est comme tu veux.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Problème d'affichage suite à réinstallation.
« Reply #11 on: May 09, 2019, 01:32:08 PM »
Bonsoir,

Ton forum est rétabli.

Il y a une redirection de mise pour arriver directement sur ton forum.

Tu la retires quand tu auras fini toutes tes installations.

Si soucis n'hésite pas.

Je passe en résolu.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline PFJ

  • Semi-Newbie
  • *
  • Posts: 11
Re: Problème d'affichage suite à réinstallation.
« Reply #12 on: May 09, 2019, 03:57:09 PM »
Merci beaucoup pour l'aide apportée, cela va éviter de repartir à zéro.

Encore merci maximus23.