Advertisement:

Author Topic: Clicking topic in forum generates 500 error but topic exists in database  (Read 136 times)

Offline truecrimson

  • Jr. Member
  • **
  • Posts: 102
  • Gender: Male
  • But I don't have a "favorite c compiler"!!
I have a topic with multiple replies that appears on the forum but when clicked generates this;

This page isn’t working www.thecrimsonpirate.com is currently unable to handle this request.
HTTP ERROR 500

I used PHPMyAdmin to check the database and the topic still exists with all replies.

I am running SMF 2.0.15.

Here is the other information I have been able to obtain;
Database server
Server: Localhost via UNIX socket
Server type: MariaDB
Server connection: SSL is not being used Documentation
Server version: 10.3.17-MariaDB-cll-lve - MariaDB Server
Protocol version: 10
User: cpses_troxzduh6x@localhost
Server charset: UTF-8 Unicode (utf8)
Web server
cpsrvd 11.82.0.14
Database client version: libmysql - 5.6.43
PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
PHP version: 7.2.7
phpMyAdmin
Version information: 4.8.5

My forum is restricted to only members and has restricted boards that are not visible to all members.  If you need access in order to help me PM me and I will set it up.  If you can talk me through fixing this I will do my best to follow your directions, though I am not an IT person and my knowledge is very limited.

Thank you.

Wouldn't you like to be a Llama too?

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,418
    • sbulen on GitHub
Re: Clicking topic in forum generates 500 error but topic exists in database
« Reply #1 on: September 08, 2019, 01:49:10 PM »
SMF 2.0.15 does not support 7.2 - that may be part of the problem.  You need to downgrade to 7.1.

SMF does not officially support MariaDB at this time - that may be part of the problem.  Note we have plenty of folks on MariaDB with no issues.  But we have encountered MariaDB implementations that have reserved words that conflict with SMF. 

Was this forum working fine previously, or is it new?

What mods do you have installed?

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,280
Re: Clicking topic in forum generates 500 error but topic exists in database
« Reply #2 on: September 08, 2019, 03:49:35 PM »
did this topic have any attachments in the posts?

do you have access to your server error log?