• Welcome to Simple Machines Community Forum. Please login or sign up.

2.0.16 Upgrade : You were unable to login. Please check your cookie settings

Started by MobileCS, December 30, 2019, 03:15:00 PM

Previous topic - Next topic

MobileCS

After upgrading to SMF 2.0.16, It logged me out and I am not able to log in to the forum.

QuoteYou were unable to login. Please check your cookie settings.

I have tried IE, Edge, Chrome and Firefox with the same results.

m4z

Any mods installed?

Are you trying the normal, center login form, or the top-left one? (The latter worked for me.)
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

MobileCS

I am able to log in now - I changed nothing. I'm not sure about the regular forum users though.

Is there something in the database that needs to be flushed?

m4z

Do you have a cache enabled? (Not sure if that could be the cause, though.)
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

Illori

can you log in from the header and not from the log in page?

also are you using the default theme or another theme?

MobileCS

I was blocked from logging in from the actual login page (the only method available on my forum).

I removed the "quick login" box sometime ago. I'm using the default theme.

GL700Wing

I had the same issue when there was a value for "integrate_verify_user" in the settings table in the database and "Administration Center » Server Settings » Cookies and Sessions » Use basic cookie authentication" was enabled - this will add the entry "$cookie_no_auth_secret = 1;" to Settings.php.

In my case the mod that added the value is Mobile Device Detect.
Life doesn't have to be perfect to be wonderful ...

MobileCS

I did not have either of those.

It's odd, but after I installed the patch I immediately restated Apache (to clear opcache). I could not log in on any browser. Then about 2 minutes later it just fixed itself ...

For now, I'm going to mark this as solved as everything appears to be working just fine.

movierchives

Quote from: GL700Wing on December 30, 2019, 07:40:03 PM
I had the same issue when there was a value for "integrate_verify_user" in the settings table in the database and "Administration Center » Server Settings » Cookies and Sessions » Use basic cookie authentication" was enabled - this will add the entry "$cookie_no_auth_secret = 1;" to Settings.php.

Old topic but just want to say this is what happened to me and fixed it for anyone else searching for a fix

Advertisement: