• Welcome to Simple Machines Community Forum. Please login or sign up.

2.0.17 Undefined index Errors When Running Scheduled Task

Started by sah62, January 02, 2020, 09:04:48 PM

Previous topic - Next topic

sah62

I'm seeing multiple errors like this when the "send birthday emails" scheduled task runs automatically after my upgrade to 2.0.17. I'm running PHP 7.2:

8: Undefined index: character_set
File: /var/www/mysite/web/forum/Sources/Subs-Post.php
Line: 1219

8: Undefined index: utf8
File: /var/www/mysite/web/forum/Sources/Subs-Post.php
Line: 1264

8: Undefined index: utf8
File: /var/www/mysite/web/forum/Sources/Subs-Post.php
Line: 1262

8: Undefined index: character_set
Apply Filter: Only show the errors from this file
File: /var/www/mysite/web/forum/Sources/Subs-Post.php
Line: 1219

8: Undefined index: server
File: /var/www/mysite/web/forum/Sources/Subs-Post.php
Line: 627

Is there something I can look at to fix whatever is going on?

Illori

this is a known long standing bug that we dont have a solution for.

user2020

This is also happening on mods like RSS Feed Poster.  :-[

Shambles


bulatus

After the update, there were really errors.
8: Undefined index: character_set
8: Undefined index: server
8: Undefined index: utf8
Task Manager logs (.../public_html/Sources/Subs-Post.in PHP): notifications of endorsements; Daily maintenance; Sending greetings and of course mods such as RSS poster feed.

Quotethis is a known long standing bug that we dont have a solution for.
:D

aegersz

I have this bug too on my 2.0.18 system.

It doesn't seem to be stopping the sending of birthday emails so I am not worried.

Quotethis is a known long standing bug that we don't have a solution for

I'm glad that it's not just me that can't fix certain bugs  :)

The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Sir Osis of Liver

The errors are harmless, but if you like fudge, you can do this -

Subs-Post.php



/// Fudge to remove undefined errors from scheduled tasks
if (!isset($context['server']))
$context['server'] = null;

if (!isset($context['character_set']))
$context['character_set'] = null;

etc.



There was another fix posted by one of the devs, but can't find it. >:(
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

aegersz

Thanks but I might just live with it anyway plus I can't test the fix easily -- when I run the scheduled task manually it works without errors.

The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Advertisement: