cannot upgrade 1.1.21 to 2.0.10

Started by aswuser, June 26, 2020, 07:46:47 PM

Previous topic - Next topic


I start upgrade file and after a few minutes get message Error!
Unknown Error!

phperrorlog says
Undefined index: database_error in ..../Sources/Subs-Db-mysql.php on line 594
PHP Fatal error:  Call to undefined function allowedTo() in /Sources/Subs-Db-mysql.php on line 595

If I try to run repair settings, I get the same errors -  Undefined index: database_error, PHP Fatal error:  Call to undefined function allowedTo() .

I am running php 5.3

I have searched the forums to try and find an answer but I am at a loss here in what to try next.

Any ideas?


Sir Osis of Liver

Upgrade php to 5.6, run upgrade.php, then upgrade php to 7.1.
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters


I already tried that. With php5.6, I get error these errors when I run repair settings:

PHP Deprecated:  preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in =/Sources/Load.php(225) : runtime-created function on line 3


Get a new copy of repair_settings.php

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."