• Welcome to Simple Machines Community Forum. Please login or sign up.

Php version?

Started by Memento, June 29, 2020, 07:40:06 AM

Previous topic - Next topic

Memento

Hello, sorry I am a noob.

My webmaster asked me if SMF 2.0.17 is php 7.x

I have no idea.

I am not sure if SMF uses a php version or if the php version is determined by the server where the software is installed.

Cheers

Arantor

SMF 2.0.17 works on PHP 5.4 through to 7.2.
No good deed goes unpunished
All helpful urges should be circumvented

grandseb59

hello
what happens if we go to 7.3?
How many mistakes are there?

Arantor

It's not officially supported but some people have reported it works OK. 7.4 definitely has problems.
No good deed goes unpunished
All helpful urges should be circumvented

a10

Quotephp version is determined by the server
yes

Have been using php 7.3 for a long while with no problems. Some older\non-updated mods may make trouble. If none\few mods + checking a little before installing everything should be fine.
2.0.18, ssl, php 7.4.23, 10.3.30-MariaDB<br />Mods: Contact Page, Like Posts, Responsive Curve, Search Focus Dropdown, Add Join Date to Post.

grandseb59


Advertisement: