• Welcome to Simple Machines Community Forum. Please login or sign up.
December 03, 2021, 05:53:13 PM

News:

Join the Facebook Fan Page.


Installed bad theme, now forum broken

Started by DeveloperMcD, July 30, 2020, 05:23:10 PM

Previous topic - Next topic

DeveloperMcD

I can't log in as any user, because they are all set to use the crappy, buggy Badem_RC2 theme.
I was going to sign up as a new user, elevate him to Admin, and go in and fix the theme.

But I unfortunately turned off registration! Stupid, I know.

1. Where is a user's default theme set in the Database?
2. How do you enable/disable registration in the Database? I didn't see anything in the settings table -- quite surprised and disappointed.

Sir Osis of Liver

Did you try getting in with /index.php?theme=1

smf_settings -

registration_method 0 - immediate registration
theme_default 1 - default Curve
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

shadav

did this not work for you?
Quote from: Bloc on July 30, 2020, 07:30:03 AM
Quote from: Texan777 on July 30, 2020, 02:04:18 AM
This theme KILLED my new installation!

PHP Fatal error:  Uncaught Error: Call to undefined function loadCSSFile() in /Sources/Load.php(2229) : eval()'d code:45

I can't even switch back to another theme. What a piece of junk!

That function is a SMF 2.1 function I believe, which would fail on SMF 2.0.x.

Try add ;theme=1 on the url when you are logged in as an admin user, that should get you back to be able to un-install the theme.
or this
Quote from: shadav on July 30, 2020, 05:53:58 PM
Quote from: DeveloperMcD on July 30, 2020, 05:36:52 PM
Ok, that's great, then why does this theme say it is made for 2.0.X only? That's exactly the version of the software I have installed.

It does NOT claim to be a 2.1.X only theme.
which version did you download?
there are three to choose from....I'd assume that the Badem.zip is the one that you want for 2.0.x

it doesn't state it's only for 2.0.x
I think you confused the name of the theme (I could see why) but the 2.0 in the name refers to the version of the theme not the version of smf.....
if you look at the download page it states
QuoteCompatible With:
2.0.15, 2.1 RC1, 2.1 RC2
it might be helpful if the creator puts a note which download is for which version of smf....

did what Bloc say work for you to reset to default theme?
If not you can try to use the repair settings tool https://wiki.simplemachines.org/smf/Repair_settings.php
once reset to default, delete the theme and in your admin under configuration go to themes and layout settings, then to theme settings and click on the red x to delete the template from your admin

then download the correct version of the theme for your smf version, then upload and install

Arantor

This is one good thing about 2.1, you can't do that in 2.1 since themes have to declare the version they're tagged for.

Yes, Badem.zip is the 2.0 version from what I can see.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: