• Welcome to Simple Machines Community Forum. Please login or sign up.

Error: The avatar you have selected is either too large or not an avatar

Started by Han, August 03, 2020, 07:55:43 AM

Previous topic - Next topic

Han

Yesterday a forum member of my forums tried to ajust her profile and she got the following error when she tried to save her profile.
The following errors occurred when trying to save your profile:
The avatar you have selected is either too large or not an avatar.


My forum excists since 2003 and she's been using the same avatar since the beginning. Her avatar is small, 61x61.
Members of my forum can not store avatars on my server. They can only choose an avatar from the gallery or link one they uploaded somewhere else. The linked avatars they kan use are max sized to 61x61. This size is originated from the past because of dial-up modems we used to have then. Smaller avatars resulted in faster load-time of the forum. I never changed the setting for it, because I never got complaints about the size of avatars

I tried to figure out what goes wrong.
* SMF forum version 2.0.17
* PHP Version   7.1.33 
* MySQL Version   5.7.31
* I contacted my host about it: The gd module is activated, also fileinfo and imagick are on.
* The errorlog of my forums does not mention anything about it.

When I use an avatar from the gallery all goes wel. I can make ajustments in the profile and save it.

But when an external avatar (Personalized Picture - Specify avatar by URL) is in and I make an ajustment in the profile and I trie to save it, I get the error:
The following errors occurred when trying to save your profile:
The avatar you have selected is either too large or not an avatar.


When I take the url of the avatar out of the profile, I can save the profile but when I try to put in the avatar's url again it return again with this error.

I include a screenshot of my avatar settings as attachement

I hope anyone can help me!

Arantor

No good deed goes unpunished
All helpful urges should be circumvented

Han

For example this one:  http://www.pcnavigator.nl/forum_plaatjes/avatar/bugs-krat.gif

I have an directory on my server where I can put some avatars of users that don't have acces to homepage space or so.
Sites that host pictures tend to throw them away over time so these are not used.

Arantor

Well, since if you go to that URL, it returns an error message, SMF can't get it either...
No good deed goes unpunished
All helpful urges should be circumvented

Han

Just found out that on schotlandforum.nl  I get the same error in my profile. They have the same forumversion as I have. Version 2.0.17
It this a bug that has to be attended?

When I put the url of the image in my browsers adress bar it gives me a 403 forbidden but when my husband does the same he sees the avatar.
It's getting weirder by the minute.

Same error returns when I use avatar url   http://www.pcnavigator.nl/forum_plaatjes/avatar/bugs-krat.jpg

Han

..... and this forum has the same problem.
Try to insert a url of an extern avatar and then safe your profile. You can't do that anymore.

Arantor

You can't use *THAT* avatar because when SMF tries to load it,it sees the error message.

The fact that you can't see it in your browser and I can't see it in mine is why SMF can't.

But to say it's "all avatars" is wrong, when you've used one URL that provably can't ever work...
No good deed goes unpunished
All helpful urges should be circumvented

Han

Is it then a chmod thing on the map in my hostaccount?

For the map the avatar is in CHMOD is:
* Owner: Read,write
* Group : Read
* Other: Read

Han

Found out tht it is the hotlinkprotection in my hostaccount that causes this problem.
Ihave that option "on" for quite a while and it never caused problems. Thats weird, isn't it?

Arantor

As per your other topic, this means hotlinking protection is actually working.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: