• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 09:40:44 AM

News:

Wondering if this will always be free?  See why free is better.


Upgrade Forum von 1.1.x

Started by chris69, February 11, 2021, 03:21:50 AM

Previous topic - Next topic

chris69

Hallo zusammen,
ich habe vielleicht eine ungewöhnliche Frage und bin für alle Tipps dankbar.
Meine Frau betreibt seit ca. 10 Jahren ein Forum mit ein paar Freundinnen. Dieses hat nun einen Stand (1.1.21) erreicht an dem es nicht mehr wirklich betrieben werden kann, ohne dass es auf eine neue Version gehoben werden sollte.
Nun habe ich versucht mich ein wenig einzulesen und bin zumindest ein wenig schlauer geworden, bräuchte aber an der einen oder anderen Stelle noch ein wenig Gedankenstütze.

wir haben vor das Forum auf den aktuellen Stand 2.0.118 zu heben. Hierzu habe ich gefunden, dass es ein großes Upgrade gibt, welches auch die notwendigen Schritte durchführt. Dazu soll der Inhalt der zip-Datei in das aktuelle Forum eingespielt werden und dann per Programm der Upgrade gestartet werden. Es ist mir allerdings noch nicht so ganz klar, wie das Forum dann die "alten Informationen" wiederfindet, die in den Einstellungen eingetragen sind.

Irgendwie fehlt mir hier in der Beschreibung ein Schritt in dem ich bestimmte Dateien sichere und hinterher wieder an die alte Stelle bringe und ggf. noch einige Anpassungen machen muss.
Gibt es irgendwo eine Beschreibung, welche Dateien dies sind und was ggf. anzupassen ist?

Vielen Dank für Eure Hilfe.
Chris

m4z

Quote from: chris69 on February 11, 2021, 03:21:50 AM
wir haben vor das Forum auf den aktuellen Stand [2.0.18] zu heben. Hierzu habe ich gefunden, dass es ein großes Upgrade gibt, welches auch die notwendigen Schritte durchführt. Dazu soll der Inhalt der zip-Datei in das aktuelle Forum eingespielt werden und dann per Programm der Upgrade gestartet werden. Es ist mir allerdings noch nicht so ganz klar, wie das Forum dann die "alten Informationen" wiederfindet, die in den Einstellungen eingetragen sind.

Irgendwie fehlt mir hier in der Beschreibung ein Schritt in dem ich bestimmte Dateien sichere und hinterher wieder an die alte Stelle bringe und ggf. noch einige Anpassungen machen muss.

Vorweg: Ein (im besten Fall regelmäßiges) Backup ist in jedem Fall ratsam, sowohl der Dateien als auch der Datenbankinhalte.

Ich vermute du gehst davon aus, dass mehr oder weniger "alle" Einstellungen in Dateien gespeichert sind, das ist ein Irrtum: Nur wenige, essentielle Infos, wie die Zugangsdaten zur Datenbank, sind in der Settings.php gespeichert (in 1.x könnte die Datei anders heissen, ich hab mit der Version keinerlei Erfahrung).

Die weiteren Einstellungen des Forums sind in der Datenbank gespeichert, genau wie alle Beiträge etc. Direkt als Dateien (neben dem Programmcode aus dem Zip-Archiv) abgelegt werden nur Dinge wie Dateianhänge, Benutzerbilder und ggf. Cache-Dateien (Dinge, die den Seitenaufruf beschleunigen sollen).


Quote from: chris69 on February 11, 2021, 03:21:50 AM
Gibt es irgendwo eine Beschreibung, welche Dateien dies sind und was ggf. anzupassen ist?

Falls du des Englischen mächig bist, gibt es hier eine Anleitung: https://wiki.simplemachines.org/smf/Upgrading

Beachte auch die Voraussetzungen für 2.0.x, die könnten sich von denen für 1.1.x unterscheiden (habe ich nicht geprüft, ich gehe aber stark davon aus).
Falls du mit dem Upgrade auch den Server(anbieter) wechselst, siehe ebenfalls hier

Um die Downtime möglichst gering zu halten, lohnt es sich oft, eine "Staging"-Kopie des Forums anzulegen, um dort einen Probelauf des Upgrades durchzuspielen, während das "produktive" Forum noch unverändert weiter läuft. (Hierzu benötigst du dann das Tool repair_settings, um die Einstellung der Staging-Kopie anfangs an die veränderte Umgebung anzupassen.)

Ich hoffe, das sind ausreichend Gedankenstützen, um dich erstmal in die richtige Richtung zu "beschäftigen". ;)
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

chris69

Hallo m4z,

erst einmal Danke für Deine Ausführungen.

Ich habe beim ersten mal ein Backup gemacht und erst einmal das "Testforum" upgegradet. In der englischen Version steht auch alles prima beschrieben, ich glaube nur nicht so ganz richtig.

Ich habe also die große Upgrade Datei heruntergeladen nachdem ich das Backup gemacht hatte. Danach habe ich - wie beschrieben - alle Dateien aus der Datei per ftp in das Laufwerk auf dem Server kopiert und dabei "alle" bestehenden Dateien überschrieben. Danach habe ich das Upgrade gestartet und es lief auch erfolgreich durch. Danach hatte ich eine blanke Seite und alles war weg. Ich vermute daher mal, dass ich einige der Dateien - wie z.B. Settings.php nicht überschrieben lassen sollte bzw. diese vorher in *.bak o.ä. Kopieren sollte.
Ich finde aber nicht wirklich eine Liste der Dateien, da - wie Du beschrieben hast - nicht alles in der Settings.php enthalten ist.

Das Tool repair_settings werde ich mir mal anschauen. Vielleicht beinhaltet dies ja die Informationen, die ich benötige.

Danke jedenfalls mal vorab.

Grüße
Chris

m4z

Quote from: chris69 on February 15, 2021, 03:21:30 AM
Ich habe beim ersten mal ein Backup gemacht und erst einmal das "Testforum" upgegradet. In der englischen Version steht auch alles prima beschrieben, ich glaube nur nicht so ganz richtig.

Kannst du genauer beschreiben, was du für falsch hältst? Die Doku wurde in den letzten 15 Jahren bestimmt von tausenden Person getestet.


Quote from: chris69 on February 15, 2021, 03:21:30 AM
Ich habe also die große Upgrade Datei heruntergeladen nachdem ich das Backup gemacht hatte. Danach habe ich - wie beschrieben - alle Dateien aus der Datei per ftp in das Laufwerk auf dem Server kopiert und dabei "alle" bestehenden Dateien überschrieben. Danach habe ich das Upgrade gestartet und es lief auch erfolgreich durch. Danach hatte ich eine blanke Seite und alles war weg. Ich vermute daher mal, dass ich einige der Dateien - wie z.B. Settings.php nicht überschrieben lassen sollte bzw. diese vorher in *.bak o.ä. Kopieren sollte.

Ich weiss nicht viel über den Installer, aber wenn die Installation erfolgreich durchläuft, wurde anfangs deine Settings.php gefunden und verwendet (bzw. ich glaube, SMF legt automatisch eine Backup-Datei an und der Installer merkt, dass es die Backup-Datei gibt und schreibt die Optionen wieder in die Settings.php, so dass es egal ist, dass du die Settings.php aus dem Upgrade-Paket hochgeladen hast). Alle Dateien im Upgrader-Paket sollen verwendet/überschrieben werden (sonst wären sie nicht in dem Upgrade-Paket enthalten).

Der "Whitescreen of death" hinterher kann diverse Ursachen haben, wie zB. eine inkompatible PHP-Version, unpassende Dateiberechtigungen, etc. Das Logfile deines (Web-)Servers sollte hier Aufschluss geben, dort wird eine PHP-Fehlermeldung (o.ä.) drin stehen.
Würde es sich (nur) um ein Problem mit den Settings handeln, würde SMF zumindest die Ursache anzeigen können, z.B. (sinngemäß) "falsche oder fehlende Datenbankinformationen". Der WSOD deutet aber darauf hin, dass irgendetwas bereits verhindert, dass der PHP-Code erfolgreich ausgeführt wird (oder es kommt bei der Ausführen zu einem kritischen Fehler). Das kann auch (mit) durch die Settings.php verursacht werden, aber ich würde erstmal von einem anderen Problem ausgehen und die Webserver-Logs prüfen.


Quote from: chris69 on February 15, 2021, 03:21:30 AM
Ich finde aber nicht wirklich eine Liste der Dateien, da - wie Du beschrieben hast - nicht alles in der Settings.php enthalten ist.

Welche "Dateiliste" möchtest du genau haben? Die Dateiliste des Upgrade-Archivs bekommst du z.B. über entsprechende Entpacker (GUI oder Kommandozeile), die Dateiliste deines Forums/Servers z.B. über Shellbefehle oder die Dateiverwaltung deines Hosters. (Bei Linux-Servern kann ich helfen, bei Windows-Servern vermutlich eher nicht.)


Quote from: chris69 on February 15, 2021, 03:21:30 AM
Das Tool repair_settings werde ich mir mal anschauen. Vielleicht beinhaltet dies ja die Informationen, die ich benötige.

Das Tool verwendet ebenfalls die Settings.php und versucht, fehlerhafte Einstellungen in der Datenbank (und vermutlich auch Probleme mit Datei-Berechtigungen etc.) zu erkennen und zu korrigieren. Wenn du keinen Server-Umzug gemacht hast, solltest du es vermutlich nicht brauchen, aber schaden tut es eigentlich nie.
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

Matthias

Benutzt du das Default Theme oder ein eigenes? Ich kann mir gut vorstellen, dass es daran liegt.

Lade mal die repair_settings.php in dein forum root Verzeichnis hoch, rufe die Datei auf, indem du im Browser die direkte URL eingibst, etwa so: deinedomain.tld/testforum/repair_settings.php und stelle das Theme auf "Default Theme" um. Das findest du dort ganz oben.
Quality first

Advertisement: