Advertisement:

Author Topic: New members that are approved by admins, email is not sent to user  (Read 2712 times)

Offline dominicm

  • Newbie
  • *
  • Posts: 2
The user is never notified that their account is approved, even thought the initial email states. "Before you can login and start using the forum, your request will be reviewed and approved. When this happens, you will receive another email from this address."

I tested with 2.0.17 and 2.0.18.

The only workaround is to use the message feature from the forums but I wish the issue is fixed.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 20,366
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • Aleksi Kilpinen
Re: New members that are approved by admins, email is not sent to user
« Reply #1 on: March 24, 2021, 02:35:25 AM »
How did you approve the accounts?
Do you get any errors in your log?
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Online GL700Wing

  • Charter Member
  • Sr. Member
  • *
  • Posts: 730
  • Gender: Female
    • GL700Wing on GitHub
Re: New members that are approved by admins, email is not sent to user
« Reply #2 on: March 24, 2021, 04:24:58 AM »
The user is never notified that their account is approved, even thought the initial email states. "Before you can login and start using the forum, your request will be reviewed and approved. When this happens, you will receive another email from this address."

I tested with 2.0.17 and 2.0.18.

The only workaround is to use the message feature from the forums but I wish the issue is fixed.
If you approve/reject a new member's account via their profile they will not receive an email message advising them their account has been approved/rejected - they will only receive an email message if you approve/reject their membership request via the Administration Center.  In addition, you can only require account activation if you approve a membership request via the Administration Center.

I came across this known non-issue about six weeks ago and created the following tip/trick topic to change these behaviours: Activation Required and Emails for Accounts Approved via Member Profile.
Life doesn't have to be perfect to be wonderful ...