Advertisement:

Author Topic: Joomla  (Read 9774 times)

Offline rotor

  • Jr. Member
  • **
  • Posts: 122
  • Gender: Male
Joomla
« on: November 22, 2005, 08:21:47 PM »
Hi,

Firstly my apologies - I realise this has been asked and people have answered before but I just cannot seem to locate just where and what the answer is.

Is there a way to stop the redirects back to smf after logging in and out of Joomla ???

Joomla   - 104
smf SMF - 1.1 RC1
bridge - MOS_SMF_BRIDGEv3[1].19a_SMF1.1b3.zip

Orstio

  • Guest
Re: Joomla
« Reply #1 on: November 22, 2005, 08:33:48 PM »
Joomla admin panel> Modules Menu>Site Modules

Find mod_smf_login in the list.  Click on it.

Set the params for redirecting to what you want.

Make sure to click Save at the top of the page.

Offline rotor

  • Jr. Member
  • **
  • Posts: 122
  • Gender: Male
Re: Joomla
« Reply #2 on: November 22, 2005, 08:55:13 PM »
Orstio,

Since inception I have been doing it that way .... but it does not matter what I pick it still goes to smf page whether I am wrapped/unwrapped. The only fixes I can find are you earlier versions ... there is 1 mention of problems with Joomla but nothing more I can find

this happens on my 2 sites - one is a fresh install yesterday

thanks for your help

rotor
« Last Edit: November 22, 2005, 08:58:50 PM by rotor »

Orstio

  • Guest
Re: Joomla
« Reply #3 on: November 22, 2005, 09:02:40 PM »
Do you have a URL?

Offline rotor

  • Jr. Member
  • **
  • Posts: 122
  • Gender: Male
Re: Joomla
« Reply #4 on: November 22, 2005, 09:20:50 PM »
Site 1

Rotorcraft Australia

Site 2

Ultra Flight

Login for you on both sites:

Username test
PW          test

PS I have tested with IE and Opera - not in Firefox/Mozilla
« Last Edit: November 22, 2005, 09:22:52 PM by rotor »

Orstio

  • Guest
Re: Joomla
« Reply #5 on: November 22, 2005, 11:46:47 PM »
Yes, it is what I thought. 

The first one is unwrapped, which is a known issue.  The option for "Back to the page from which the user logged in" will not work for the unwrapped forum.

The second one, though wrapped, does not display the login module, so it runs into the same issue.  That can be solved, however, by adding this code to your Joomla template:

Code: [Select]
$_SESSION['return'] = 'http://' . $_SERVER['HTTP_HOST'] . $_SERVER['PHP_SELF'] . '?' . $_SERVER['QUERY_STRING'];

Offline rotor

  • Jr. Member
  • **
  • Posts: 122
  • Gender: Male
Re: Joomla
« Reply #6 on: November 23, 2005, 12:29:41 AM »
Orstio,

thank you for the fix and the info. It worked on the wrapped forum and I'll be changing the unwrapped forum to suit.

Once again - thanks for your time

Rotor