• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 01:48:29 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Feature Request: new member is not required to accept the registration agreement

Started by viking9, August 29, 2021, 12:48:11 PM

Previous topic - Next topic

viking9

I would like to make a feature request then:
If the checkbox "Require user to accept the registration agreement:" is checked when Admin is registering a new member, it would then require the new user to accept the registration agreement.

viking9

To give some background to this feature request that was split from a bug report (https://www.simplemachines.org/community/index.php?topic=578693.new#new):

When I, as Admin, register a new member I enter their username and E-mail. I have also checked "Require user to accept the registration agreement:".
The new member then gets an E-mail with his username and password and can log in immediately.
However, the new member never needs to accept the registration agreement.

I am using SMF 2.0.18
This is what it looks like:


In the other thread, it was concluded that the checking the "Require user to accept the registration agreement:" should not require the member to accept the registration agreement.

My feature request is that it should. 

Shades.

Mine works fine! I just added a new member via admin, got the new member email, clicked the link to activate and log in, once logged in it sent me straight to the user agreement and wouldn't let me do anything until I clicked on "Agree" at the bottom.  8)

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

viking9

Quote from: Shades. on August 30, 2021, 02:14:31 PMMine works fine! I just added a new member via admin, got the new member email, clicked the link to activate and log in, once logged in it sent me straight to the user agreement and wouldn't let me do anything until I clicked on "Agree" at the bottom.  8)
That is strange. It doesn't work for me and others in the "bug" thread. The response in the other thread was that it shouldn't work..
However, it may work if you have modified the default registration agreement? I think that it should work in either case (that is why I had reported it as a bug).

Advertisement: