• Welcome to Simple Machines Community Forum. Please login or sign up.
October 19, 2021, 04:10:43 PM

News:

Join the Facebook Fan Page.


How can I convert my Smf 2.0 to 2.1 RC4

Started by Xpresskonami, September 24, 2021, 10:47:21 PM

Previous topic - Next topic

Xpresskonami

It's been a while I visit smf website. On getting here I found this new template beautiful and easy to use. I want to convert my forum to this type of version. I use smf 2.0.18

How can I covert my smf version to this type of version SMF 2.1 RC4 without losing any of my database files ???

shadav

use the 2.1 rc4 Large upgrade file
keep in mind you won't lose anything in your database but it will reset the forum itself to default
2.0.x themes and mods will not work on 2.1 rc4 so you will lose all themes and mods installed but no posts, users, ect will be lost

also keep in mind that it is still in release candidate so there will be bugs and need to be constantly updated, it's not really meant for a live environment and as an rc there's limited themes and mods currently available

Xpresskonami

Ok thank you. It's actually the bugs I'm trying to avoid. I will work on this, but it seems my current version of smf 2.0.18 has lot of bugs such as (post limit not working) and also (sitemap error) will all this smf 2.1 fix up all error for me when I upgrade??

shadav

well sitemap is not part of smf by default, that's a mod, so you would need to check and make sure that the mod you installed is installed correctly
and post limit not working, that depends on what the issue is

updating to 2.1 rc4 might fix the issues might not as in the post limit if it's a database issue updating may not fix it and well it won't do anything about sitemap as again that's not a core feature, that's a mod and not sure if the mod has been updated for 2.1 rc4, so updating would remove the sitemap all together

more than likely your current issues are due to mods you've installed
while updating to 2.1 rc4 may fix these issues again do keep in mind it's a release candidate and will have bugs in it and will need constantly updated

Xpresskonami

Yes I agree the sitemap is a mod. But in the post limit, it is not a mod but I just start having error with it. When I publish a new post worth of 800 content words it will limit the post words to either 50 or 60, it is after I modify the topic and re-post I will have the full content. I check on my limit topic and it is currently at 0, I switch it to 60000, still having same error. And this is from the script not a mod. I'm think if it will fix it or not after I upgrade

shadav

yes it is a core feature, however something you installed or a theme you are using most likely is causing the issue

Illori

Quote from: shadav on September 25, 2021, 12:44:02 AMyes it is a core feature, however something you installed or a theme you are using most likely is causing the issue

not always, if they are copying the text from word for example then for sure they need to convert to UTF-8 and that should fix the issue.

Xpresskonami

Quote from: Illori on September 25, 2021, 06:25:53 AM
Quote from: shadav on September 25, 2021, 12:44:02 AMyes it is a core feature, however something you installed or a theme you are using most likely is causing the issue

not always, if they are copying the text from word for example then for sure they need to convert to UTF-8 and that should fix the issue.

Not working after converting to UTF-8 still having same error.

Arantor

And as per your other thread you don't say what error you have. You just say you have a problem. The symptoms and exact behaviours matter.

Do you get a message, if so what does it say? If it cuts off, where exactly does it cut off? What does it cut off at? Are you copying from a Word document? What are you copying if so? Does it do it here in the test board?
No good deed goes unpunished
All helpful urges should be circumvented

Xpresskonami

Quote from: Arantor on September 25, 2021, 09:31:31 AMAnd as per your other thread you don't say what error you have. You just say you have a problem. The symptoms and exact behaviours matter.

Do you get a message, if so what does it say? If it cuts off, where exactly does it cut off? What does it cut off at? Are you copying from a Word document? What are you copying if so? Does it do it here in the test board?

It didn't show any error. I got most of my content on WhatsApp. Likewise on some top newspapers website. This didn't brings any specific place it cut off. It just seems to works like when I post the content it automatically delete the rest of the content.



Arantor

And if you do it here in the test board does it cut it off?

Cutting off the way you're describing implies there's something damaged about the content because if it were cutting off due to SMF *configuration* you'd get a message about it (or you'd be cut off at much longer than the limits you're talking about)
No good deed goes unpunished
All helpful urges should be circumvented

Xpresskonami

Quote from: Arantor on September 26, 2021, 09:05:59 AMAnd if you do it here in the test board does it cut it off?

Cutting off the way you're describing implies there's something damaged about the content because if it were cutting off due to SMF *configuration* you'd get a message about it (or you'd be cut off at much longer than the limits you're talking about)

The error is due to this symbols " and ' whenever it's included in my content it will cut out from where it start in the content. For example

Smf is "simple machine forum"

It will cut it to

Smf is

Kindred

And, as we have said several times that exact error is always it's always... always the problem of UTF8 conversion
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Xpresskonami

Quote from: Kindred on September 26, 2021, 11:34:49 AMAnd, as we have said several times that exact error is always it's always... always the problem of UTF8 conversion

How can I fix this ?? I don't have any issues about this before

Shades.

Admin>Maintenance>Forum Maintenance>Database>Convert HTML-entities to UTF-8 characters>Run Task Now

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Xpresskonami

Quote from: Shades. on September 26, 2021, 03:13:24 PMAdmin>Maintenance>Forum Maintenance>Database>Convert HTML-entities to UTF-8 characters>Run Task Now

I GOT THIS ERROR

Column 'subject' cannot be part of FULLTEXT index
File: /home1/user/public_html/Sources/ManageMaintenance.php
Line: 666

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.18, while your database is at version 2.0.13. The above error might possibly go away if you execute the latest version of upgrade.php.

Xpresskonami

Quote from: Xpresskonami on September 26, 2021, 07:53:20 PM
Quote from: Shades. on September 26, 2021, 03:13:24 PMAdmin>Maintenance>Forum Maintenance>Database>Convert HTML-entities to UTF-8 characters>Run Task Now

I GOT THIS ERROR

Column 'subject' cannot be part of FULLTEXT index
File: /home1/user/public_html/Sources/ManageMaintenance.php
Line: 666

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.18, while your database is at version 2.0.13. The above error might possibly go away if you execute the latest version of upgrade.php.

How can i fix this

Arantor

So what mods did you install? I want to guess you installed some kind of related topics mod at some point? Are you still going to try to install it after the upgrade?

Also in answer to your question about how you can fix it, please note that bumping in under 24 hours is considered rude since we're all volunteers doing this when we have the time.
No good deed goes unpunished
All helpful urges should be circumvented

shadav

Quote from: Xpresskonami on September 26, 2021, 07:53:20 PM
Quote from: Shades. on September 26, 2021, 03:13:24 PMAdmin>Maintenance>Forum Maintenance>Database>Convert HTML-entities to UTF-8 characters>Run Task Now

I GOT THIS ERROR

Column 'subject' cannot be part of FULLTEXT index
File: /home1/user/public_html/Sources/ManageMaintenance.php
Line: 666

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.18, while your database is at version 2.0.13. The above error might possibly go away if you execute the latest version of upgrade.php.

depends on where the column subject is
is it the one under the messages table?
if so mine is set to varchar(255)

Xpresskonami

Quote from: Arantor on September 27, 2021, 11:04:11 AMSo what mods did you install? I want to guess you installed some kind of related topics mod at some point? Are you still going to try to install it after the upgrade?

Also in answer to your question about how you can fix it, please note that bumping in under 24 hours is considered rude since we're all volunteers doing this when we have the time.

Similar topic mod.

Advertisement: