News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Merge Topics Bug?

Started by Steve, April 19, 2022, 02:18:21 PM

Previous topic - Next topic

Steve

I tried to merge this topic:

https://www.simplemachines.org/community/index.php?topic=581906.0

and this topic:

https://www.simplemachines.org/community/index.php?topic=576301.0

and got this error:

Merge topics requires at least two topics to merge.

Bug or something else?

[edit] link fixed --Illori
DO NOT pm me for support!

Diego Andrés

Perhaps is because the topic is pending approval?

SMF Tricks - Free & Premium Responsive Themes for SMF.

Arantor

You should be able to merge even unapproved topics if you are the merger have permission to approve posts in the board where the target topic will end up.

Diego Andrés

I noticed the first post is linking to a different topic that the intended one, it's supposed to be this one:
https://www.simplemachines.org/community/index.php?topic=581906.0

Not that it makes any difference I suppose.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Arantor

Also, I'm not sure merging things into mod threads is necessarily a good idea? Though I haven't seen the code for the new mod site - but in the old mod site Bad Things could happen if this were done incorrectly.

Diego Andrés

Tried locally with no issues, shows up as an unapproved post in the mod topic, so no clues at the moment.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Illori

When you go to merge the 2 topics it only shows you one topic to merge. It should have 2 topics here instead of one. You cannot view this attachment.

Arantor

Do you have permission to merge topics in the relevant board? The mod board's permissions are special IIRC.

Illori


Steve

Thanks for the correction Diego. The one you linked to is actually the one I tried to merge with the other my first post. And I tried merging in either direction, i.e. starting with https://www.simplemachines.org/community/index.php?topic=581906.0 and when that didn't work I tried it the other way, starting with https://www.simplemachines.org/community/index.php?topic=576301.0 ... same error.
DO NOT pm me for support!

Steve

Quote from: Diego Andrés on April 19, 2022, 02:20:35 PMPerhaps is because the topic is pending approval?
Apparently the topic must be approved first. I approved it and the merge went without a hitch.
DO NOT pm me for support!

Advertisement: