News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Preview post not working, also format toolbar not showing

Started by Railrover, September 25, 2022, 04:02:55 AM

Previous topic - Next topic

Railrover

SMF 2.1.2 with no mods installed.

Think it may be down to a permissions issue somewhere (although I don't get anything showing up when I run the file permissions checker.

Detailed version check shows 2.1.2 for everything.

I've use the "Restricted - minimum files writeable" profile from the package manager File Permissions screen.

Any ideas?

Cheers

Mike

Steve

Do you have the same problem if you select 'Apply individual file permissions settings ...'?
Please do not PM me for support.

Railrover

Quote from: Steve on September 25, 2022, 07:01:47 AMDo you have the same problem if you select 'Apply individual file permissions settings ...'?

Thanks for getting back to me, Steve.

I can certainly try - but I'm not sure what permissions I need to give, and to what files.

Cheers

Mike

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Railrover

Yup - that's what I have (at least according to the SMF File Permissions Checker)

Unfortunately, the only way of checking seems to be to trawl through every directory.  Would anybody have a pointer where I need to double check in case I've missed anything?  If I can find out which file(s) are responsible for showing the format toolbar when you post a message it might help me to see if I've missed one somewhere.

Cheers

Mike

Sir Osis of Liver

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

live627


Kindred

Your FTP or file manager should allow you to apply chmod permissions in a RECURSIVE manner, changing all files and directories at the same time.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Railrover

But I still don't know which files or folders I'm looking for to set permissions on (they all look fine anyway).

See the difference between posting on the SMF forum (this one) and posting on my own board.  Regarding Javascript - what do I need to tell my ISP to do to get it working?

I do appreciate your help so far  ;D

Cheers

Mike

Railrover

Quote from: Sir Osis of Liver on September 26, 2022, 08:24:59 PMWhich theme are you using?


Just the bog standard theme - I've running a completely vanilla board.

Cheers

Mike

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sir Osis of Liver

How many files do you have in /Themes/default/scripts/?

What is your setting in Admin > Features and Options > Source for the jQuery Library?
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Railrover


Railrover

Quote from: Sir Osis of Liver on September 28, 2022, 11:44:59 AMHow many files do you have in /Themes/default/scripts/?

What is your setting in Admin > Features and Options > Source for the jQuery Library?


52 files in total.

JQuery: Source = Google CDN and url is blank (are we onto something here??)

Cheers

Mike

Sir Osis of Liver

There are 34 files in /scripts in clean 2.1 install, the rest must be from mods.  Not likely it's a jquery issue, bbc buttons and smileys use js, not jq.  Google cdn should work, the url field is blank unless you're using custom source.  Other jq features such as user dropdown wouldn't work if jq wasn't working.  Do any of the script files have a .js~ extension?
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Railrover

Quote from: Sir Osis of Liver on September 28, 2022, 09:38:06 PMThere are 34 files in /scripts in clean 2.1 install, the rest must be from mods.  Not likely it's a jquery issue, bbc buttons and smileys use js, not jq.  Google cdn should work, the url field is blank unless you're using custom source.  Other jq features such as user dropdown wouldn't work if jq wasn't working.  Do any of the script files have a .js~ extension?


OK - so this install is an upgrade from a 1.X installation (which may have had some mods but were disabled prior to upgrading).  It also looks like I don't have the ability to cascade file permissons, so several of the javascript files had incorrect permissions set (by default everything gets copied with very restricted permissions, which I need to go and change explicitly).

After setting the files to 0644 it looks like we are back in business.

Many, many thanks for helping me out in this.

Cheers

Mike

Advertisement: