News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

problem with user login after changing the registration agreement

Started by fotosukces, April 14, 2023, 07:07:58 AM

Previous topic - Next topic

fotosukces

Hi
I changed the content of the agreement that the user accepts during registration. I approved the changes and logged out of the administrator account. I logged into user account and the new content of the user agreement appeared immediately, but without any button to accept this agreement.
The user cannot press the accept button because the button does not exist. The user cannot enter the forum home page, cannot enter the forum profile, cannot enter anywhere. He is logged in, but the full content of the forum use agreement is displayed immediately. There is no accept or disapprove button.
What can I do in this situation?

Have any of you had a similar problem? May I ask for a hint where and what should be done so that the user can continue to use the forum?

I have a forum: SMF 2.0.19

Kindred

hmmmmm....  I don't think that 2.0.19 had logic to require a re-acceptance - I thought that was a 2.1 feature in the core
(of course I could be wrong, I haven't had my first cup of coffee yet)

If that is true, however, that is probably a mod on your side.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

fotosukces

from this the conclusion that I should uninstall the mods one by one, and check each time, user login, if everything is ok.

Thank you for the hint. I will uninstall the mods.
Maybe it's just that I messed something up.

Kindred

well, I'd look at mods that involve new users, user agreement, or GDPR
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Kindred

I take it back. I have had my coffee an had a chance to test it...

That **IS** part of 2.0.19

However, the button was present for me...   What is your site URL?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."


Sir Osis of Liver

Button is displayed, goes to registration form.  Clear your browser or try different browser.

2.0.19 core does this when agreement is edited -

This will force all members to re-read and accept the registration agreement in order to continue using the forum.

It's not an option.

Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

fotosukces



Clearing the browser and changing it did not work. I gave an example user who does not see the button after logging in. And that's my problem.
But I just figured out how to get around it. As this problem appeared today after editing the contract, I will ask the hosting to give me a copy from yesterday. I will upload it and I will not change the content of the contract.

Thank you for your comments and for trying to help.

Steve

Wait, you just gave us one of your member's name and password???

Edit: I've removed it for now until you answer my question.


And what you're going to do doesn't solve the problem, it just circumvents it.
DO NOT pm me for support!

Kindred

Ummmmm.
No.

If you have this problem with the revised agreement,  then any new user will have that problem with the original agreement.  However,  I believe that your problem is YOUR browser, not the system
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: