Can't upgrade/Changing column names/Server hasn't responded for 30 secs

Started by overdue, February 09, 2024, 04:08:55 PM

Previous topic - Next topic

overdue

I get the following error trying to upgrade to the latest version. Unfortunately, I can't remember what version I was originally on and don't know where I can find the version while being stuck on the upgrade.
QuoteOverall Progress
14%
Step Progress
0.2%
Time Elapsed: 43 mins, 42 seconds.
Database Changes
Executing database changes
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made.
Executing upgrade script 1 of 2.
Executing: "Changing column names." (1 of 42 - of this script)
Error!
Server has not responded for 30 seconds. It may be worth waiting a little longer before trying again.Click here to try again.

I keep trying but it always ends with the server not responding error. I don't know what to do. It's been a while since I messed with SMF and it was an empty forum meaning there's no posts or users at the moment (I had previously been working on it -mods and themes- to get it ready so I could open it) so it shouldn't be because the forum is too large or something like that. I use Cloudflare and disabled it after I started getting the timeout but it doesn't seem like that is the issue either. Other sites on the same domain come up fine so it's not downtime or anything. Not sure what else to do except uninstall completely and start fresh.

Edit:
I was able to find the version I'm upgrading from. It's 2.0.15.
2.1.4; default theme - curve.

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

overdue

Quote from: Kindred on February 09, 2024, 04:21:31 PMWhat version of php?

According to cPanel, it's on 8.1.

Edit:
I was able to find the version I'm upgrading from. It's 2.0.15.
2.1.4; default theme - curve.

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

overdue

Quote from: Kindred on February 09, 2024, 05:30:28 PMIf 2.0.15 is working,  then you are NOT on php8.1


Also, I don't know if the forum was actually working prior to upgrading. I just saw it needed upgrading in the cPanel and went for it. I did select the backup files options in the upgrade page but don't know how to reverse it.

Edit: Okay, I found how to reverse the upgrade via Softaculous. Going to the forum now presents a white blank page. What version of PHP do I need in order to get it to work?

Edit: Instead of downgrading PHP; I decided to back up themes and such and delete the whole board. I did a fresh install with the latest and it seems to be working. Please close this thread.
2.1.4; default theme - curve.

deansmar

That's exactly the same problem I was having today on my Wampserver (localhost)

First the PHP problem, then the database problem..

Changed the settings of the host MariaDB to accept and work with larger file..

But I am not to sure if you can do that in your cpanel (online) website..

deansmar

To get a 2.0 to work you need under 7 probably work ok with 5.6 which ist what I was using..

And if your forum was a 2.0.15, and you are trying to upgrade to 2.1.4
there is not much point in backing up your old themes..

They will probably not work with the newer version..

Kindred

Don't use Softaculous... always use our upgrader from this site
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sir Osis of Liver

2.0.15 will run fine in php 7.4, support for 8.0 was added in 2.0.19.  Would be a good idea to get the 2.0.15 forum up and running before upgrading.  It's not necessary, but will give you (and us) a better idea what you're working with.

Quote from: Kindred on February 09, 2024, 06:59:16 PMDon't use Softaculous... always use our upgrader from this site

Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

Aleksi "Lex" Kilpinen

Also also, "reversing an upgrade" is usually near impossible without reverting to a backup. So having good backups is a necessity, and if something goes wrong you should just use them to avoid creating further issues. Sometimes, the upgrader can take a long while on some servers and the "error" is simply letting you know that it's taking longer than expected, but it does not mean nothing is happening - It can pay off to just give it more time.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Advertisement: