News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

"Your settings could not be saved to Settings.php."

Started by 2FD, April 04, 2024, 06:15:12 PM

Previous topic - Next topic

2FD

So the other day I got an enigmatic error when trying to set-up my SMF, which read "Critical Error: Your settings could not be saved to Settings.php." This happened on the first (technically third) page of set-up, where you name the server, database, etc., and as much as I've searched around I haven't been able to find something that's exactly my problem. The closest I've found was problem #6061 from SMF's GitHub, but it seems to have been resolved by now (I tried finding the same line in my own copy of the file, wasn't there and it has been almost 4 years since that post after all).

I believe I am using version 2.1.4 of SMF.

Kindred

It would seem that Settings.php is not writable...
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

2FD

Quote from: Kindred on April 04, 2024, 06:40:59 PMIt would seem that Settings.php is not writable...
That doesn't seem good. Would I need to restart the installation process to move forward with the installation or is this fixable with my current installation? This is my first experience with SMF, if anyone is wondering. Totally willing to restart since I didn't get very far in the process.

Kindred

No... just correct the permissions on Settings.php and continue the installation
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

2FD

Quote from: Kindred on April 04, 2024, 11:27:32 PMNo... just correct the permissions on Settings.php and continue the installation
Oh alright. Say, how would I go about correcting permissions if you don't mind me asking?

Kindred

Well, that depends on how you access your file system and the settings of your host.

You may need to experiment... start with 664 or 644... only do 666 if neither of those work.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Steve

If you're using ftp, just right click the file and select properties.
DO NOT pm me for support!

2FD

Quote from: Kindred on April 05, 2024, 05:02:42 AMWell, that depends on how you access your file system and the settings of your host.

You may need to experiment... start with 664 or 644... only do 666 if neither of those work.
Well it's self hosted, so I have everything on my computer locally. If you mean file properties then I shouldn't be having a problem with permissions because I am using the Administrator account on my computer (at least theoretically).

Kindred

Oooooh, that's not good.

You should never host things on your local computer with internet access... especially since you don't seem to understand permissions configuration.

File permissions are different,  because - depending on your server software and how you have configured it, smf might be running as the php system... which might be system, might be admin, might a defined user, or might even be "nobody" (if you have really screwed up configuration)
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

2FD

If you're think what I believe you are, then what I meant by "local" was I am using a separate computer I own myself to host, not the computer I am using to post on this thread with. If you're worried about that specifically, then don't be. But that's besides the point.

The server right now is offline, and I will certainly be looking into the permissions I have set.

Kindred

Well, that is marginally better...  but self-hosting should only be done  if you understand server software and hardware...

That's why companies have dedicated infrastructure teams whose job it is to make any externally accessible system secure and configured correctly.

But, that's neither here nor there for your actual problem.
As indicated by the error message -- however you have your system configured,  your Settings.php in not currently writable by the php system -- and while it can be set to be unwritable AFTER configuration,  it needs to be writable for first setup.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: