News:

SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

cron job error

Started by puravida47, April 22, 2024, 10:49:17 AM

Previous topic - Next topic

puravida47

I had several SMF sites, in past years, this is a first I cannot identify what to change.

I did a new install, everything runs smooth, however, every 24 hrs an error report.
I checked in cron and don't know where and what to change:

here are details:
admin report:
/public_html/Sources/Subs.php (Line 6239)

Type of error: Cron

2: fsockopen(): Unable to connect to ssl://www.simplemachines.org:443 (Connection timed out)

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
host directory report line 6239:

      // Open the socket on the port we want...
         $fp = @fsockopen(($match[2] ? 'ssl://&#39; : '') . $match[3], empty($match[5]) ? ($match[2] ? 443 : 80) : $match[5], $err, $err, 5);

<<<<<<<<<<<<<<<<<<<<<<<<

appreciate any advise

shawnb61

That looks like your mail is unavailable during that time.  Server maintenance?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

puravida47

all my mail for several domain on this server (dedicated) are working. members sign up, and emails confirm, all sent.  It's only for this cron job once a day every day.

shawnb61

Same time?  If so, check with your host to see if it is a maintenance window.

"Unable to connect" is a pretty strong indicator the mail service was down, even if only briefly.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

puravida47

Different hrs, between 5 and 7 a.m.
I sent ticket to host and will update here.

thanks

puravida47

My host replied, and after their review, they made some adjustments for the firewall for that domain website.
So I will see in the morning if another error log or not, and will post result here.

thanks for help

puravida47

Looks problem solved by Hosting company.
Since they adjusted the Firewall, no more errors.

thanks for your help here.
I just installed another forum and same issue with the cron. So I will get the host to adjust my account for that domain too.  They have some settings tight, and they ate always on it when I ask them.

StrykerX

Quote from: puravida47 on April 23, 2024, 06:48:52 PMLooks problem solved by Hosting company.
Since they adjusted the Firewall, no more errors.

thanks for your help here.
I just installed another forum and same issue with the cron. So I will get the host to adjust my account for that domain too.  They have some settings tight, and they ate always on it when I ask them.

Can you please ask them/show what they changed? Having the same issue on a self managed server.

puravida47

Quote from: StrykerX on May 21, 2024, 08:38:32 PM
Quote from: puravida47 on April 23, 2024, 06:48:52 PMLooks problem solved by Hosting company.
Since they adjusted the Firewall, no more errors.

thanks for your help here.
I just installed another forum and same issue with the cron. So I will get the host to adjust my account for that domain too.  They have some settings tight, and they ate always on it when I ask them.

Can you please ask them/show what they changed? Having the same issue on a self managed server.

Sorry, was not here for few weeks, was working on my NFT places.  I ask them, and they did not tell me what the tech settings changed.  Possibly to "long" ago that I asked now.  sorry.

Advertisement: