News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Currently 1.1.4 trying to migrate to 2.1x Major issues. Need help.

Started by GhostRider2110, June 09, 2024, 07:34:44 PM

Previous topic - Next topic

GhostRider2110

Ok, here's the story. Yes, I know all my own doing by not upgrading until now.  The current system is running
SMF 1.1.4
PHP 5.6
Mysql 8.0.37

Which does run, but trying to update it is, well being problematic. Running on RHEL 7.9, which needs to go as well, thus the need to move to new server. :)

So I started with trying to migrate the current to the new server.  Figured move it over, then run updates.  Yes, running into the same issues others with the mysql mysqli function issues.  The new server is running:
PHP 7.4
Mariadb 10

I imported the backup into the new VPS. No the site would not come up at all, but repair_settings.php would so I could make sure all was good on the basic level.  The upgrade.php would just stop, early on and had to rely on the php logs to troubleshoot.

Tried the 2.0.18 upgrade zip and go to a point where getting this error:
[root@vps2 public_html]# /usr/bin/php74 -f upgrade.php -- --debug --backup
PHP Deprecated:  Array and string offset access syntax with curly braces is deprecated in /home/stevenso/public_html/Sources/QueryString.php on line 409
PHP Deprecated:  Function create_function() is deprecated in /home/stevenso/public_html/upgrade.php on line 141
 * Updating Settings.php... Successful.
 *
 +++ Backing up "attachments"...Unsuccessful!  MySQL error message:
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'TYPE=MyISAM
                                SELECT *
                                FROM smf_attachments' at line 5


So, I decided to go back to the original 1.1.4 and try to do minor updates, like 1.1.4 to 1.1.5 from the command line. Well running in to the same thing. 

[root@ip-xxx-xxx-xxx-xxx public_html]# /usr/local/bin/ea-php56 -f upgrade.php -- --debug --backup
 * Updating Settings.php... Successful.
 *
 +++ Backing up "attachments"...Unsuccessful!  MySQL error message:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM
                                SELECT *
                                FROM smf_attachments' at line 5
[root@ip-xxx-xxx-xxx-xxx public_html]#

Any advice would be greatly appreciated. 

Thanks
Mitch

Mitchell Baker
--------------------
CoffeeCup Software Ambassador
Get 20% Off CoffeeCup Web Design Software
Use this code when you checkout: 226STS
--------------------
www.getcoffeecup.com

Kindred

Upgrade to 2.0.19
Don't bother with the 1.1 incremental. That's a waste of effort.

Then Upgrade to 2.1.4
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

GhostRider2110

Should I try it on the new VPS I'm trying to migrate to?  Or on the original (after backups of course LOL )

Thanks
Mitch
Mitchell Baker
--------------------
CoffeeCup Software Ambassador
Get 20% Off CoffeeCup Web Design Software
Use this code when you checkout: 226STS
--------------------
www.getcoffeecup.com

GhostRider2110

That seemed have done the trick.  Command line updated the original site, the moved it to new server and that seems to have worked.  Thanks.  Now just have to figure out how to get my SMG data into something else, LOL..

Later
Mitch
Mitchell Baker
--------------------
CoffeeCup Software Ambassador
Get 20% Off CoffeeCup Web Design Software
Use this code when you checkout: 226STS
--------------------
www.getcoffeecup.com

Advertisement: