Advertisement:

Author Topic: Getting this error when I try and update  (Read 10301 times)

Offline Aaron Nelsen

  • Jr. Member
  • **
  • Posts: 113
  • Gender: Male
    • Hijinks Inc.
Getting this error when I try and update
« on: March 14, 2004, 01:20:32 AM »
When I run Upgrade.php I get this error before it even starts the upgrade.

Quote
The upgrader was unable to find language files for the language you have specified.
SMF will not work without the primary language files installed. Please either install them, or use english instead.


Offline Tyris

  • Sophist Member
  • *****
  • Posts: 1,306
  • Gender: Male
    • Shana Project
Re: Getting this error when I try and update
« Reply #1 on: March 14, 2004, 01:32:03 AM »
yeah, it this error initially too... if you re-dl the package, and just upload the upgrade.php it should fix it (I think)...

Offline Aaron Nelsen

  • Jr. Member
  • **
  • Posts: 113
  • Gender: Male
    • Hijinks Inc.
Re: Getting this error when I try and update
« Reply #2 on: March 14, 2004, 01:32:33 AM »
Thanks, I'll give it a try.

Offline b0$$

  • Semi-Newbie
  • *
  • Posts: 41
  • Gender: Male
  • west side!
    • The C-Walk
Re: Getting this error when I try and update
« Reply #3 on: March 14, 2004, 02:03:53 AM »
that did nothing for me on my test board forum...

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Getting this error when I try and update
« Reply #4 on: March 14, 2004, 02:10:03 AM »
If you are getting this exact error message, the fastest way to solve it is to edit Settings.php and change this:

$language = "something.lng";

To this:

$language = 'english';

However, this issue should have been solved in an update I made to the packages specifically to solve this issue and some undefined language entries.

-[Unknown]