Advertisement:

Author Topic: Message: "Notice: ob_end_flush(): failed to delete and flush buffer. No buf ...  (Read 17973 times)

Offline martp

  • Semi-Newbie
  • *
  • Posts: 57
Hi there! I upgraded from Yabb-se 1.5.5 to smf. Install-progress seemed fine, but i get the following error-message at the bottom of the board:
Notice: ob_end_flush(): failed to delete and flush buffer. No buffer to delete or flush. in /home/httpd/yyyy/xxxx.de/www/yabb-se/Sources/Subs.php on line 1201
I cannot enter the admin-area, because evrytime i'm asked for my password (although i'm already logged in) and when i enter it, i get a (german) message that reads something like this (translated): "Session ran out while writing. Go back and try again."
I cannot post new topics, cannot change my profile, evrytime i get the same error.
Anybody has a clue?
Thanks!

Oh! Just tried the "help"-menu of my board:
Notice: Undefined index: help_pm_name in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 75
Notice: Undefined index: help_pm_title in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 75
Notice: Undefined index: help_pm_name in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 77
Notice: Undefined offset: 0 in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 91
Notice: Undefined index: help_section_ in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 104
Warning: Invalid argument supplied for foreach() in /home/httpd/mplass/art-up.de/www/yabb-se/Sources/Help.php on line 107

Warning: Invalid argument supplied for foreach() in /home/httpd/mplass/art-up.de/www/yabb-se/Themes/default/Help.template.php on line 88

Something seems to be not working well, I assume?  ;)
I have no clue.
« Last Edit: March 15, 2004, 03:46:27 AM by martp »

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Can you post a link?

Also, try finding this in Subs.php and totally removing it:
Code: [Select]
// So long, and thanks for all the fish!
@ob_end_flush();
if (!empty($modSettings['enableCompressedOutput']))
@ob_end_flush();

-[Unknown]

Offline martp

  • Semi-Newbie
  • *
  • Posts: 57
Thanks for answering. Here's the link:
http://www.art-up.de/yabb-se/

I deleted the lines in sub.php and now the strange Message is gone. But still i cannot even log out!
Help would be appreciated, since i didnt make it to go back to yabb-se1.5.5

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Sessions do not seem to be working properly on your server.

-[Unknown]

Offline martp

  • Semi-Newbie
  • *
  • Posts: 57
But yabb-se worked fine on this server. Is there anything that has to be changed for smf?

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
I don't know what to tell you.  Your session information is not properly being saved.

It is stored by and with PHP.  All settings for it are in php.ini.  It should work unless your host has configured something wrongly.

-[Unknown]

Offline martp

  • Semi-Newbie
  • *
  • Posts: 57
Problem solved!
« Reply #6 on: March 17, 2004, 04:56:56 PM »
Right! My provider checked it and changed something to do with the session-data storage. It works! And I love it! Great job, good service! Thank you very much :D
M.