• Welcome to Simple Machines Community Forum. Please login or sign up.
October 20, 2021, 04:19:59 AM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Custom Profile Field Mod

Started by winrules, March 30, 2006, 02:21:25 PM

Previous topic - Next topic

Kindred

holy moly!

Upgrade to smf 1.1.2 immediately.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Davey D.

Quote from: GJ-tje on March 12, 2007, 12:55:10 PM
Quote from: davidkirk on March 12, 2007, 12:26:48 PM
Reply #1013 - any help here?
Referring to posts doesn't help with your problem.
Most users don't check back te pages to find post #1013... ;)

Maybe you can explain your problem once again?
Have you did somethings on own initiative? If you've allready tried something, we don'thave to suggest those answers, because you've already tried!

I appreciate someone taking the time to at least offer to help. I have now posted the same question five times (really). I have been asked to repeat it three times now. This is why I keep referring to old post, so as not to retype the whole topic. I will try yet again.

I have installed this MOD, but I need to know how to move the created field(s) under the "Username" field. I want my registration page to flow and not have people entering, or forgetting to enter, information below the CAPTCHA field.

Help please...

mancio

Sorry for my english.

I have a problem with this mod (Custom Profile Field Mod 3.16)

I use the SMF forum vers 1.1.2
Template use: SAF-ORANGE

Then i install this mod all is perfect but i would configurate this mod in PREFERENCES and OPTION setting i don't see the LINK!!!

I try re-install this mod... but it is not changed null.

HELP ME
thaks
Mancio

Kindred

davidkirk,

Edit the register.template.php file to move the display of the custom fields up....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Davey D.

It's no secret I will probably never be an expert at this stuff, so could I get a weee bit more help? Exactly what am I looking for to move within the 709 lines of code in the "register.template.php" file?

GJ-tje

Quote from: mancio on March 13, 2007, 06:42:37 AM
Sorry for my english.

I have a problem with this mod (Custom Profile Field Mod 3.16)

I use the SMF forum vers 1.1.2
Template use: SAF-ORANGE

Then i install this mod all is perfect but i would configurate this mod in PREFERENCES and OPTION setting i don't see the LINK!!!

I try re-install this mod... but it is not changed null.

HELP ME
thaks
Mancio
Have you tried to set your language in English?
I can only use this mod if I set my language setting to English!
"People cannot gain anything without sacrificing something of equal value.
To obtain, something of equal value must be lost.
That is alchemy's first law of Equivalent Exchange."

"People should not be afraid of their Goverments. Goverments should be afraid of their People."

Kindred

ah....  for other languages, you will have to manually add the text strings in modifications.YOURLANGUAGE.php

(in other words, open modifications.english.php, copy out the text strings for this mod, paste them into the modifications.YOURLANGUAGE.php file and edit them into your langauge.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

paulthai

Quote from: paulthai on March 12, 2007, 12:14:21 PM
How can I get the information creating by Custom Profile Field?

Such as, the value of field CP1

Please show me the code....

I try by created the ssi_showprofiles in SSI.php.

Thank you....


function ssi_getprofiles()
{
global $context, $settings, $options, $scripturl, $modSettings, $txt , $sourcedir;

require_once($sourcedir . '/CustomProfile.php');


for ($i = 1; $i < 21; $i++)
{

             // This try to show the custom Profile Field.
echo ' ' . $modSettings['CP' . $i . '_name'] . ': ' . $modSettings['CP' . $i . '_???????] .  '<br>';

}



}


Help me Please.......

onfulltilt

I've just installed SMF 1.1.2., it seems to be working just fine.  Now I've installed the Custom Profile mod and according to all the tests that SMF ran, the install was successful (no error messages) however, the control panel does not show up (under Features and Options) for this mod.

I am currently using the default theme.

On what may be a related side note, I've also tried to install the Ad Management mod and that one also seems to install correctly but does not display the link to the control panel (altough it does make an extra space for it in Configuration section, but no text).

Any idea about why I can't seem to add mods?  I have not been using SMF for very long so hopefully there is a relatively easy solution to these issues.

Thanks in advance for any help.

Kindred

1- are you using english?
2- did the mod really intall the text strings in modifications.english.php?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

onfulltilt

Yes I am using English (at least everything appears to be in English).  I'm not really sure if the modifications.english.php file was really modified as I'm not sure where it is.  This was pretty much a straight forward install of SMF.

naitram

look at your error log in the admin section

onfulltilt

I just checked the error logs.  I'm getting a bunch of errors.  Here's a sample:

8: Undefined index: ad_management
File: /home/docaa/public_html/Sources/Subs.php
Line: 2738

Unable to load the 'Ads.english-utf8' language file.

8: Undefined index: cp_cpfields
File: /home/docaa/public_html/Sources/ModSettings.php
Line: 142

Unable to load the 'CustomProfile.english-utf8' language file.

Does this shed any light on things?

Davey D.

Quote from: Kindred on March 13, 2007, 09:28:59 AM
davidkirk,

Edit the register.template.php file to move the display of the custom fields up....

Exactly what am I changing in this file???

Jeesh...I can't believe I have been asking the same question (basically) since January 23rd.  My original post, #835 is here. If I am doing something wrong please let me know so I can post this question somewhere else.

naitram

Quote from: onfulltilt on March 14, 2007, 02:24:05 PM
I just checked the error logs.  I'm getting a bunch of errors.  Here's a sample:

8: Undefined index: ad_management
File: /home/docaa/public_html/Sources/Subs.php
Line: 2738

Unable to load the 'Ads.english-utf8' language file.

8: Undefined index: cp_cpfields
File: /home/docaa/public_html/Sources/ModSettings.php
Line: 142

Unable to load the 'CustomProfile.english-utf8' language file.

Does this shed any light on things?

sounds like the mod never installed completely

Kindred

ah....  actually, it looks like both of those mods may have problems with a forum that uses english but installed as utf-8

Davekirk...

Apparently you have not been asking the right questions...   
You asked, is it possible? (answered: yes)
You asked: What do I do? (answered, edit register.template.php)
I merely assumed that you would be able to move the small block of code into the desired location...

What you should have asked the first time was
"Can someone please edit the code for me in register.template.php and send me the updated code to move the display of custom profile fields to a location under the existing "name" field"


The answer is:

move/remove

global $sourcedir;
require_once($sourcedir . '/CustomProfile.php');
RegistrationFields();

into the middle of this code:

<tr>
<td width="40%">
<b>', $txt[98], ':</b>
<div class="smalltext">', $txt[520], '</div>
</td>
<td>
<input type="text" name="user" size="20" tabindex="', $context['tabindex']++, '" maxlength="25" />
</td>
</tr><tr>
<td width="40%">
<b>', $txt[69], ':</b>
<div class="smalltext">', $txt[679], '</div>
</td>
<td>
<input type="text" name="email" size="30" tabindex="', $context['tabindex']++, '" />';


and change that to:

<tr>
<td width="40%">
<b>', $txt[98], ':</b>
<div class="smalltext">', $txt[520], '</div>
</td>
<td>
<input type="text" name="user" size="20" tabindex="', $context['tabindex']++, '" maxlength="25" />
</td>
</tr><tr>';
global $sourcedir;
require_once($sourcedir . '/CustomProfile.php');
RegistrationFields();
echo '
<td width="40%">
<b>', $txt[69], ':</b>
<div class="smalltext">', $txt[679], '</div>
</td>
<td>
<input type="text" name="email" size="30" tabindex="', $context['tabindex']++, '" />';

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Perfektionist

March 14, 2007, 05:51:14 PM #1056 Last Edit: March 14, 2007, 06:05:56 PM by Perfektionist
Thanks a lot for that coding! Like Davekirk I've been looking for a solution to that problem.

But one more problem:

If you enter the username and then hit the tab key to proceed to the next field, the cursor skips those fields created with custom profile mod and goes directly to the e-mail-field.

Any suggestion how to solve this?

Thanks and regards,
Michael

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

onfulltilt

Quote from: naitram on March 14, 2007, 02:49:20 PM

sounds like the mod never installed completely

Any reason why none of the mods I'm trying to insall end up installing correctly?  Perhaps an easy fix?

naitram

could be a permissions thing. you need to look at the error log right after trying to install the mod

Advertisement: