• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 12:42:45 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Custom Profile Field Mod

Started by winrules, March 30, 2006, 02:21:25 PM

Previous topic - Next topic

LBizGrl

YEAh...HOPE I did it right...LOL...

I went into the actual file and simply took out the UTF-8  part, saves and ftp'd back to site. I can see the tab now and add a field. :)
Smile! :)

It burns WAY more calories than a frown!

barclaymd

Sorry if this is not the way I am to communicate about the mod. It is great. Something happened and now the custom profile is present at registration as it should be; however, even though to enter the profile data, the data never makes it to the database and the fiels are blank in the profile section for the member, older data is there but nothing after the 46th member.

Any help is appreciated.

Thanks,

Mark

[SiNaN]

Is it an admin-edit-only field? The behavior for those fields on registration was changed with 3.20 version. Non-admins are no longer able to save admin-edit-only field data, even on registration. If you want to revert that behavior for registration:

Sources/CustomProfile.php

Code (Find) Select
(!empty($modSettings['CP' . $i . '_edit']) || empty($modSettings['enable_CP' . $i . '']))

Code (Replace) Select
empty($modSettings['enable_CP' . $i . ''])
Former SMF Core Developer | My Mods | SimplePortal

zonalslim

Help needed please


Hi all

I have installed the custom profile field mod by winrules

I have set a field up so that members have to put in their postal town on registration.

The problem is that yes it does make you put it in to register but when you go to approve the member the field does not show?
If I then look at their profile the custom box is empty.

I have set all the setting but it does not seem to transfer the information from the registration to their profile.

Any help would be greatly appreciated.

Cliff

Flapman

June 22, 2010, 09:32:32 AM #2964 Last Edit: June 22, 2010, 09:36:18 AM by Flapman
Hiya,

I tried to install this mod on SMF 1.1.11 and got one error:

1.    Execute Modification    ./Sources/ModSettings.php    Test failed
2.    Execute Modification    ./Themes/default/Profile.template.php    Test successful
3.    Execute Modification    ./Themes/default/Display.template.php    Test successful
4.    Execute Modification    ./Themes/default/PersonalMessage.template.php    Test successful


The mods I have are here:

1.     Anti-Spam Verification Questions      1.02      
2.    New In Topic View    1.1    
3.    Advanced Contact Form    1.1    
4.    Aeva ~ Auto-Embed Video & Audio    5.1.28    
5.    Auto Email Inactive Users    1.7    
6.    Bookmarks    2.2.1    
7.    SMF 1.0.16 / 1.1.8 Update    1.0    
8.    SMF 1.0.16 / 1.1.8 Update    1.0    
9.    New RSS Button Per Board    1.0    
10.    Enhanced Profile Header    1.0    
11.    Social Bookmarks    1.1    
12.    Google Talk Field    1.0.6    
13.    Custom Copyright    1.1    
14.    SMF File Manager    2.1.3    
15.    Colorize Boards    3.0    
16.    ColorizePost    1.2    
17.    vMulticolor-Stars Mod    1.00    
18.    SMF 1.0.19 / 1.1.11 Update    1.0    
19.    Use color Tags in code Mod    1.0    
20.    Color And BgColor BBCode Bar    3.3.1    
21.    SMF 1.0.17 / 1.1.9 / 2.0 RC1 Update    1.0    
22.    SMF 1.0.18 / 1.1.10 / 2.0 RC1-2 Update    1.0    
23.    Enhanced PM Warning Message    1.0    
24.    Active Users Privacy    0.1    
25.    Child Dropdown for Board Index    1.1
26.    Ad Managment    2.3    
27.    Twitter and Facebook Publisher mod    2.4    
28.    RSS Feeder    1.1.4    
29.    Custom Profile Field Mod    3.20    
30.    RSS Feed Poster    2.1    
Avatar Packages
   Mod Name    Version    
1.    game avatars    1.0    
2.    Sci-Fi Avatars    1.0    
3.    183 High Quality Sci-Fi and Fantasy Avatars    1.0    
4.    3D ART Avatars    1.1

Kindred

as with any mod... a failed file just means that you will have to manually add the code to that file
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Flapman

Hiya Kindred,

So I just need to modify the Source file?

Thanks in advance,

A

Quote from: Kindred on June 22, 2010, 12:48:41 PM
as with any mod... a failed file just means that you will have to manually add the code to that file

~DS~

Quote from: Flapman on June 22, 2010, 01:14:03 PM
Hiya Kindred,

So I just need to modify the Source file?

Thanks in advance,

A

Quote from: Kindred on June 22, 2010, 12:48:41 PM
as with any mod... a failed file just means that you will have to manually add the code to that file
Yes in ModSettings.php
"There is no god, and that's the simple truth. If every trace of any single religion were wiped out and nothing were passed on, it would never be created exactly that way again. There might be some other nonsense in its place, but not that exact nonsense. If all of science were wiped out, it would still be true and someone would find a way to figure it all out again."
~Penn Jillette – God, NO! – 2011

barclaymd

I am using RC2 and I can not find how to add Custom Profile Fields. I had a mod in the previous ver. but I ws told that RC2 had that feature built in?

Thanks

staticmind

Can someone tell me if this will work properly in 1.1.11? I have installed and activated it, but after doing so my Features and Settings admin page will not load at all.

Crystaltears83

August 10, 2010, 06:26:27 PM #2970 Last Edit: August 10, 2010, 07:07:09 PM by Crystaltears83
Hey there. I used the parse instructions for smf 1.1.11 During install my only error was the test failed on the modsettings.php file... so I went through, very carefully changed what the parse instructions said to change... and when I got finished, I tried to load the features and settings page... got this error:

Parse error: syntax error, unexpected T_DOUBLE_ARROW in /home/s043eri/public_html/forum/Sources/ModSettings.php on line 126

Installed Mods:


1.     Custom Profile Field Mod                                           3.20
2.    Hide Unused Profile Display Fields                                    1.0
3.    Picture Signature Field                                                    1.0
4.    Moderator and Administrator Comment Tags                   1.8
5.    The Rules                                                                    1.3
6.    Bakers Dozen Pages                                                        1.2   
7.    Menu Buttons                                                                    1.1
8.    Auto Refresh Who Index                                                  1.0
9.    Member Notepad                                                            1.0
10.    Treasury                                                                          1.04
11.    Ultimate Profile                                                         0.9.1
12.    Admin Notepad                                                         2.0.1
13.    Signature Dropdown Choices                                          1.2
14.    SMF Staff Page                                                            1.7


I am using the KozaKelebegi.zip theme.

Not sure what files you need so including what I hope will help below.


Update: Figured it out.

How the parse info said to put it:
    $subActions = array(
        'basic' => 'ModifyBasicSettings',
        'layout' => 'ModifyLayoutSettings',
        'karma' => 'ModifyKarmaSettings',
        'ultprofile' => 'ModifyUltProfileSettings',
       
    );

    $subActions['pages'] = 'ModifyDozenPagesSettings';

    $subActions['rules'] = 'ModifyRulesSettings';

'profile' => 'ModifyProfileSettings'

);

   // By default do the basic settings.




How it should have been:
    $subActions = array(
        'basic' => 'ModifyBasicSettings',
        'layout' => 'ModifyLayoutSettings',
        'karma' => 'ModifyKarmaSettings',
        'ultprofile' => 'ModifyUltProfileSettings',
        'profile' => 'ModifyProfileSettings'
    );

    $subActions['pages'] = 'ModifyDozenPagesSettings';

    $subActions['rules'] = 'ModifyRulesSettings';

   // By default do the basic settings.

hcfwesker

Quote from: [SiNaN] on May 29, 2010, 05:37:43 AM
Is it an admin-edit-only field? The behavior for those fields on registration was changed with 3.20 version. Non-admins are no longer able to save admin-edit-only field data, even on registration. If you want to revert that behavior for registration:

Sources/CustomProfile.php

Code (Find) Select
(!empty($modSettings['CP' . $i . '_edit']) || empty($modSettings['enable_CP' . $i . '']))

Code (Replace) Select
empty($modSettings['enable_CP' . $i . ''])

I'm not sure if that would answer my question, but here it goes ....

I have some custom fields that are set to "admin only" to edit.  Is there any way to add additional member groups to these particular fields to allow other staff, besides the Admin group to modify as well?


betzy

QuoteVersion Information:
Forum version: SMF 1.1.11
Current SMF version: SMF 1.1.11
hello guys, no error here ... it works like a charm, but i have one question:
what file i have to edit to autogenerate the custom fields ( name & value ) in table cell like in this photo

Jbilderbeek

September 19, 2010, 01:33:57 PM #2973 Last Edit: September 20, 2010, 11:53:03 AM by Jbilderbeek
Hello,
I've been trying for hours to get this mod working!
First tried the normal installation but had no result (and no errors).
Just tried to manually edit all files, but still no change, I just don't get the extra tab for the options (and no errors).

Please help me out! What do I do wrong?

Kind regards!


EDIT: Using SMF 1.1.11
Theme: Altar_111v2
No other Mods installed

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jbilderbeek

Using SMF 1.1.11
Theme: Altar_111v2
No other Mods installed



Kindred

so, with 1.1.x and a non-default theme, you will have to manually install the mod into the additional theme(s)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jbilderbeek

Allright...I tried the manual installation guide...do I have to copy those files to the theme folder?

Kindred

no, you have to manually edit the template files that are already IN your custom theme folder.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

immo_we

I know I'm not the only one but it seems to be different. I solved the install isues in modifications.php and created an english utf-8 language file. but now I stick on the following case.

I can add a custom profile field. It is always unnamed. If I change the name and try to save the foillowing errors occurs:

8: Undefined index: pm_posts_verification
8: Undefined index: max_pm_recipients
8: Undefined index: pm_posts_per_hour
File: <removed by immo>/forum/Sources/ModSettings.php
Line: 291

I dont know how to solve. Could please anybody give me a hint ?

List of installed plugins:

1.     Manage Members Membergroups     1.0.0     [ Uninstall ]
2.    Additional Membergroups on Profile    1.0    [ Uninstall ]
3.    Language Drop    1.5.1    [ Uninstall ]
4.    Gallery 2 Integration    1.0 RC1    [ Uninstall ]
5.    Timezone Select    1.1.2    [ Uninstall ]
6.    Custom Action Mod    2.04    [ Uninstall ]
7.    Add Honey Pot to Track IP    1.1    [ Uninstall ]
8.    httpBL    2.3.4    [ Uninstall ]
9.    Default Membergroup on Registration    1.1    [ Uninstall ]
10.    Custom Profile Field Mod    3.20    [ Uninstall ]



Advertisement: