Advertisement:

Author Topic: Arcane Magic  (Read 23849 times)

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Arcane Magic
« on: April 18, 2006, 10:02:32 AM »
Link to the theme


This theme was actually designed with the MKPortal User in mind as it matches the Portal skin actarus medievil magic.  It is however, a very nice medieval theme for smf.  This was modified with permission from neisianstyles.

The themesite has additional images to see what it looks like.
« Last Edit: April 18, 2006, 08:22:50 PM by technodragon73 »
Don't tell me to get into shape...I have a shape...It is round!


Offline CyberSongs

  • Semi-Newbie
  • *
  • Posts: 46
    • Music
Re: Arcane Magic
« Reply #1 on: April 19, 2006, 06:02:29 PM »
This theme did not install correctly.  First the two specs for URL's and Images went to the wrong place, one directory up, then, it didn't like it when those paths were changed.

This does seem to be a common problem among themes.

You have to manually change the paths in modify the theme, but then this can result in lost links and images too.

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #2 on: April 20, 2006, 01:38:47 AM »
could you tell me what link references?  This is the first time I have ever heard of this and  Iwould like to take a look to see if I can fix it so noone else has this issue.
This theme did not install correctly.  First the two specs for URL's and Images went to the wrong place, one directory up, then, it didn't like it when those paths were changed.

This does seem to be a common problem among themes.

You have to manually change the paths in modify the theme, but then this can result in lost links and images too.


could you tell me what link references?  This is the first time I have ever heard of this and  Iwould like to take a look to see if I can fix it so noone else has this issue.
Don't tell me to get into shape...I have a shape...It is round!


Offline DrP3cker

  • Semi-Newbie
  • *
  • Posts: 23
Re: Arcane Magic
« Reply #3 on: May 29, 2006, 09:02:26 PM »
Edit: Wrong thread :|

Not sure how that happened.

Offline ArkServer

  • SMF Hero
  • ******
  • Posts: 1,831
  • My posts are my own
    • BlushyFace | A spoopy and creppy site
Re: Arcane Magic
« Reply #4 on: May 31, 2006, 02:41:45 PM »
Demo?

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #5 on: June 01, 2006, 12:22:20 AM »
unfortunately not for this one...i do not have it installed at my forum (had to cut down on the nuimber of themes that were available)

The theme page for this theme has twoo really big screen shots of it though.

Unless someone has this installed and would like to provide a link for others to see it.
Don't tell me to get into shape...I have a shape...It is round!


Offline ivanlexbert

  • Newbie
  • *
  • Posts: 1
Re: Arcane Magic
« Reply #6 on: July 26, 2006, 12:03:36 AM »
I have a dead Link of Image.
how do I remove the lines in the boards ( -------) like that.
How do I fix it and where?

Take alook at my Site pls.

hxxp:www.ivanlexbert.thesmokylounge.com/forum/index.php?board=1.0 [nonactive]

Thanks for all.. I just install it so i really need some help.  :P
« Last Edit: July 26, 2006, 12:16:46 AM by ivanlexbert »

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #7 on: July 26, 2006, 12:19:24 AM »
Best I can tell is that it is one of two problems...either the messageindex.template.php file was corrupted, or the image was corrupted.  Try downloading the SMF version from my site as I just looked it over and everything seems to be working fine with that one.
Don't tell me to get into shape...I have a shape...It is round!


Offline theunder-ground

  • Semi-Newbie
  • *
  • Posts: 39
Re: Arcane Magic
« Reply #8 on: July 30, 2006, 01:35:22 PM »
I have been working on this theme as well with the post Icons not showing even though they are uploaded and not corrupt

http://plan.jaydedsilver.us/index.php

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #9 on: July 30, 2006, 01:46:09 PM »
post the code for me from line 150 to line 175 from the messageindex.template.php if you wouldn't mind...that is where the issue is I think


EDIT:  Ok, i figured out the issue...this goes for everyone...Please make sure to notice that this theme is for RC2 ONLY...using it on another version of SMF can and will have bizzarre effects (like images not linking right)
« Last Edit: July 30, 2006, 01:53:46 PM by TechnoDragon »
Don't tell me to get into shape...I have a shape...It is round!


Offline theunder-ground

  • Semi-Newbie
  • *
  • Posts: 39
Re: Arcane Magic
« Reply #10 on: August 06, 2006, 05:51:33 PM »
Yep.  I got that figured out and have I think all of the differences fixed.

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #11 on: August 06, 2006, 09:30:30 PM »
glad to hear that...and glad you like the theme!
Don't tell me to get into shape...I have a shape...It is round!


Offline CyberSongs

  • Semi-Newbie
  • *
  • Posts: 46
    • Music
Re: Arcane Magic
« Reply #12 on: August 13, 2006, 08:09:59 PM »
TechnoDragon,

I have to apologize; I got so busy with this project {Stand Down} that everything else became secondary for quite a while.

I think my original problem as posted here was just the difference between 1.07 and the 1.1RC's.  Plus I was switching over to three new servers and four new domains, it got quite hectic.

I don't see too many problems anymore, checking the forum logs regularly.

One thing, overall, with SMF, is that if you put the theme in a directory you create, then it generally misses some images and other stuff.

I'm rechecking all of the boards now.

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #13 on: August 14, 2006, 09:31:40 AM »
Not a problem, glad to see you got everything running smoothly now.
Don't tell me to get into shape...I have a shape...It is round!


Offline amber333

  • Semi-Newbie
  • *
  • Posts: 33
  • Gender: Female
    • Order of Bahamut
Re: Arcane Magic
« Reply #14 on: October 06, 2006, 11:16:56 AM »
Ok so I'm running smf 1.0.8, and I really like this theme, is there no way to fix the dead link to the icon or the input box coloring problems previously mentioned about this theme?

My site is www.orderofbahamut.com/forums

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #15 on: October 06, 2006, 10:15:07 PM »
unfortunately i don't have a 1.08 forum for testing...all i have is rc2 and now and rc3.
Don't tell me to get into shape...I have a shape...It is round!


Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #16 on: October 29, 2006, 10:58:32 AM »
I have updated this theme to work for SMF RC3!  You can check out a demo at

http://golddragonhosting.com/smf/index.php?theme=6

and the new place to get the TP version is http://dragontalk.net
Don't tell me to get into shape...I have a shape...It is round!


Offline Verminion

  • Newbie
  • *
  • Posts: 2
Re: Arcane Magic
« Reply #17 on: March 11, 2007, 12:40:24 PM »
First of all I want to say that my friends and I really love this theme.  It has a nice color scheme and it doesn't look "ordinary".  Secondly I wanted to point out that I did find a few issues that I'll probably try to tidy up in my implementation.

1.  There are some form fields that show up with a pale white background, especially the login blanks and all the combo boxes and search fields and all the textareas in the admin area.  This wouldn't be a problem except for the very pale text on top of them.  I'm not really that old yet, but I don't like to strain my eyes so I'll probably be hunting down those and assigning a new style sheet class to them or something of that sort so that either the text is darker there or the background is no longer white.

2.  When I was playing around with the admin settings for the theme I turned off the SP1 statistics which I'm assuming should have removed the "Key Stats" box and put the stats over the forum box.  Instead it put the stats over the forum box and left the "Key Stats" box where it was essentially duplicating that info in two places.  I might not bother fixing this in my implementation but it is something someone might care about.

3.  The dashed border seems to show up in a few places I don't think it should be, like all the way at the bottom around the theme credits... and I think the search functionality at the top would look better with the same bordering as the other brown areas of the index page.

4.  I find the fonts overall to be too small but the buttons have such small text I'll probably be swapping them out in my installation.  But that's mostly a personal preference.

Offline TechnoDragon

  • Jr. Member
  • **
  • Posts: 374
  • Gender: Male
  • With great power comes great resposibility...
    • Dragon Talk Forum
Re: Arcane Magic
« Reply #18 on: March 11, 2007, 12:43:15 PM »
thank you for the feedback!  I will see what I can do to correct some of these style problems!
Don't tell me to get into shape...I have a shape...It is round!


Offline Verminion

  • Newbie
  • *
  • Posts: 2
Re: Arcane Magic
« Reply #19 on: March 11, 2007, 02:19:19 PM »
Hey, thanks for the quick response.  I found something else today while I was looking at it.  The "Enable inline links" option under the admin panel for themes does not appear to work right.  Or rather when I selected it it appended the word "Theme:" onto the last link on the path on a post I was looking at.

 The changes I've made to correct a few of these things...

removed the background-color setting from NormalText2 so the search bar floats on the swirly background.  I just think it looks better that way

Added a background color to the various form element entries in the style sheet... this makes it so the various text entry boxes now match the search box and has better contrast with the light text.

I took the dashed border off the SmallText class.  This makes the index page look a little strange, but it fixes the stray dashy borders that show up unexpectedly everywhere else.  I'm going to see if I can find another way to draw the dashed border on the date column on index.

« Last Edit: March 11, 2007, 02:57:56 PM by Verminion »