Advertisement:

Author Topic: referer.php missing in SMF 1.0 Beta 4.1 Public?  (Read 4854 times)

Offline bib

  • Newbie
  • *
  • Posts: 3
referer.php missing in SMF 1.0 Beta 4.1 Public?
« on: March 30, 2004, 08:18:47 AM »
Hello there.

I have just installed the Prog on my site for testing and all seems to be working fine, all but one strange thing. I have a 404 tracker on the site that alerts me whenever a uri is requested and does not exist; well, I haven't seen exactly when it happens but I got this notice this morning:

May wrap:

hxxp:www.sharpnet.co.uk/sm/referer.php?forum=Sharpnet+Internet+Solutions+Ltd+BB%7Chttp%3A%2F%2Fwww.sharpnet.co.uk%2Fsm%7CSMF+1.0+Beta+4.1+Public [nonactive]

Is it normal that referer.php does not appear to exist in the sm dir?

Thanks  ;)

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: referer.php missing in SMF 1.0 Beta 4.1 Public?
« Reply #1 on: March 30, 2004, 08:37:38 AM »
Blah, I'm just changing the darn copyright link to go straight.  Not worth it.

(basically, some browser is not doing the javascript right because it's dumb, or some crawler is reading things wrong.)

-[Unknown]

Offline bib

  • Newbie
  • *
  • Posts: 3
Re: referer.php missing in SMF 1.0 Beta 4.1 Public?
« Reply #2 on: March 30, 2004, 08:51:41 AM »
Hi unknown, I don't understand why this was designed like that in the first place ???

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: referer.php missing in SMF 1.0 Beta 4.1 Public?
« Reply #3 on: March 30, 2004, 09:04:09 AM »
Well, you see the copyright link says it goes to ww.simplemachines.org.  The purpose of this is that Google likes flat links better.

But if you click on it, some JavaScript code will add to the link, giving a little information.

However, the referer.php is on www.simplemachines.org.  It's http://www.simplemachines.org/referer.php - you can click that right now.

So, some browser(s) are not reading the JavaScript correctly.

-[Unknown]

Offline bib

  • Newbie
  • *
  • Posts: 3
Re: referer.php missing in SMF 1.0 Beta 4.1 Public?
« Reply #4 on: March 30, 2004, 09:15:45 AM »
I see  ;)

Well it doesn't work with Mozilla Firefox then  >:(

But I see your point.

cheers  ;)

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: referer.php missing in SMF 1.0 Beta 4.1 Public?
« Reply #5 on: March 30, 2004, 09:17:17 AM »
I see  ;)

Well it doesn't work with Mozilla Firefox then  >:(

But I see your point.

cheers  ;)


It works fine with my Mozilla Firefox :P.  But I changed it anyway.

-[Unknown]